TP-Link Kasa switches, dimmers, and outlets do not appear in new app

My entire set of TP-Link Kasa switches, dimmers, and outlets appear in the old app, but do not appear at all in the new app. Also, in the IDE, I can see them just fine. I’m working with ST support, but hoping that crowdsourcing will work better and faster!

Here’s what I’ve already tried:

(1) Removing all devices and re-adding them from the new app (I can add them from the new app but they don’t appear in the app after adding, only in the classic app and IDE)
(2) Re-registering the TP-Link account integration
(3) In the IDE, manually associating all the devices with my hub
(4) In the IDE, manually associating all the devices with a group
(5) Uninstalling both classic and new apps from my iPhone and reinstalling them (which clears cache)

Total mystery and I’m stumped! I’m hoping someone else has run into this and been clever enough to solve it.

Thanks!

Alex

Does this include removing the top-link Kasa integration (from menu > settings > linked services) and then adding it back?

No need to remove devices, just unlink the integration… then reconnect the integration by clicking + (plus) in the upper right of the dashboard, select smartapp, by brand and choose tp-link Kasa

Thanks, jkp! Unfortunately, I did try that (and just retried for good measure). I’m curious, though: you suggest adding a smartapp instead of a device to reconnect. I’m not aware of a Kasa smartapp.

There is an outage at the moment. How did you add them to the Classic app previously… by using custom device handlers?

I had to wait out the outage as well, but it’s back for me. In both old and new apps, I’ve used the official TP-Link Kasa handlers. I bought my devices after the commercial handlers were released.

Install the tp-link kasa app on your mobile device. Set up an account on their app. Add your kasa devices to it. Then all you need to do in the ST app is link the kasa account through their integration and all your kasa devices will populate to the ST app. After tHe outage of course.

Just redid the full setup but still no dice. I did everything via the Kasa app, then added one device (which actually adds all of them) via the new ST app. Still: in the old app, I see the devices (but can’t automate them since I’ve migrated my location). In the new app, I see zilch. Fascinating and frustrating!

And thank you for all the help thus far!

Time to call or email ST support and hope they can assist. A very strange issue you have.

One thing to try… wait a bit and go to menu > settings > linked services and open the kasa integration and simply click through it and see if they appear.

Oh, also contact kasa support and see if they can assist, they own and manage the integration. There have been some instances in the past where it took a few hours for devices to appear but strange you only see tHem in tHe Classic app.

Have you looked under menu > devices?

Will do, and will report back when/if anything works! I’m chasing ghosts.

Support tickets submitted and again many, many thanks for the assistance @jkp!

For a little more weird humor value, the devices appear in the linked service device list in the new app, but still not in the list of devices at the app level.

under menu > devices?

@totoro buy any chance are using a tp kasa spot camera & if so does it appear in smartthings.

the integration only lists supported devices for lighting, outlets and switches/dimmers

1 Like

Dominick, thanks for the idea. But I’m only using outlets, switches, and dimmers.

Yes, that’s correct, under menu > devices.

1 Like