Tp link 100 issues

Guys i have an oddity with tp link 100 wifi sockets, evertime one is plugged in at home here my whole wifi network crashes. The only resolution to return back to normal is un plug the tp link and reset my router.
Im baffled you guys have any thoughts ?

Four items:

Research, Troubleshoot, Contact, Replace

Research: First, complete some basic research. Read through the TP-LInk HS100 link below.

Then look at this post (may be same problem) in different words:

Also, browse for similar problems, if you have time (not as high a priority): This is the HS-100 forum. You will be looking for very similar topics.

Troubleshoot: As far as troubleshooting before you contact TP-LInk, you want to go down to minimum and build back up. the below is an example. It will take about 15 - 30 minutes, but should isolate where the problem is.


  1. Device has been installed into the KASA app and is still installed.
  2. The device worked properly at one time and the problem has started recently.

Troubleshoot 1. If you have another HS-100, plug it into the same location and see what happens. If there is a failure, then some other device is causing the problem.

Troubleshoot 2. For this device, RELOCATE it in a plug in another room. If it works, it is some other device causing the problem (try several locations).

Troubleshoot 3. If neither of the above bore fruit, the steps below should isolate the problem to the plug, Kasa - plug interaction, or other plug interaction. Steps:

a. Disable remote control in the KASA app for the device.

b. Disable any SmartThings connections or any other means used to control the bulb.

c. Turn off your phone or disable the Kasa app in the phone. Also turn WiFi off on your phone.

d. Plug the device back in and check network functionality (speed test, etc). If fails, you can tell TP-Link that Kasa and other control points were disabled plugging the device in was the causative factor in the newtork failure… It may be under warranty.

e. Turn on your phone and enable the Kasa App. Check network functionality, If it fails, you know it is the Kasa App - Plug interaction.

f. Turn on Remote Control in the Kasa App. Then turn off your phone’s wifi Try to control the device via the SmartPhone (no wifi). If it fails, again, you know it is the likely the Kasa Cloud to Plug interaction.

g. Update the firmware via the Kasa App. This is just a good idea.

h. Start adding other connections (smartthings, bridge, other control integrations you may have). Failure indicated the problem is at that interaction.

Contact: If the fault is in the plug or the plug - KASA App interfaces, contact TP-Link for advice (and return)

Replace:. (US) The HS100 is $30 on Amazon and the HS105 is $25. These are relatively good prices. I have both - but prefer the HS100 since it takes less real-estate.

Thanks Dave, a comprehensive list indeed thank you

I had already done the basics but was unable to resolve the issue properly so i reset the plugs and selected a secondary wifi i run at home for back up from an older router… perfect worked without issues and no crashes from the main router

The main router must have some issues me thinks with firmware, this is the second wifi item that should work on the main router but has caused issues, i am not a fw expert and really do not want to go down that rabbit hole, thank you for your list it was most comprehensive

Same thing happened to me but seemed bc I used too many of them. I have a dual band router and everything I use wirelessly is on 5ghz bc my security camera wreaks havoc on 2.4ghz (basically causes a jamming issue bc of the camera ap’s). Well I bought the 2 pack and then purchased 2 more for a total of 6. Now the night I had them all in it seemed fine. but the next night I started losing Wi-Fi connection on virtually everything which also included my 5 gigahertz. I power cycle the router about three different times to no avail. finally I reset the router with the smart plugs out of the wall’s at that point after I reset the router, it was back to normal. needless to say the plugs were the common denominator for the problem. to the girl at Walmart’s technology department, she was spot-on when she warned me about these plugs. she did say that too many of them can actually cause problems and damned if she wasn’t right.anyway I returned two packs of them and going to keep one pack but I can’t afford to be plugging these things all throughout the house. if anyone can give details as to why this would be happening please let me know. I don’t see a problem with having six additional individual devices that would carry an IP address of their own and cause that kind of a problem.