Time based events failing?

true. I did unplug, but only for a minute… I’ll try that now!

Ok, So I unplugged the hub and waited a while… plugged it back in, got the green light…

and well, everything is working now.

I had to cycle some lights and some contact sensors, but they are all up and running.

I’m sure it won’t last, but I’m going to hope it does.

Thanks… i wasn’t leaving it unplugged for long enough.

2 Likes

2 Likes

So my sunset automation that has been failing did run tonight. And still shows blank for the next schedule.

My run at 7 AM automation does have a pending schedule. We’ll see if it runs in the morning, and more interestingly, whether the sunset automation runs tomorrow night.

This is what.pisses off. I reported this problem days ago right after the maintenance . Support just got back to wanting to.help me run a repair
It is one thing if they acknowledged the issue and gave usefull info. Totally.another to pontificate … it as if they are in Another universe.

I think to report an issue in this thread now, one should have pulled the plug on their hub for 15 minutes, plugged back in, and then had a timed event fail. I say this only because I am observing people having success now doing this step in other threads.

Detail:

  1. @slagle post about reboot
  2. I believe the 15 minute sleep rebuilds zigbee network (not sure about zwave). I’m not sure what this would have to do with timing at all…
  3. I don’t know if the folks having success also have to also “reset” apps that use times too, or if the hub sleep/reboot fixes it.
  4. My personal experience is that I only had two timing issues, and all I did was reset those two items (one was a reset SmartApp, and one was my sunrise routine) and they have worked fine since. I have not had to reboot my hub at all, in fact it’s been up since I installed it, not been off once.
  5. Probably unrelated, but the Android app is behaving horribly (only since the platform update), and I wonder if it’s horrible behavior is wreaking havoc in the backend.

Hello,

I have been having issues too, I reset my events and now they seem to be going off on schedule but I now have another problem. When a new routine is triggered it is not overriding the old routine. So last night I had night time fighting with day time and it short cycled my heating all night… Has anyone else seen this issue as well?

Not sure what you mean by “overriding”. Routines are allowed to fire anytime you tell them to, so you can accidentally and easily short cycle anything. You should probably start another thread and paste in it your settings there so people can help. This thread is about things not firing. Also contact support telling them you are short cycling your heat, but note that they are warning people that they are still slow to respond right now.

I’m having issues with some routines working and some not… these are VERY simple, built in time based events, so nothing more than lights turning on and to a certain level at certain times. Some work, some do not… I don’t get it.

How do I create a ticket for this so I too can put this issue in and hopefully get a little more attention on the subject?

https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=smartthings%20support

Also, please reboot your hub as described in my post a couple above and then check on your timed events after that.

I completely agree. @slagle, it’s definitely worth it to post this.

I was not having any trouble, and the times/scheduled events were not bothering me until yesterday. I had nothing working at all. But I believe my issues fell into the category of what others were referring to as poltergeist in the system.

I had tried rebooting my system a couple of times, to no avail. I would unplug the hub and leave it that way for about a minute. Being a network guy, that always works for modems and routers.

With advice from @jdroberts, I unplugged the hub for about 15 minutes. When I brought it back online things were very close to normal. I did have to cycle a few of my lights, but not everything.

My scheduled routines did for on time this morning. My lights were also responding to sensors, as programmed.

Not due how long this will hold, but it did fix it for now.

@slagle, what are the chances that a software reboot could be added to the app. I would recommend that it be a hard reboot of the system, if the hardware is capable of it.

Don’t get too happy, it’s a matter of time before you’re back in ‘dark ages’. I have been rebooting my hub several times since Saturday. It works for couple of hours before things get out of sorts again. I have problems with runin () timers and not only with Smart Lighting, as well as problems using zigbee/zwave integration.

Not getting happy as it is still frustrating… But I’m always glad to find a fix, even if it’s temporary.

While a temporary, repeatable fix, is never ideal it is almost always better than having a completely down system.

I guess after 20 years naval aviation where we were just glad the planes came home with our seat of the pants repairs conditioned me to just be glad things are working for the moment.

I woke up this morning and checked my ST logs.
Good Night (issued from Minimote at 11:15Pm) - successful
Good Night (automatic) - failed last night at 11:30Pm…no entry in log.
Good Morning (automatic) was successful at 6:00Am!!!

Things appear normal now at 6:30Am.

check the scheduler as I outlined instructions above… my guess is good night will be scheduled in the past and continue to fail… Good morning running is not an indication that it will not continue to fail…

1 Like

Rebooting the hub does two different things.

Locally, it heals the Zigbee network.

Globally, it should cause your hub to resynch with your cloud account. That could have a positive effect on many devices, even cloud to cloud.

What it won’t do is change when individual events are scheduled to run, those are database entries in your cloud account. So if you have an event scheduled to run yesterday that didn’t, you probably still have to open that individual routine/smartapp and resave it to get it scheduled properly.

Live logging entry for “Things quiet down”…are things out of sync because I run on EST and the records are kept in PDT? And why is “current time of day” compared to "Thu Sep 17 20:15:00 "!!! :

10:50:52 AM: debug The current time of day (Tue Oct 27 07:50:52 PDT 2015), is not in the correct time window (Thu Sep 17 20:15:00 PDT 2015): doing nothing

1 Like

As I mentioned, sunset ran last night for the first time in a couple of days. But then good morning failed to run this morning for the first time in a couple of days. (All it does is change mode from Night to Home at 7:00 a.m. As I write it’s 8:30 and the house is still in Night mode.)

My housemate was furious, because he got tripped up by several different things as he was getting ready for work.

xAF below zero here. He wants anything that affects him fixed or replaced “by November.” And off on Halloween.

The poltergeists are winning here, I’m afraid. :ghost: :flushed: :skull:

1 Like

I hear you, many of us are reaching negative xAF, but knowing that you are not alone doesn’t solve your problems. In my effort to stop the decline in my home, I have been taking down apps that misbehave. Soon I’ll be reaching the pre-v2-migration stage, which is a “bare hub”.

1 Like

I didn’t get that from my reading, but tried it anyway. And you know what? You appear to be right! I replicated my failing IFTTT schedule in SRB that was restored to working order using @JDRoberts workaround, verified it wasn’t scheduled in ST… and it ran last night, respecting the Night mode restriction. Choice is good! Too bad that none of the working solutions is the off-the-shelf one from ST. :unamused:

1 Like