Time based events failing?

We should spin another thread for poltergeist light issues…

Add me to the list. None of my lights turn on this morning that are time-based :confused:. Put in a support ticket

For the failed time based event, can you try varying the time by a minute or so, click done and check if it triggers? It did help me to open the offending routine and click “done” again.

1 Like

I still had issues last night with lights failing to turn off at specified times. Had to push the button on the routine and then they turned off.

I tried off setting everything by two minutes and saving will see if that works morning :grinning:

1 Like

For mysterious light turning on/offs, there is another thread for sharing your experiences

I have a Goodnight routine that is set to run at 1:00 AM every night. All it does is turn off all the lights and locks the door. This has worked perfectly for weeks but has failed to run for past 3 times. The only way I know it hasn’t run is there is nothing in the Messages that indicates it ran. Normally the software places a message that it is running Goodnight and verifies that everything is set properly.

Good Night failed - not in log.
Good Morning failed - not in log.

My Minimote is programmed for Good Morning & Good Night (button 2).
Minimote started routines work.

My Tasker App scheduled tasks are running late.

Nexus 5 Stock V6.0 MM

Many MM users having time issues with v6.


I see the same problems with smart lights automations.

I have one which ran fine prior to the most recent platform update.

All it does is turn a light on at sunset. It doesn’t run. I’ve tried changing it and resaving. Creating it all together new. Changing the name of the automation. It doesn’t run.

Not only that, it’s not scheduled to run. The schedule is completely blank. This is different than my other automations.

The other parameters are there and set correctly, but it never gets scheduled.

Yahoo! My sunset (based on luminance) finally worked today and the popcorn effect was the shortest ever. Sorry if this is off topic but this thread was really created as a result of failed triggers from last update in my opinion anyway.


Ouch! I was about to raise the victory flag after a full day of success since changing/re-saving all time triggers and taking the hub fully offline/online.


It would seem that this little problem has found its way down here to Alabama…

My routines fired on time.

But nothing is responding… things are turning on and off at random. The app says they are on, but they are off. The app says they are off, but they are on…


There you go, unfortunately.

Welcome to a club with way too many members. :scream: :scream: :scream: :scream: :scream:. :ghost:

1 Like

My previously working routines started failing in the last day or so. What’s going on?

Yep… not happy… but, such is life.

This is one reason I’m changing over to switches instead of bulbs.
When something like this happens I can just hit the switch to turn the lights on and off.
And when the ST world comes back online, everything will still be in sync.

If you are talking about GE bulbs, you may lose them soon, that’s how it started for me yesterday morning and by night most of my zigbee devices were gone. Keep us updated if that happens to you too…Try to reboot your hub by letting it sit for 30 min with no power, batteries and ethernet cable. It seems that for some people works, it helped me, but I still have some problems lingering around that I am trying to isolate.

Yeah, all of my bulbs are GE Link bulbs.

I have several things that are running local… they are not working either.

Weird how the cloud is affecting so called local running apps.

Ah, talking about interesting facts, try to turn on the bulb without setting level, they will all show up as runnig locally.

1 Like

i can tell you what the problem is… every one of my time based or sunset etc events that failed were because it missed running once and from that point on never runs… and the reason it never runs is because if you
1 go into the ide
2 and under my locations
3 and choose smart apps. .

and check the app or the event "when things quiet down" etc which had a time… ie time based… they show "next run time " as a past date and time.

apparently from what I can gather if an event is missed or the scheduler crashes there is no cleanup code in smartthings that goes through and fixes them… you can go in yourself and see which if any of your time based smartapps/events are fubared… also I confirmed you don’t have to change a time… at least for smart lighting smartapp… just refresh is enough to fix it… however I could not get my good night routime which as a "“when things quite down” portion set from midnight to 2 am to fix itself. I changed the time , added and deleted things… no go… still said next runtime was in the past… in the end I had to rename it… add a new one… compare them , get it configured the way I want , then delete renamed/old one… This seems consistent with what others are saying about what has to be done to get routines working again. Most of my failures had a next runtime around the time the maintenance was done, so I think that is what caused them to be missed in the first place… From then on as I stated you are SOL till you update or delete/fix them.


[quote=“Lgkahn, post:230, topic:26885, full:true”] This seems consistent with what others are saying about what has to be done to get routines working again.

Consistent with most of them, except I have two or three that have no events scheduled. It’s just blank. Not a past date. And I can’t get anything to fix that. The schedule parameters are all there and set. But no schedule has been assigned to run it.