Thread Network Stopped Working

Day before yesterday, March 7, all of my thread devices went offline. They have stayed that way ever since. Today, I thought I would try deleting and re-adding them including a device/repeater that is closer to the hub. Problem is, nothing will pair today. It gets all the way to the “Registering your device” stage, sits there a while and then I get “Something went wrong”.

The Nanoleaf app can see if there are active thread networks, and the Smartthings thread network shows up there. I’m utterly baffled.

1 Like

That error message is all I’ve ever seen trying to add Matter devices to ST.

One thing that did improve my overall experience was to remove all the bulbs from the Nanoleaf app and make the first pairing to something else (Echo 4 in my case)

1 Like

They had been working fine for months for me. They would go offline more often than other protocols, but not for very long until now.

The error code I get is 39-517.

I was able to add an Onvis thread plug to ST via the Alexa thread network, but not my Nanoleaf bulbs. I want to use the ST thread network because the ST hub is closer to where the devices are.

The app seems to have updated. The icon is different and the pairing process looks a little different. Same result though, “something went wrong”. Ugh. You get a new error message that’s more confusing than helpful. Part of what it says is, “make sure your device and hub are on the same network.” What?! This is a Thread device. What network are they talking about? Regardless, I don’t have several different wifis, bluetooths, or anything else. There is more than one thread network, but I unplug my Amazon Echoes that have it when I’m trying to add it to Smartthings, so that shouldn’t affect it.

Radio silence from support. I’ve sent them several logs at this point.

It might, but in a negative way.

If the thread networks from your echoes have already been registered with SmartThings, and then they are unreachable When you go to add a new thread device, that can be a problem.

Matter over thread is supposed to be able to handle multiple thread fabrics, and SmartThings has been getting better at this, although iteratively.

So the first thing I would try is just leaving everything on before you add it and see if that helps any. :thinking:

Also, your phone and hub probably need to be on the same Wi-Fi network branch as the thread border router that will be used. You wouldn’t think that would make a difference since Bluetooth is used for commissioning, but with thread, it’s trickier.

I was under the impression thread networks from different hub/border router manufacturers helping each other out wasn’t working yet. I heard they are going to fix that later this year though.

When you say wifi branch, does that mean on the same router? I do have Eero Pro 6 with 2 routers. If so, I suppose I could unplug my secondary router to make sure…

I just tried adding my Nanoleaf bulbs to Alexa, and they won’t add to that either. I submitted a ticket with them too. Ugh.