Thermostat Problems

I have the RCS TZ45 thermostat. Ever since going from v1 hub to v2 hub it hasn’t worked correctly. Basically the device is reporting correctly but any command the app gives to the device, the device doesn’t do it. Even though the device log makes it look like it is but nothing changes on the device. I have removed the device and readded it. I have updated to the newly released andriod app but no luck. Support has had my ticket for a while and still no luck. Anyone have any ideas?

Same here. Different thermostat with wifi connection but the app does nothing and it doesn’t respond to routines. I’m told by support there is a bug.

Support has told me they don’t know what it is and was hoping the patch would fix it but it hasn’t

I just bought the v2 hub and RCS TZ45, I can turn the fan and system on and off but I cannot adjust the temperature set point. Every time I try making a modification, the app thinks that I am changing to 2F. I hope they fix the bug soon.

Try the thermostat now for some reason mine is working fyi

Are you using any custom thermostat device type? I was using and had a similar issue. See here and here.

No custom device type on the thermostat it just is working correctly now.

@aquaria1984 I was having the exact same issue with a Trane T-stat which is an OEM RCS TZ45. I went through repeated attempts of adding/removing it with no success. Ultimately I removed it from ST, unjoined it from the Z-Wave network on the t-stat and then did a complete factory reset. If you don’t know how to do the factory reset, go into the menu and then hold down the 2 center buttons for 3 seconds. Be sure to document all settings on the thermostat, you’ll have to set it back up for your type of HVAC.

Here is another forum discussing the same issue for the Trane

Basically i was able to narrow it down to the app not communicating with the thermostat correctly. Due to this, i had to wait for SmartThings to fix the app to fix the problem.

Edit: This has been resolved platform-side and the fix no longer applies to new setups. I will leave the body of the post as creating a new device type and applying it to a paired device is still valuable.

Previous post begins:

Big thanks to Danielle and her patience as we went through the troubleshooting steps for this - turns out there’s a problem with the device handler for this thermostat running locally.

If we move the DeviceType from local to cloud, the problem is resolved. This should be fixed with a Hub firmware update that we’re beta testing in the office.

*The steps to fix this on your own are as follows: *

1. Open SmartThings IDE in your web browser and log into your account with your SmartThings App credentials
2. Click on “My Device Types” in the navigation bar at the top of the screen.
3. Click the green “+ New Device Type” button on the right.
4. On the “New SmartDevice” page, click the “From template” tab.
5. Scroll to the bottom, click "Z-Wave Thermostat"
6. If you want, you can edit the name - look for the definition (name: “Z-Wave Thermostat” ) - if not, that’s ok.
*7. Click the blue “Create” button at the button of the page. *
8. Click the “Publish” button above the IDE editor window and select “For Me” in the drop-down list.

You should get a green “Device type published successfully for me” message - now we just need to change the Device Type the thermostat is currently using.

1. Click on “My Devices” in the navigation bar at the top of the screen.
*2. Click on the name of the device you’d like to alter (In this case, your RCS TZ45 Thermostat). *
3. Scroll to the bottom, click “Edit”
*4. Find the Type field, and click the dropdown menu. *
5. Scroll to the bottom, Find the “Z-wave Thermostat” device type (Or whatever you named it earlier), and then click “Update”.

Give it about 20 minutes (or reboot your Hub), and you should be good to go!

If you’re still having trouble, or you’d prefer we do this for you, email in to Let us know we have permission to access your Hub, and send us the email address your Hub is under - we can sort out the rest from there.

I am having issues with my thermostat as well. It’s not communicating with my ST App. I tried your instructions listed above, but when i tried to create from template tab for Z Wave Thermostat, i get this error

Groovy.lang.MissingMethodException: No signature of method: script1450469077590554266850.attribute() is applicable for argument types: (java.lang.String) values: [thermostatFanState] Possible solutions: attribute(java.util.Map), attribute(java.lang.String, java.lang.String), attribute(java.lang.String, java.lang.String, java.util.List), tileAttribute(java.lang.String), attributeState(java.lang.String)

Same here, just installed my new Honeywell TH8320Z and all is well except the app does not refresh the temp reading. Found the reference to this string and just tried the work around, had same issue and fault message. This is a bummer

Same here… waiting to see…

Thanks for letting me know. Could I have you all submit tickets, so I can create a developer ticket around this issue?

This is slightly different than the fix mentioned above - the problem Danielle was running in to was related to Thermostats running locally, and has since been addressed. If you’re unable to create DeviceTypes from Template, that’s something I’ll have to bring up with my supervisor, and the other problems mentioned by @SBDOBRESCU’s thread look to be related to Routines and Thermostats.


1 Like

Thanks for chiming in. It seems like the issue has been resolved. I do have a ticket in, though.

Not a problem @SBDOBRESCU I hope to be more active on the forums as we hire more support staff. Thanks for the update.

1 Like

My issue seemed to have resolved itself. It’s working now. Did you still want me to submit a ticket? I don’t know what the issue was.

If the issue is resolved, then don’t worry about it - but if it resurfaces, please do!