Thermostat changes temperature at its own at midnight

I have a C100 z-wave (IRIS) thermostat which operates with automations that I have created. From last few weeks, I am noticing that the thermostat is setting the heating temperature to 75F in the middle of night. None of my automation has that temperature. with this high temperature, my family wakes up in the middle of night and I then need to turn off the thermostat. this happened 3-4 times so far. Last week I deleted the device and re-paired with my hub hoping that the issue will be resolved but it happened last night again. when I tried to review the history in the IDE, there is no trigger other than the set temperature to 75F in the middle of night. I hope someone from the community can help with this issue.

Its most likely some automation rule or smartapp which is doing it (it can’t change by itself). You can review a list of SmartApps using your thermostat from the IDE -> My Devices -> Click on your thermostat -> Scroll down to the bottom of the page and see the list of SmartApps.

You try to press the “black reset” button as shown in this post to reset your thermostat.

If that doesn’t fix it, you can also try to exclude, factory reset (see the bottom of the first post here for instructions) and then pair it again with the hub. This will also disconnect all existing automations and smartapps and should give you a clean start.

Also it help to pair with the C-Wire connected on this thermostat as it puts the thermostat into active repeating mode rather than listening mode.

1 Like

Thank you for your reply. I had contacted the ST support and they told me to follow steps which said:
unplug power and ethernet on the hub, wait for 10 minutes.
After powering up the hub, exclude the thermostat. re-pair the thermostat.

I did these steps with no luck. I had another thermostat of same kind and I just replaced before seeing your post. I will see if it has resolved. if not, I will give these steps a try.

Thank you once again.

This just happened to me last night. Not trying to make you feel better, but my 2nd floor CT101 changed the heat to 88F from 72F at 11:45PM. I was awaken by feeling nose bleeding downstairs at 2:00AM, but I did not realize what was going on upstairs. Now I am feeling terrible for my son and my parents who slept upstairs and all awaken at around 3AM. This was the first time it ever happened to me since I installed the thermostat with Smartthings 3 years ago. The device has C-wire powered and batteries installed. I was wondering if it was due to old batteries?

Anyway, while I can’t find out why it happened, I created an automation to prevent this from happening again: If any thermostat temperature goes above 78F, turns on my Hue light, reset the thermostat to 72F, and push a notification. Now I just need to remember to remove this automation in March.

I had such automation that you described. unfortunately it was not triggering in my case. you may need to keep an eye on it.

Wow, thank you for the heads up. Wondering why it was not triggered? Isn’t the condition on the temperature?

Seen this exact issue as well with no record of why. It just happened. Nothing from google, smartthings, or ecobee except for it happening.

this happened again yesterday night. the temperature changed to 85 and woke me up in the middle of night. none of my automations or scenes has this high temperature.