There was a problem retrieving the live stream url

video
streaming
hubv2
samsung
cameras

(Brij Mohan) #1

I am getting the error: there was a problem retrieving the live stream url, when trying to view live stream from SmartThings, All my smartthings apps also stopped generating the clips.
These Cameras works fine with SmartCam+ Andriod App.

I am Using SNH-C6417BN and SNH-V6414BN with SmartThings V2, started getting this error from Nov-7-2017, it was working perfectly fine till Morning on Nov-7.

I tried Hard Reset of SmartThings, Factory Reset of both the Cams, deleting and re adding the Cams back to ST. I have reserved IP’s for both the CAMs and ST. Spent almost 2 days with SmartThings support but nothing helped. I would appreciate if anyone in this community has any experience or and suggestion to solve this issue.

My SmartThings Smart Home Monitor is totally broken. Thanks in advance


(anh ho) #2

Got same problem, ST failed to generating the camera clip


(www.rboyapps.com - Make your home your butler!) #3

Basic question, but did you reboot your hub and phone. That solves many connection issues.


(anh ho) #4

When getting alarm triggered, i viewed the alarm report, it said begin generating record clip but nothing show up, however i can see the live view. It was working on Nov 3rd, but failed now. I did reset everything but no lucks


(Andrew Day) #5

I’m having the same issues with this for the last few days, both live streaming and recorded clip generation not working. Tried rebooting all devices with no luck.


(Brij Mohan) #6

Tried rebooting everything, even did ST hard reset, factory reset, camera factory reset. Spent all total approx 2-3 hours with SmartThigs support guys. Nothing helped.
If I look into Live Logging in Web Interface it gives me following error.

45b4592e-05c5-4e93-9fcf-d3adb1654b14 7:32:32 PM: debug locationHandler(json-body)= [status:error, data:[message:Unable to aquire shard info from cloud, errorcode:19]]
45b4592e-05c5-4e93-9fcf-d3adb1654b14 7:32:32 PM: debug locationHandler(json-header)= [content-length:93, http/1.1 500 internal server error:null, connection:close, x-st-version:1.5.3, content-type:application/json, date:Tue, 14 Nov 2017 01:32:32 GMT, server:Video-Core, x-st-application:Video-Core]


(www.rboyapps.com - Make your home your butler!) #7

You should contact ST support for this. Looks like your device can’t either figure out which ST server to contact or that server is offline.


(Shawn Ballard) #8

I also am getting the same error message and experiencing same issues. I have also tried everything you have tried. Please let me know if you find a fix. I have sent an email to ST 2 days ago and no response as of yet.


(Shawn Ballard) #9

i got a response back from ST…
Jason (SmartThings)
Nov 14, 11:48 AM MST

Hey Shawn,

Thanks for reaching out to us. I am sorry to hear that you are having trouble accessing your live stream on your Samsung SmartCams. After looking at the logs, the problem is that your cameras connected, but did not populate all of the correct states to function properly. Our engineers are aware of this issue and working on a resolution and I have tagged the associated problem ticket. This means that once we have any new information or a resolution, we will follow up with you via email. However if you don’t wish to wait for a resolution, the current work around is to remove and re-add these cameras until all the correct states populate. This is not a great alternative to get your cameras working within SmartThings, but hopefully after a few attempts you will be able to access the live stream. Here is a link to our SmartCam article that explains these steps.

I hope this information helps for now, but if you do have any other questions in the meantime please don’t hesitate to let us know.

Kind Regards,
Jason


(Brij Mohan) #10

Yeah, I also have the same feeling. I contacted them spent few hours with them then they said they will need more help from their colleague but never responded back. Let me followup with them.


(Brij Mohan) #11

Thanks for sharing Shawn. Till then we can safely say that ST does not support these CAMs :frowning:


(Kevin Reisinger) #12

Anyone have any updates? Would love to get this working as these camera’s not working is extremely limiting the capabilities of my “smart” home. Thanks…


#13

I have 4 different IP cameras (2 Foscams, 1 Iris cam, 1 iPhone app webstream) with 3 different DTH which some use RTSP and others use MJPEG (http) stream urls. I can view all the camera streams via VLC and browser (ActionTiles) but the ST app won’t load any of the streams and says “There was a problem retrieving the livestream url.” for all my cameras.

Some other symptoms:

  1. I’m able to control my Foscam cameras’ pan/tilt/cruise functions from the app so I know the hub is connected at least.
  2. Taking snapshots take a veeeery loooong tiiiiime to populate, sometimes after exiting/entering the camera is the only way to see the snapshot

I’ve tried:
Hub reboot, phone (Samsung G7edge) reboot, camera refresh…


#14

same problem. just started yesterday.
anybody find a solution yet?


#15

This same thing started happening a few days ago. I have 2 Samsung 6417s and a D-Link 5222.
I have deleted and reinstalled the cameras several times, I have reset the hub, I have reset my phone and tablet, all to no avail.
Any suggestions.


(Matt Hunt) #16

Hi - same thing here with a Samsung HD Pro (SNH-P6410BN). The camera is available, but when you connect (or try to) you get eventually that there was a problem retrieving the livestream URL. This did work fine - not sure until when as the camera was always showing as available.
Logged with Support who came back quickly with a usual list of trouble shooting from rebooting everything, disabling device health and checking that encryption was turned off on the Samsung Cam app. Still no difference. I’ll report back if they come back with something that gets this going.