The "Remove" button is not working to exclude devices


(Ron) #1

I am trying to exclude a device but when I press the “Remove” button on Preference nothing happens. I can’t even tell I pressed the button. Android v1.7.4

Anyone know if this is broken ?


(Cyril Peponnet) #2

If you want to exclude a zwave device go to hub and zwave utilities in the pref pane. Remove button is for replacing faulty device afaik


(Ron) #3

According to this page remove is used to exclude.


(Tim Slagle) #4

Hey Ron!

We know about this issue. It’s being worked on as we speak and I’ve heard there is a fix already.

In the meantime you can remove the device from the IDE and then use the Z-Wave exclude option to exclude the device and that should allow you to re-add it.


(Ron) #5

@slagle Thanks I had done it from the ide already but was wondering why remove doesn’t work. Thanks for the info.

Strange that Riley from support replied stating that I should make sure I deleted all my associated Smart Apps from the device. He didn’t seem to know about this “known” issue. I would think if I had Smart Apps associated I would get an error not just have the button press ignored. In this case I know I didn’t have any smart apps because I just added the device and wanted to delete it.

You said you heard it was fixed already. Was this a fix to he Android App so I have to wait for the release of the app, or was it fixed already on the server side ?

If app needs to be released can you tie the fix to my open ticket #111902, thanks

On a related topic, is it possible to select the device type code you want applied when adding a device ? I am adding from my Android app. I have two device type I am working on a new “Beta” version of my zxt-120 device code and I have the original code since I have several of these devices and most are running now on original code.

When I include my new testing zxt-120 device it offers the Original Device Code but does not offer the new Device Code. So I have to install the original, then open the ide and switch to the new. This is problematic because the original installs preferences and setting variables which are different from the new code so I am pretty sure when I switch the old preferences and settings remains present and just stays as junk. I would like to clean install the new Beta device code. Not sure this is clear, if not I can explain further.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

I have the same problem and used the “obvious” workaround. No patience here when I’ve set aside a little time to install / replace a few Things…


(Ron) #7

Are you on Android or iOS ?

Workaround likely not obvious to all (that was the meaning of the quotes right :slight_smile: )
It’s actually a little hard to find the exclude button in the ide. I would think adding an exclude button on each device page would make it more obvious. I only knew about it because I had a device which was “deleted” in ST but not excluded so I could not add it. Then you have to use the “Utilities->exclude” option. So I knew it was there.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

Android, mostly, though I think I tested on iOS and saw same problem. Currently no iOS device at home…

Frankly, I’d really like to have full Z-Wave Exclude (with result messages) in the mobile App.

Results are only in the Hub Event log, requiring two browser tabs… Rather tough on mobile browser.


(Ron) #9

Just so you know the “remove” button still does not work. So not fixed already.


(Tim Slagle) #10

Understood. I mentioned it is being worked on and that I heard there was a fix. Meaning we know what the issue is :smile:


(Ron) #11

I see perhaps that is the problem. I never consider code fixed until it is fixed, tested, released. I have so many “fixed” issues with my device I am losing count. Glad the issue is known.

Can you link my ticket #111902 with the fix so I am notified when it is released. If I don’t know it is released I will likely keep using the ide when I don’t have to.

Thanks for keeping us informed. Communication seems to be getting better :smile: