Multisensor recording in Farenheit but App in Celsius


(Cuan Brown) #1

I have a multi-sensor that for some reason shows in Farenheit where everything else is in C. This was working over the weekend but I have moved everything to a new email account so needed to recreate everything.

I have deleted it/readded it. Reset my home location back to Celsius and then re-added the device but not luck

Any ideas?


(Rajiv) #2

I had a similar issue in my door sensor. I used the Web to change the home settings to C, uninstalled the device, removed the battery and readded it.


(Aaron S) #3

We are seeing a trending issue with this but I have been unable to isolate a pattern. it’s not the same sensor or circumstances th each time. The more instances we have for tracking, the quicker we can isolate. Shoot a note too support with the screenshots and they’ll investigate.


(Scot McSweeney-Roberts) #4

I’ve got the the same (or similar) problem with both the sensors that came with the kit. I didn’t realise that I needed to set the house to C when I initially set it up (seriously, why don’t you read the phone’s locale settings and use that as a sensible default?). I’ve now set the house to C, the sensors are still showing as F (but now in a red circle, I guess it thinks it’s 70C), I’ve tried deleting them and readding them (even taking the battery out) with no luck.


(Cuan Brown) #5

So my hub was rebooted remotely via the api website by myself and never came back. Raised support ticket and based on what I dis to resolve the issue imho it was a server backend issue. Aaron and co worked with engineers and after 3 days my hub came back online last night. The interesting thing is that the Fahrenheit device automatically switch backed to Celsius. Seems like a few gremlins in the cloud based software.


(Paul Green) #6

I have the same issue.

Has anyone come up with a solution which doesn’t involve uninstalling, reinstalling and rebuilding your macros etc? Getting a tad annoyed with the beta test feel of Smart things in the three weeks I’ve had it. Every time I need to make a seemingly minor change, you shouldn’t have to uninstall all routines, uninstall the sensor, reinstall the sensor, and then rewrite every routine that was linked to it.


(Rajiv) #7

Did you try changing the settings using the Web, and not the software? That worked for me.


(Cuan Brown) #8

I agree with you. There is a beta feel to it and the interface is really clunky. The fact that I cannot add another users is pathetic. It should not have been released without cote features. Anyway I will soldier on but it is frustrating


(Paul Green) #9

No, but I’ll give that a try when I get home, will report back :slight_smile:


#10

I was having the same issues with devices showing in Fahrenheit although the hub was set to Celsius, but it now seems to have fixed itself.

The only change I have made is to update the iOS app.


(Aaron S) #11

We are getting some traction on these reports. We are hearing reports that they are correcting themselves (albeit not fast enough). Keep reports coming so we can isolate.

Thanks!


#12

Me too. Home Location on the web is C, but readout on device in the app is in F. :confused:


(Aaron S) #13

@Twisticles (I am not sure HR will let me write out your handle! :smile: ).

If you haven’t already - can you send this image and email address for your account to support@smartthings.co.uk to check out?


#14

Sure, will do!
Thanks for responding too, appreciate it.


(Paul Green) #15

There is not a parameter available to me on the web interface for change scale.


(Rajiv) #16

Go to My Locations, Edit, Change the scale

If it’s in C, Change it to F, and then back to C again.

This may or may not work. It worked for me.


(Nav) #17

I also reported this to Support today. So far they are advising me to check everything is set to C in my locations…which it is.

The two sensors I have are the multi-sensor and motion sensor. The motion sensor correctly shows Celsius. By the multi-sensor shows in Fahrenheit. The IDE and the App both show being set as C.


(Tom Beech) #18

I just got SmartThings, and this is the only major issue i’m having thus far… My multi sensor is reporting temperature in F and not C. However, when the location is set to ‘C’ the tile in the app is red, which I guess means that it thinks 70c is pretty high, so it knows that it should be reporting in Celsius. When i set it to ‘F’ the tile goes green, which is more evidence to support my previous idea.

Any update on this?
Thanks


(Cuan Brown) #19

i removed it and readded it and rebooted the router. That resolved it for me. I made sure to update my location/settings before readding


(David Brown) #20

Hi, I had the same problem. Some sensors will change straight away, like a motion sensor. But others will take a least 3-4 days to get in line with the app. Just bare with and it will sort it self in time.