Telldus Z-Wave Plus plug-in switch not found by Smartthings hub


#1

Hi SmartThings fans!

I just bought myself a Smartthings hub and I am now trying to include my Z-wave devices.
I have already succeeded with other devices, such as Philips HUE bulbs and SONOS equipment.

I have a bunch of Telldus Z-Wave Plus plug-in switches, but I am not able to get them included in the Smartthings hub.

The switches are excluded from the old network, and I try to add the switches when the switches are in pairing mode (slow red blinks), but the smartthings app do not recognize any of them.

I have tried both switches that have been used in other networks previously (which now are excluded) and I also tried a new one which never has been included, but no luck.

Anyone have any luck including Telldus Z-wave Plus Plug-in switches? Any suggestions?

Thanks!


#2

Are you sure they were excluded from the previous network, and not just deleted? Those are two separate actions.

Anyway, what I would do is start by just doing a general exclude from SmartThings to make sure they were truly excluded.

After that, they should add. I can’t say if they’ll have full functionality, but you should at least have on/off.


#3

Hi again.

I found the issue. I was dispatched a US hub and not a UK one.
Since I live in Sweden, I have European Z-Wave devices which of course don’t work with the US hub.

Thanks.


#4

Also, this is probably a silly question, but just to be absolutely sure…

Are the teldus switches and your smartthings hub on the same Z wave frequency?

The smartthings hub comes in two models, one with the UK zwave frequency and one with the US zwave frequency. The frequency cannot be changed after the time of manufacture. Anytime you are adding new Z wave devices to the hub, the frequencies must match exactly.

The Telldus Devices are made on the EU frequency, but not on the US frequency. So you would need to have the EU version of the SmartThings hub.

edited to add: I was posting my question just as you posted your answer! But I will leave my question up just in case anyone else has a similar problem.


(Lasse) #5

FYI - have an UK v2 hub and it works with Telldus Z-Wave switches. Located in Sweden.

/Lars


(Sven Magnus Skaar Jakobsen) #6

Lars: Any issues with Smartthings reporting the devices as unavailable? What DH are you using?


(Lasse) #7

Using “Z-Wave Switch Generic”, if I remember correctly it was auto detected to that DH.

Had some weird issues in the beginning, bit no issues the last 3-4 months.

/Lars


(Sven Magnus Skaar Jakobsen) #8

Do you have device health on?


(Lasse) #9

Device health is off, wasn’t aware about that setting.