Take over Vivint Kwikset 910 locks with ST

I recently moved into a house that had Vivint to control Kwikset 910, doorbell, thermostat, etc. They took the control panel so I don’t have one.

I’m wanting to NOT use Vivint and would like to take control of, at the very lease, the Kwikset 910’s. I have a ST hub and it sees the two locks but can’t seem to control them.

I’ve tried factory reset on the locks, ST z-wave repair, etc, etc with no luck.

I hope someone can point me to the correct forum link or maybe has a solution.

Why not the Vivint, if it’s zwave it’ll work with your hub.

Status check:

  • Were you able to pair them with the hub?
  • How far are the locks from the hub?
  • Do you have any mains powered z-wave device in the room (assuming these are z-wave models)?
  • When you operate them manually do you see any events in the IDE Live Logging on in the ST app?
  • What device handler are you using for the locks?

Thanks for the reply.

I don’t mind the vivint equipment, just don’t want to use their service.

Pardon my lack of knowledge, I’m a bit of a newbie with this:

I was able to pair them with the hub.

I had the hub about a foot away from the lock.

Not sure what you mean by any mains powered z-wave device (and yes these locks are z-wave).

Not sure how to find the IDE live logging, but I’ll take a look at that tonight.

How do I find the device handler for the locks?

Thanks in advance for the help!!

Mains powered device means some sort of a Z-wave item running off power not battery (z-wave wall switch, z-wave outlet, etc).

You’ll need to log into the IDE to see what Device Handler the locks are using. If they are just showing up as a “thing” you’ll want to adjust them to a z-wave lock.

In the app, what are they showing up as since you said you can see them?

Did you enable anti theft on your locks while they were connected to your panel? If the anti theft feature was enabled and you removed them without “excluding” them first then they’re locked to the old panel.

Unfortunately the panel was removed by the previous owner and I’m unsure (but he probably didn’t) unlock them from the old panel.

What is the workaround for this?


1 Like

Hi! I am in the exact same situation :’(
Were you able to solve the issue?

I haven’t worked on the problem for a bit but still haven’t resolved the issue.