T9 using the Honeywel Home app NOT the TCC App

last year I replaced an older Honeywell smart thermostat that used the TCC app and got the T9 which uses the Honeywell Home App.

is there a way to add the T9 to smartthings. I seemed to try all the different options within smartthings even tried to add the T9 to my old TCC app which doesn’t look like it will support.

not a huge deal but would nice to have in smartthings


In the new app, did you go to add device and choose “Honeywell Home Total Connect Comfort” brand? It says it supports the T9.

thats what is weird my old thermostat used an App called TCC (Total connect…)
but the new T9 thermostat uses an app called “Honeywell Home”
I used to have both apps on my phone and it was confusing if I opened the TCC one out of habit it would say lost connection since it was gone. So I removed the app and just use Honeywell Home app and all is good. I did have the TCC app connected to Smartthings but it was showing it was disconnected since that thermostat is gone. Today I tried to add the T9 to the TCC account (I can still login through the web into the TCC account ) but it doesn’t seem to allow the T9 in there.

I’d contact Honeywell. They own the integration with SmartTHings and should be able to help,