SmartThings Community

Synology Diskstation & Cameras

project_cameras
(swanny) #1

I’ve been working on integration with my Synology Diskstation specifically the Surveillance Station cameras. The Diskstation is a network storage (NAS) and media server solution. It also has a full camera surveillance solution.

The integration I have implemented uses local network access to connect to the Diskstation and allows creation of camera devices. The camera devices support taking of pictures, triggering recording on the NAS, and motion detection. Camera movement, presets, patrols, and zoom are also supported. Synology has their own separate DSCam app where you can view live streams and recordings. Synology supports a huge number of cameras which is great (https://www.synology.com/en-us/support/camera). However, the camera system is limited to two cameras without additional license purchase.

You can download the SmartApp and device type here with instructions:

I’ve tested it quite a bit but there still may be some bugs. I don’t have a zoom camera to test that feature, but support should still work.

18 Likes
Any Recording system for Surveillance Camera work with ST?
Best camera options for SmartThings integration
Double/Triple Duty Cameras with ST Hub
Cloud video storage
Integration with AT&T digital life
Ring vs Skybell vs Kuna vs?
(Brian) #2

I <3 you!
Im getting my DS214play at the end of the month and was hoping to get it integrated with ST somehow!

(Raymond) #3

Looks pretty awesome. I’ve been using just the single camera license for now on my NAS but want to add a few more. I’ll set this up in the next couple days and give it a go!

(Coolcatiger) #4

Thank you so much.

I always wonder how I can use my camera’s as motion sensors. I you did it.

Thank you!

(Richard) #5

Got this installed and working mostly. I can take snapshots with my DLink camera, but not my Hikvision. On the Synology, the DLink uses surveillance station for motion detection, and the Hikvision uses it’s own to trigger. Also, the Hikivison is using H264 and the DLink is using mjpeg. I mention these as hopefully clues that might explain the issue.

(swanny) #6

I have both a H264 and a Mjpeg camera, so I don’t think that’s the issue.

@RichardH I’ll start a PM thread with you to see if we can track it down.

(Richard) #7

I am also having the same issue as Richard. I have 2 Axis 3014 cameras and can only take snapshots with one. Both camera have the same settings in surveillance station so im not sure what is going on.

(swanny) #8

@rog and @RichardH I have updated the device type with some additional logging to help track this issue down. Please download the updated device type from the link in the first post, copy it over your current one, and publish it for yourself. Then go into the app and click on the refresh button. Please send me the text written out to the log. With two examples I should be able to find out what is different than with my setup.

(Richard) #9

I just did this, but I don’t see anything in the logs different than what I sent you earlier. But I also did not understand the step in your post about going to the app and hitting the refresh button.

(swanny) #10

Sorry, i meant go into the Camera Device and press the refresh button tile there. It’s down on the bottom of the tiles. That should print out some new information. Getting tired and not being too clear in my typing. :smile:

(Richard) #11

Hey Swanny i seem to have fixed the problem by replacing removing the space in my camera name.

Here is what shows up in the device log when i take a snapshot with my old camera name “Front Door”

Front Door image is smartthings-smartsense-camera: Front Door_326024eeae594a45b507d8a48616392e.jpg

This is with the new name "Front-Door"
Front-Door image is smartthings-smartsense-camera: Front-Door_326024eeae594a45b507d8a48616392e.jpg

(swanny) #12

@rog Thanks! @RichardH had sent me his logs last night and that’s what I suspected was the issue as of this morning. It’s great to have the confirmation. I’ll make the real fix to the device this weekend and update this thread when it’s done.

(swanny) #13

@RichardH @rog I have updated the device type to fix the capture bug related to cameras with spaces in the name. Just copy it over the old device type and publish. You don’t need to update the Diskstation (Connect) SmartApp.

You may need to delete the device that had the spaces in the name using the IDE or mobile app and recreate it using the Diskstation (Connect) SmartApp. The iPhone app seemed to have issues if the device had one of the bad images still linked, but deleting the camera device with the spaces will definitely resolve the issue.

(Richard) #14

Worked like a charm. Thanks swanny!

(Marfi) #15

Thank you! Worked
Regards

(Eric) #16

same here just purchased ds214play and smartthings and wanting to see how the two can be used together

(swanny) #17

@eatdoku This integration allows cameras from the Surveillance Station software that comes with your Diskstation to be used in SmartThings. Check out Surveillance Station and if you like it, you can follow the instructions to integrate the cameras with ST.

(F5snopro) #18

I have a QNAP NAS with Surveillance Station. Wonder if this code will work with it? The NAS boxes seem very similar.

(swanny) #19

I did a bit of checking on the QNAP vs. Synology setup of Surveillance Station. It looks like QNAP does not expose the Surveillance Station API like Synology does, and it still wouldn’t be the same API if QNAP has added the support recently. Looks like your out of luck on this one. Sorry!

(F5snopro) #20

Bummer. Thanks for checking into it though!