Switchbot - Simple “power on” for some TVs (IR blaster)

@granzy

Sorry to ask the obvious question, but I can’t get my head around it and can’t seem to find any clarification googling etc.

Could you explain how the actiontiles setup works?

For reference, my fan remote is in actiontiles. But that meant creating a piston for each physical button, then adding to actiontiles by using a weblink to each piston.

Not the most intuitive.

How did you make yours? Cheers!

@djh_wolf
see my post 10 above. This will add a “placeholder” device in smartthigns.


Then just add that device to actiontiles.

@granzy

So the custom remote you made… is the whole thing created in the switchbot app, and imported as a single device into actiontiles?

I presumed it was an actiontiles screen with multiple buttons.

Any chance of a screengrab of the device in the switchbot app please? Also, do you know if it works on the classic app, or is it a standalone app anyway ?

Ta! I’m virtually sold on this I think. Just want to be clear. =)

The custom remote I made is just a panel with individual devices added, not a single device.


(see post 10) You add the device in the standalone switchbot app, then use the new app to add the switchbot into smartthings (not sure if it will work to add in classic app)

2 Likes

cheers, much appreciated!

568/5000

I use an alternative method.
I created a projector to have the distinct ON and OFF keys and create a correct virtual device and be sure not to turn it on if it is already off by pressing off.
All the other keys I copied and created in the custom remote control.
After I created a scene for each button, with the synchronization with google home (or alexa) the scenes are imported and I can say verbally: “put volume up” and not necessary but more orderly, I did the routines in google home to avoid of having to say “put or activate” to activate the scenes

1 Like

Note that my current system is:

  1. Use my phone (wifi) to hit an actiontiles button.
  2. This flicks a virtual switch
  3. Webcore piston triggered by any change in the virtual switch, which then…
  4. …sends an autoremote message to the old s6 handset, which is…
  5. …intercepted by tasker, which then uses the anymote plugin to send the appropriate IR signal.

All in all, this takes 2-3 seconds, which is way faster than i’d expect. Note also that the delay is substantially increased if I use a virtual push button switch (cloud based) as opposed to the (local) standard virtual switch. Does sound a little long-winded, but it works and it’s surprisingly fast enough.

-=edit=-
out of curiosity, I tried cutting out the virtual switch altogether, replacing the actiontiles button with a URL link directly to webcore. Now we’re looking at 1-2 secs. I’m sure this could be even faster if I was using 5G wifi instead, or if I could add an IR blaster to a hardwired android box.
-=/edit=-

Righto… the switchbot. Couple of q’s. =)

  1. In practice, are the delays too great to make it ‘comfortable’ to use as a replacement real remote? I don’t want to hit ‘vol up’ and need to wait 6-10 secs for an actual response. See above.

  2. My current system is solid, but it’s annoying to set up. Feels massively over-engineered. Also I’m finding it difficult to find exact matches for certain functions of my complicated home theatre using the amymote suggested remotes. The switchbot mentions a learning mode - can I use this to duplicate ANY button press from my existing remote by point and shoot?

Cheers!

Yes,
in your emulated device in swithcbot you can add all button you need…

1 Like

Hi all,

I don’t use the new app and choose not to have both running on my phone due to the battery drain and location issues that it can cause. Alas, I haven’t even looked at the new app yet and don’t plan to until I get the switch app banner.

So I’d like to know if anyone has managed to add this device to Smartthings use the Classic App? Or is it only in the new app where it can be added?

Like many of the new cloud to cloud integrations, it can only be used with the new V3 app.

2 Likes

Righto, decided to purchase a switchbot mini for about £25 off amazon uk.

Haven’t had the chance to mess with it much yet really, but I don’t think it’s up to much. Obviously using cloud it’s not going to be the best, but predictably the volume controls are way too laggy.

It’s alright (2-3 secs) for changing functions, but for volume - pointless.

It would be fantastic if someone could create a way to use it locally, as for example for my devices (rgb light and smart sockets) that worked with Smart Life and now with Tasmota firmware they work locally. This would certainly speed up the responses of the IR but I have to say that in Italy I do not have these tough times, maybe about 1 second late. Longer delays I notice them in routines, for example turning up volume 5 times with a single scene created. between one volume up and the other always 1 second

needs some addition to the app to simulate a long keypress. that would sort it. even a 1 sec delay is too long for replacement volume control. I think i’m going to return it.

ooh…worth a look maybe…?

Nope. Must only be for the bot, not the hub buttons

Update -

Submitted feedback hoping for a decent response and hopefully some improved functionality. Just really need to have the software allow you to edit a button on a remote and change the behaviour from ‘pressed’ to ‘held for x secs’ and it would be a great little product.

The response I got ? Step by step instructions on how to set the hub up.

Absolute, total waste of time. Didn’t even listen. Someone else suggested buying the ‘bot’. Why the hell would anyone think that I’d spend another 30 quid to press a volume button, then a further 30 to press vol down??!!.

Crazy. Should be an easy fix I’d imagine. For now this isn’t a viable project. = (

Update - had an email from them to ask if I was satisfied with the response. Replied to say ‘no, you didn’t answer the question at all’.

The reply was awesome…

… Step by step instructions on how to point the remote at the hub and learn a button.

Waste of time guys. Waste of time. Shame.

As I mentioned when starting this thread, I don’t use it as an overall replacement for a TV remote. I agree, I think it would have too much lag and be too frustrating for that.

I control my TV by voice, and that works fine for me. The problem that I had, which quite a few people with certain brands of smart televisions have, is that there’s no way to turn the TV on by voice. That’s where the SwitchBot mini comes in. All I needed to do is turn on the TV with the voice command, and after that my fireTV takes over.

And of course I also use it to control the SwitchBot buttons.

But it does sound like it’s not something that will work well for your use case.

1 Like

Sorry man, didn’t want to risk coming off as a tosser over this.

My point was (is?) that this could easily be a thoroughly awesome product if the software could be tweaked.

  1. Press and hold functionality.
  2. Tasker integration.
  3. Better control of the design of the DIY remotes. The existing system is literally adding a series of identically-sized rectangular buttons, no icons, stacked in order of creation with no way of rearranging, spacing out, colours, icons… Etc. Pretty basic. Shame, because the ability to learn buttons is a huge bonus!

My gripe is more with the support system - it’s shocking. I took the time to feedback thinking it was worth a shot. Instead I get somebody pointlessly telling me the unrelated bare basics, TWICE!? Terrible. Waste of time having the option of feedback.

I agree that for simply powering up a TV though… PERFECT. =)

1 Like