Support Non-responsive for weeks, hub unusable

I originally emailed smartthings support on 12/31 and received initial emails back where the rep didn’t seem to know how to resolve my problem. It has now been over a week with no response despite 2 emails from me. Is this how Samsung supports their paying customers?

My hub is lost in migrating from smart things classic to the newer app, which sounds like a common issue.

There are 2 support numbers, one is for anything Samsung and the other is SmartThings specific. You will most likely have better luck with the second one:

1-800-726-7864 is Samsung’s main support number in the US.
1-855-238-7339 is a number specific to SmartThings and ADT.

If you can detail your issue maybe others on the forum can help you otherwise this is an unhelpful complaint that nobody can help you with :wink:

The most common issue with the migration is simply that a new location gets created without user awareness and the mobile app is defaulted to that location so it appears like everything has vanished. Simply selecting the other “Home” location will fix the issue. I noticed the issue as my default location was not called “Home” so the new name tipped me off… plus I read a lot of posts here.

Another issue is that you may have been moved to another shard. I was on the original one when on v2 and with v3 I am now on a server on the East cost. The URL to login that I was using still takes me to the old shard so once again nothing shows up… try this one instead:

Or… once you are logged in, got to Locations and select the new location to be taken to the right place.

Just a shot in the dark since we have no info on what your issue is… please share it, and you might get a solution from a forum user.

The non-responsiveness is awful. :scream:The migration issues, fortunately, are typically not too hard to fix once you know what they are.

Check out the community – created FAQ and see if it helps:

1 Like

Also, the migration is from a account to a account. It’s not a migration of the app itself. So you can continue to use the Classic app, which you may find more usable.


Thank you both. Not just meant as a complaint, but expected samsung to have reps here too that could address the poor responsiveness. Didn’t think other users might be able to resolve, but awesome if we can go that route.

The issue is I appear to be logged in to both the classic and new app via my Samsung account, but cannot view my hub, switches, and automatons in the newer app. When I try to manually add my hub, it says I need an invite from the owner (me lol).

I’m not sure which app I would prefer, but simply had the newer one installed my default when I got a new s9 phone so figured I’d give it a shot.

This forum is just for customers helping customers. It’s not officially read by staff, although occasionally some staff members participate here informally.

The official support forum where there are employees responding to posts as part of the official support system is over at However, they’ll tell you they can’t answer questions about smartthings hubs, and just give you a phone number to call. So that’s not really much help. That forum is mostly to help people with appliances and TVs which I would guess can afford to pay for employee-monitored forums since they have a much higher price point.

Anyway, start by reading the community FAQ and see if it’s a location issue, just because it usually is. When you first get a Samsung ID instead of a smartthings ID, the system automatically creates a new empty location for you and sets it to be the default. But when you already had a SmartThings ID with a hub and location in it, that confuses everything until you untangle it.

1 Like

Looking at the faq and the linked website, i only have one location. In the classic app though the location shows as coordinates and in the connect app it shows as an address. Could that be the issue? I tried deleting and re-adding home in both apps, also signing totally out and back in from the Samsung account to no avail.

All the devices show up logging into the website and the classic app, but the hub and “local” devices are still missing in the connect app.

You will need to contact ST support at They will probably need to sync up your account for both apps.

1 Like

I am not sure what you are deleting or why, but if things are working in the classic app, i would suggest you just continue to use that and not worry too much about the new app unless there is some compelling reason to continue fighting with it.

As JD noted, the community isn’t a source of official support. Some employees such as myself participate in the forum in our spare time but are limited in the amount of support we can provide. Your best option is to go through as it sounds like you’ve done.

All that said, were you able to reach a resolution via email?

I haven’t heard from support since 1/3 via email. I tried to call the number provided this weekend but not but they aren’t open on Saturdays.

For now I’ve just reverted to the classic program but worried that will lose support in the future.