Entire setup botched after migration. Support is an unresponsive black hole

I don’t even know where to start. It’s been nearly two weeks since I tried migrating to the new platform. I’m on the V1 hub and been with SmartThings since just after the Kickstarter days.

I tried the migration and at first, everything showed up on the new app. But not everything carried over. I tried to delete items from the old app, and tried to set them up on the new app, but nothing would go through. Same for adding Rooms. I’d try to add a Room and nothing in the app. In the IDE and classic app, it’s there. Now, it’s to the point where my hub doesn’t even show on the new app. Some suggested I look to see if a new location was created, but in my case it was not. My entire setup is unusable.

Two weeks ago I reached out to support and was told to reinstall the app. Of course that didn’t work. I was told the next day that they would “get back to me with an update”. I’ve sent three follow ups and it’s a black hole of no response. In the meantime, I have a barebones setup with the classic app and Alexa support. I don’t expect to get all answers right away, but the way ST support has gone downhill is atrocious.

I feel like I’m two steps away from going to another system because to have zero answers after so much time is no way to handle technical support.


If the hub is not showing in the new app, then you will definitely need ST support to resolve the issue. Be sure to include the detail about the hub not showing in the new app and request that your ticket be escalated to a higher level of support. Good luck!

Tagging @Brad_ST @SamsungZell

Yeah I let them know nothing is showing in the app. I figured something botched hardcore with the transition. Again, I don’t mind but I do mind having a 2-week wait with radio silence after I keep pinging them multiple times.

1 Like

Looks like ST’s “crack support team” figured it out, but gave me two awful “solutions”.

Apparently my SmartThings Hub and devices live on their NA01 (North American) server and my Samsung Account lives in the EU region. To fix this, I have to create a new Samsung Account using a different email address in the correct North American region. Um… I only HAVE one email address!

Then my “choices” are to delete everything, factory reset my hub, and set everything up from scratch on the new account. OR… I can give them the new email / account and they can “attempt to transfer your Location, Hub, and devices over to the new account.”

I don’t even know how to proceed. I have a V1 hub and I’d bet it would ask for that “welcome code” that came with it 5 years ago that is long gone, if I completely reset it and started over. But I also don’t trust ST support to correct the issue.

Oh, and I don’t even have a different email address to give them!!! :rage:

Fair warning, there is a thread here in the community where people have been posting issues with the welcome codes. There is a staff member that occasionally jumps in to help with that, but the general support sounds pretty useless on that issue.

Thanks for the info @iridris. I actually looked this over a few minutes ago and I’m SOOOOO glad I remembered this Welcome Code blocker before I even went ahead with whatever reset Support wants me to do.

On a good note, since I’m a gmail user, I was able to use the plus sign method to create a new Samsung Account that still goes to my email, but to Samsung, is a completely new account / address.

I’ve replied to support that I need the Welcome Code. Based on their current turnaround time, I’m guessing it’ll be another two weeks before I get an answer. Yay!

1 Like

Honestly in your situation I would order a new Hub. Basically any, I mean either a v3 or a Hubitat Elevation and jump ship. 99.99% that the v1 Hub is going to be discontinued. Look at the announcements, and when they received last a new firmware.

We are in Phase 1 now.

1 Like

If your going to go through all this, might be time to look at other hub solutions then.


UGH. I didn’t know there was some sort of planned transition. I wonder if there’s a way to flash the ST hub to work with something else, when things get to that point. I love ST but I don’t know if I want to drop more money on another piece of hardware.

The hubs are pretty cheap and v1 is definitely too old to be fooling around with.

1 Like

Depending on the transition path that Samsung presents, I’ll have to decide what to do. If I can get a good discount on a V3 hub, then I may do it. But it may serve me better to get a Pi and begin tinkering with HA or Hubitat or even working on a way to get things integrated with Homebridge using a basic hub (again, with a Pi).

1 Like

I’ve just read one of your old posts back from 2015, it is almost like reading posts about the current situation.
If you still have WAF, then you might better go with Hubitat. It might would take less time than Home Assistant. But it really depends on WAF and the time what you want to waste on it. Now there is no escape route. You have yo redo lot of things to make it similar how it was before…