Super frustrated with Iris Garage Door opener and and Linear Go Control

I have tried installing both the Iris and Go Control Garage Door openers. Its always the same problem. I connect them to the hub they can tell me if the door is open or closed but when I try to open or close the door it won’t work. I get the 5 beeps and it won’t operate the door. I have tried troubleshooting per the instructions switching the wires and it won’t work. It seems they are the same manufacturer. I returned the Go Control and bought the Iris from Lowes in the hopes of better customer service but it has been horrible.

Has anyone run across this problem and successfully trouble shooter this problem?

Thank you

1 Like

What kind of opener do you have? If it doesn’t have just a simple wall push button then the Iris/Go Control units won’t work.

1 Like

Its a brand new chamberlain HD210 with a simple button

hmm, looks like it should work. Post up a picture of where you have the wires connected.

Yes, check your wiring again. I had the same problem with my Genie opener, til i figured out the builder used 2 different kinds of wire, but not in a logical manner-- ie he used a dark brown sheathed wire for left side optical sensor, and a light brown sheathed wire for the right-side optical sensor and the one coming from the push button opener.

Of course i assumed the two optical sensors would have the same wire. oops.

Hi Jamie, Im not sure I follow what you are suggesting. There are 4 holes for wiring the 2 on the left are for the open close function which is also where I have wired the opener into and the 2 on the right are for the sensors. Each of the sensor holes has two wires coming into it 2 white ones and two red ones. Are you suggesting I place the Iris wires in the sensor holes?

This page says that the opener is compatible with the MYQ system. I don’t think those work with the IRIS openers. I looked at the manual and it says something about synchronizing the opener control and you may have to press the button up to three times. So I don’t think it’s just simple push button control.

I am just guessing though. If the controller is flashing that means it is getting it’s signal, so it sounds like a simple open close on the button is not what it needs. Might want to contact Chamberlain to be sure.

I had the sensor orientated incorrectly which did not only the sensor to work correctly. I also had an issue with the “floor laser sensor” wire not being connected all the way which for some reason allowed the door to work without the door controller but when I connected the door controller it wouldn’t work.

Once sorted out, I have had zero issues.

See this thread. You have a little additional adapting to do.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.