Sun Calculator suddenly way off (Smart Lighting, etc.)

smartlighting
sunset
scheduling
sunrise

(Jeffrey Cooper) #1

Last night Sunrise was triggered at 11:30pm. This morning,sunset was triggered at 11:30am. This has been the one reliable part of SmartThings for the last 3 years. Anything up with that that anyone knows about?

Thanks,
Jeff


Routine running on UTC instead of local time
Routines and Time Issue
ST on time machine
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Same observation here.

My Smart Lighting: sunset - 15 minutes based trigger just went off 20 minutes ago at 11:20am PST. Though we have a lot of smoke here in San Francisco, it sure ain’t “sunset” :city_sunset:.

Sigh… :confounded: :worried:

I have submitted report to Support@SmartThings.com ; Ticket #431057


Another Smart Lighting instance set for exactly sunset seems to be OK, because it uses the Location object trigger Event rather than than the other sunrise/sunset scheduler; I guess.


(Bobby) #3

yey, first routine failure here too…in gosh, I don’t even remember, since April or so?.. Great run, though, I must say :smile:


(John C) #4

Also had this failure: one of several Smart Lights automations turned on my living room light. However, other automations set with different sunset-plus-offset values didn’t fire. Like all of you commented, this has been running faithfully for years.

The implication (to me) is yet another random event in the SmartThings eco structure. Some of you may recall my story of the door sensor reporting ‘open’ on a door that remained closed.

Anecdotally, it would seem there are some things basically wrong in the ST architecture. It must be extremely frustrating for ST support & engineering to hear these claims and have no answer to the question, “Why?”


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #5

https://status.smartthings.com/incidents/l8tj56w196kk

Scheduled SmartApps triggering hours ahead of time
Investigating - Some users may see their Routines or other scheduled SmartApps triggering earlier than scheduled. We are currently investigating.
Oct 14, 16:07 EDT


(John C) #6

To follow up: when arriving back home after sunset, the house was dark. Nothing came on. Asked Alexa to do it and she did.

Reviewing the logs now, nothing makes sense. A random assortment of on and off commands.

Hopefully we aren’t woken in the middle of the night :rage:


(jkp) #7

ST appears to have just resolved an issue where scheduled SmartApps/Routines executed early

https://status.smartthings.com/


(Allan) #8

I’ve been having this issue for a couple weeks but haven’t looked into it. I have a Smart Lighting routine that says when my garage door opens turn on the outside garage light only when between sunset - 10 and sunrise + 10 then turn off 10 minutes later. It has been coming on 4 or 5 hours early. My front porch light which is a simple turn on sunset - 10 and turn off sunrise + 10 works fine. A third routine turns on a kitchen sink light on motion after sunset and before sunrise which also works fine.

No idea why one of my three routines based on sunset/sunrise has issues and the other two don’t but I haven’t contacted support about it yet until I can really test and watch it happen. It’s “almost” like the one routine is ignoring the timezone but I still have to verify.


(Jeffrey Cooper) #9

I’ve seen cases of “this one works, that one doesn’t.” I have multiple motion sensors tied to lights in different rooms with a 5-minute stay-on window. One works just fine- if motion persists (I am in the room for a while), the light just stays on. The other, in my garage, turns off at 5 minutes, and won’t turn back on again for about a minute. Both triggers are the same, both stay-on durations are the same. But they behave differently. This system is full of all kinds of weirdness.


(www.rboyapps.com - Make your home your butler!) #10

Looks like this was resolved recently:

New Incident Status: Monitoring
We have resolved the issue causing scheduled SmartApps to execute early, but many SmartApps may still be scheduled for the incorrect time. After running once, the schedule will be set for the correct time moving forward.

However, you can manually force the schedule to update to the correct time by going to the ‘Automation’ page in the SmartThings app, navigating to ‘SmartApps’, tapping on the SmartApp you need to re-schedule, and simply hitting ‘Done’ on the upper right. If it’s a Routine, you can do the same by going to the ‘Automation’ page and tapping the gear icon, then tapping ‘Done’ on the upper right.
Oct 14, 20:08 EDT


#11

im having the same issues. automations running hours before they should… stuff is just broken.


#12

resolved? you posted that 19 hours ago, and it still happened to my this morning at 6am… stuff scheduled to run at 11am happened at 6am waking everyone up.


(jkp) #13

I was simply reporting what the status page was showing - with a link to the status page. :slight_smile:


(www.rboyapps.com - Make your home your butler!) #14

You need to reinitialize your SmartApp and routines to get it to correct the schedule:

New Incident Status: Monitoring
We have resolved the issue causing scheduled SmartApps to execute early, but many SmartApps may still be scheduled for the incorrect time. After running once, the schedule will be set for the correct time moving forward.

However, you can manually force the schedule to update to the correct time by going to the ‘Automation’ page in the SmartThings app, navigating to ‘SmartApps’, tapping on the SmartApp you need to re-schedule, and simply hitting ‘Done’ on the upper right. If it’s a Routine, you can do the same by going to the ‘Automation’ page and tapping the gear icon, then tapping ‘Done’ on the upper right.
Oct 14, 20:08 EDT