Sunset Automation not functioning in SmartApps

sunset

#1

I have been trying various combinations of things to get this to work but it still is not.

Using the SmartLighting I have set up an Automation to turn on my outside lights at Sunset. This is not working. What the Automation does is turn the lights on at 4:05/4:06pm daily. Other aspects of the Automation are fine… like only running M-F. I have tried using the Offset at different amounts, nothing. Most recently I set it to a specific time, 6:20pm, still fired at 4:05/4:06pm. My alternative is to go to IFTT, but I would like to keep it within the system itself, if i can get it to work.

Almost forgot, my hub does have a location set up via the mobile app, since we are using the presence detection for some other automations. This geofencing with the hub is working fine.

Am I missing something? Any thoughts or suggestions would be appreciated?


(Ron Talley) #2

Do yourself a favor and install webCoRE and never look back. SmartLighting has the advantage of running local if all of the devices are local but other than that, I no longer see any benefit of using "Smart"Lighting as it has turned out to be pretty “Dumb” and basic for me.


#3

Thanks for the Info… Got it installed, and just finished writing the basic Piston to perform the action at Sunset. See how this goes tomorrow.


(Allan) #4

I have 3 different Smart Lighting automations all using sunset/sunrise and all work just fine. If you decide to go back to local control I’d contact support and see f there is something weird with your setup.


#5

So, apparently I have something else going on. Because at 4:06 today the lights came on again. The interesting thing is that I had deleted the Sunset Automation right after I finished up with the WebCore Piston. So unless there is some remnant of that automation that still fired today, then I have something else that is doing it.

My WebCore Piston fired just fine btw. Thanks, rontalley.

Another small twist to this is that I had completely forgotten about an automation I setup back when I first got the hub, which turned on the Living Room light at Sunset… This automation has always worked and continues to work to this day.

So you may definitely be onto something vseven about some oddness with my setup.

Thanks for all the feedback.


#6

If you open one of the devices in Things that came on at 4:06 and then select the SmartApps tab, you will see every single automation (ST) you have that is tied to that device.

Are these bulbs that you are turning on? If so, what kind? Just wondering if you have something like Hue or LIFX that you may have set a scheduled routine up specifically in the app for those bulbs.


(Tony Fleisher) #7

Sounds like you might be setup with the wrong location/timezones. You can go into the ide and look at your location details for your hub to see the coordinates and timezone setup for your location.


#8

Just checked that per your suggestion… I have WebCore, the WebCore Piston, A Simulated switch (just On/Off, no timer), a schedule automation to turn the outdoor lights off at 2:30a (this functions fine) and “Notify Me When”. That’s it.

As far as bulb types… 2 Sylvania Flood lights and a Cree bulb (all outdoor rated).


#9

Checked that one already and it is correct. It even displays the Sunrise and sunset in the Hub UI on the website and the times are correct for my area.