Routine running on UTC instead of local time


(Don Caruana) #1

Anyone notice any routines running UTC instead of local time? I have a simple “Lights out” routine that runs at 11pm. Tonight it ran at 7pm. But that’s 11pm UTC. I have another that runs at 8am and it ran then this morning.

Just me or anyone else seen anything like this?


(jkp) #2

Investigating - Some users may see their Routines or other scheduled SmartApps triggering earlier than scheduled. We are currently investigating.
https://status.smartthings.com/


(AB) #3

I am observing the same behavior.

The first time for me appears to have occurred with a ‘sunset’ event occurring at 1:59pm.


(John C) #4

Probably related…


(jkp) #5

ST appears to have just resolved an issue where scheduled SmartApps/Routines executed early
https://status.smartthings.com/


(Tito) #6

I had same issue today. Instead of 11:58 PM, it triggered at 7:58 PM, all time local, EST


(John C) #7

Also just experienced ‘Good Night’ being executed 5 hours early. Sigh! :pensive:

Updating routines & will see if ‘Good Morning’ runs tomorrow at the correct time…

Human Error, do you suppose?


(jkp) #8

I go with @JDRoberts theory…


or
Pennywise!
images


#9

Nope - not fixed. I only have three ST routines set on timers, two are for sure still wrong, I’ll validate the third in a few more minutes. Here are the three:

  1. Set to sunset + 5min modifier. This executed at the wrong time yesterday… it should have run at 2017-10-14 @ 18:19 Pacific Time, but instead it ran at 2017-10-14 @ 12:19 Pacific Time which just happens to be 18:19 UTC. I definitely noticed it at the time but assumed it was a random fluke and did no further research. I’m reasonably sure this was the first incident.
  2. Set to a strict clock time, 06:03 Pacific Time. This just executed a few minutes ago, I looked in forums, I found this thread. For the record it happened at exactly 06:03 UTC time so this is almost certainly just a bug with timezones.
  3. Set to sunrise + 5min modifier. I do not recall this having been triggered incorrectly… I think it should have. Also, by my math this will go wrong about 35 minutes from now.

edited to rearrange in chronological order since I think that makes a bit more sense


(llcanada) #10

@lkjsaendlkje I still having the same issue that you are having. The timing still off this morning and routines going off earlier than they should? Hopefully it will get fix.


(DLee) #11

As our four master bedroom blinds opened in all their noisy glory at 3:30 am this morning, I realized just how little ST has improved over the past 3+ years.


(Don Caruana) #12

My 8am routine ran at 4am AND at 8am…


(Don Caruana) #13

Check out the link that jkp included above. It says, as of last night, the routines would probably run one more time incorrectly and then reset properly. Or you can force it, via their instructions.


(DLee) #14

“probably run one more time incorrectly” is an unacceptable solution for a known time configuration bug of this nature. ST should have a better solution to resolve after all these years.


#15

My routine to turn on lights was supposed to run at 3:20 am, but it ran at 11:20 pm four hours early.


(John C) #16

Did these steps last night & all is back to normal this morning.

That being said, I would have been miffed if I hadn’t seen the posting & followed those steps…


(John C) #17

Absolutely true. That’s why it’s Not Ready for Prime Time. Yet. :neutral_face:


(www.rboyapps.com - Make your home your butler!) #18

See this message from ST:

New Incident Status: Monitoring
We have resolved the issue causing scheduled SmartApps to execute early, but many SmartApps may still be scheduled for the incorrect time. After running once, the schedule will be set for the correct time moving forward.

However, you can manually force the schedule to update to the correct time by going to the ‘Automation’ page in the SmartThings app, navigating to ‘SmartApps’, tapping on the SmartApp you need to re-schedule, and simply hitting ‘Done’ on the upper right. If it’s a Routine, you can do the same by going to the ‘Automation’ page and tapping the gear icon, then tapping ‘Done’ on the upper right.
Oct 14, 20:08 EDT


(Kevin) #19

Just had my sunset routine run again many hours early at 12:12 instead of say 6:12. I even did the work around they said would help last night. I went into Smart Lighting and hit done last night prob around 9pm or whenever they posted it on the status page. So I dont know if this is totally fixed or not…


#20

I’m all good now. My morning routines happened as expected today. I did not do anything to “flush” the bad schedules, for the record.