Sudden erratic behavior - V2 hub

I was away from home for a bit over 24 hours (about 27, to be exact). Everything was working fine when I left home.

When I came home, all sorts of lights were on. We had left someone working at the house, so I figured they just hadn’t turned the lights off. But on further investigation, I found that anything that is beyond the physical on/off of a switch is either not working, or working sporadically.

We use Amazon Echo a lot. “Alexa, turn on Kitchen Counter.” Alexa says “OK”. Nothing happens. Smarthub log shows command received from Alexa but does not show any on/off action. Or, sometimes, the light goes on, but only after a long delay. (Yes, beyond any kind of reasonable cloud delays - I’ve been there before.) From the smartphone app, the new version just hangs for a while and then pops up “A network or server error occurred. Try again later.” The classic app just does nothing. Except that sometimes they work, though usually with a delay.

Other local routines don’t work at all - in the Smart Lighting app, I have two rooms which have automations that say:

  • Which devices do you want to control? < list of smart lights >
  • What do you want to do? Mirror Behavior
  • Mirror which switch? < name of master switch >

Neither one works anymore. And, most (but not all) of the lights I found on when I returned home were the ones controlled by these two automations, so I suspect that the person here working tried to turn them off but it wasn’t working. (Update, about 20 minutes later - now at least one of them is sometimes working.) (Update 2, about 10 hours later - I should add that the smart lights being controlled by the automations are able to be controlled individually via the smartapps, so the hub is clearly able to communicate with them.)

I have a contact sensor on the closet door. Open the door, light goes on; close the door, light goes off. Can’t be any simpler. Except now nothing happens.

I’ve done Z-Wave repair on the hub several times. I’ve rebooted the hub several times, both from the hub utilities in IDE and by power-cycling the hub (including removing batteries). I’ve power-cycled my WiFi router.

I can go into the Alexa app and “forget” all the devices. It then successfully discovers them again. I had noticed recently that once in a while, when I said “Alexa, turn on Stairway LIght” (for example), Alexa would respond “Stairway Light isn’t responding. Please check its network connection or power supply.” But if I tried again, it worked. I have at least one switch right now that I am consistently getting the “not responding” message on from Alexa.

The only thing I’ve seen that seems at all out of the ordinary is the following in the hub event log after I reboot the hub:

Does anyone know what it means?

All that’s left that I can think of is that the hub has just plain gone bad. I’m really hoping that’s not the case, but I’ve ordered a new one (V3) that is supposed to be here Tuesday (it’s currently Sunday evening). Besides the hassle of replacing the hub, I’m going to be traveling next weekend so I’d be under the gun to get everything back up to speed. I assume I have to rediscover all the devices on the new hub? And reauthorize everything to SmartApps? And fix a whole bunch of WebCoRE routines that will be broken?

Tell me what I’ve overlooked that will fix the issue quickly and painlessly.

SO . . . .

I have a new V3 hub. I couldn’t get any kind of device exclusion to work on the old hub, so ultimately I just did a hard reset on it. Devices were still visible in the IDE (as I recall, that was several hours ago now) so I deleted them there.

Connected up the new V3 hub. Nothing would connect, so I tried doing device exclusion. Every time I run it, even though I’m doing the correct reset action at the device (i.e., tapping the up “on” side of my GE paddle switch, or triple-tapping my Zooz switch), SmartThings comes back and says there was nothing to exclude. But I’m still unable to pair Z-wave devices. When I try to pair them, the system log just shows me line after line of this:

7156c1c3-c896-4891-bf13-75ae9e20ce78 7:47:00 PM: debug No devices to add, verified devices: [:]
7156c1c3-c896-4891-bf13-75ae9e20ce78 7:47:00 PM: debug detecting status for dca9119e-7f6e-4e28-92a7-f5f9e3001656 : true
7156c1c3-c896-4891-bf13-75ae9e20ce78 7:47:00 PM: trace in ssdpDiscover
7156c1c3-c896-4891-bf13-75ae9e20ce78 7:47:00 PM: debug scheduled run, numberOfRuns: 11
7156c1c3-c896-4891-bf13-75ae9e20ce78 7:47:00 PM: trace in discovery

Zigbee devices (my Iris motion detectors) pair with no problem.

Now what??

Sure is quiet around here. :wink:

For no obvious reason - beyond the obvious that perhaps I was just doing things wrong earlier - all of a sudden the Z-Wave exclusions worked and I was able to add in all my devices. (I still have a few that I just haven’t worked on yet.)

For some reason, 2 of my 3 Stelpro Zigbee thermostats don’t want to connect. But I’ll just keep plugging away at them.

This seems similar to the issues I’m having also. Most of my issues seem to be with the Smart Lighting automations also. I just created a new thread and then stumbled up on this one. I pasted it below if you want to see the details, but sounds very similar.

Hi, @philly33flyers, almost all of my automations are through WebCoRE. The two very simple ones I have using SmartLighting were not causing me problems. Sorry, I know that’s not much help to you.

WIth regard to my own problems, I suspected the Zwave module on my V2 hub had gone wonky, though I had no way available to me to prove that. I mainly worked through whatever other possibilities I could dream up until that was the only one left.

One thing I’d strongly suggest you do is to go to the Device List in IDE, and examine the Event Log for each of the devices involved in the automations. That should tell you whether a command was sent from or to each of the devices. If a command was received, but not executed, then you have device or connectivity problems. If no command was ever sent to the device, then the problem is probably within the automations.