Help! My smart switches all turn off at 1AM!

First time poster, forgive me if I’ve picked the wrong thread category, etc. I’ve been living happy with my Smartthings home for about 2 years now and everything has been going great!

Until recently. I don’t exactly know when because I’m not usually up at 1am, but it seems to have coincided with a recent app update when my hub started having issues connecting to the cloud (now resolved with some reboots). I think it’s just been the last few weeks otherwise I would have noticed a disconnected Ring camera.

I’ll get to it: every day at 1am every zwave device I have that’s on, turns off. Not exactly 1am; when I go into the IDE it’s 1am and 29 seconds or 40 seconds or 31 seconds depending on the device.

I can’t find a single link between devices except zwave. I mostly use Zooz Zen27 switches, but I also have two zwave smart outlets (different brand I can’t remember) that are doing the same thing. Every zwave device that’s on, it seems, turns off at 1am. No other types of devices are affected (wifi Kasa plugs, other wifi plugs, linked Logitech Harmony devices, etc.). Some devices are part of “smartlighting” automations (turn on/off at sunset/sunrise respectively) but others should be on 24/7 and have never been part of any automations (security camera for instance). No notable events in the hub log (disconnections, etc.), and the device events just say they were turned off. Looks like my hub is hardware V3.

I’m just at a loss of what to do. This is a relatively serious security issue; all my outside lights, a Ring security camera, landscape lighting, and all inside lights turn off in the middle of the night when they most need to be on! I have made no new automations and added no new devices for quite some time. I use Alexa integration, but there’s nothing in the Alexa history about turning off these devices. The IDE history can’t seem to tell me anything about what triggered the events and while all are between 01:00 and 01:01 the random seconds involved has me a little puzzled. I have round about 27 devices in total and so burning everything to the ground and factory resetting is really not an ideal option.

Can anyone suggest some troubleshooting steps, or any way to track down what’s triggering these events? I’m headed out of town next month; this just can’t happen when I’m gone. It’s just crazy to me I’ve made no changes in smartthings, I haven’t even opened the app until recently, and after 2 years suddenly everything is going haywire! Thanks!

I don’t really deal with Alexa much. If Alexa did do it would it be obvious? I just turned a light on using Alexa and I don’t see it 'fessing up anywhere. Could Hunches with automatic actions do that sort of thing, if indeed you have them enabled?

Otherwise the options include:

  • Using the device pages in the IDE to identify legacy apps that subscribe to the devices and so are capable of controlling them.
  • Watching the Live Logging at 1am in case anything legacy based triggers and also logs anything.
  • Using the mobile app history (the Menu > Settings > History one) to see if anything Rules based was running at the time - it should show Rules, Scenes and Automations that activate.
2 Likes

As it is all Zwave, I would suspect and All Off Zwave command, or whatever it is called. But I have no clue how someone could find that.

1 Like

@kypdurron5, Have you got any automation or device which should turn off at 1 AM? If you do so, then turn off that automation or unplug that device. If a Zwave all off command is broadcasted then all device which accepts it will turn off. Either a device sends it or the Hub sends it.

1 Like

Alexa: yeah her history section is a little bit sketchy for some reason. However there’s also a voice history that’s really comprehensive so I can at least say Alexa didn’t think she heard anything. I only use Smartthings for automations.

Legacy Apps: I’m interested in looking into this, but I can’t seem to find listed subscriptions in the IDE, can you direct me more specifically?

I’ll definitely try the live logging next time I can stay up that late!

As for the mobile app history thanks, I didn’t realize that was there! It does give me a complete list of the devices, however it just says swith:off. I checked my “smartlighting” app controlled devices at sunrise and sunset and it says the same thing for those too so I don’t think I can get anymore info there.

I do have several automations but I’ve looked at all of them and the settings are correct, no extra devices or different programming. And to answer your question, no, I’ve never had any device turn off at that time on an automation. I haven’t edited an automation in many months either.

If you go into My Devices and open up a device page it shows the legacy SmartApps that are using the device at the bottom. It calls it the ‘used by’ section but it is basically the list of the apps that subscribe to it.

1 Like

Thanks; it’s completely blank for some of the switches and only has my Sunset/Sunrise automation for the rest. So again, just nothing in common between these different devices other than zwave. That I’ve found yet anyway. That’s the confusing part to me; if they’re not being controlled by any automation or app, how can they possibly turn themselves off?

The Ring base station and sensors are zwave, but the cameras are WiFi (zwave messages aren’t large enough for video, so there are no zwave cameras).

So if your camera is also turning off, it’s not just zwave. :thinking:

My first guess also would be Alexa hunches, they just aren’t working very well yet. And turning off a bunch of devices at a fixed time late at night seems to be the most common error. So that’s the first thing I’d check.

https://www.amazon.com/gp/help/customer/display.html?nodeId=G7F5F7K93GKSLC4F

If you turn off hunches and that doesn’t fix it, and you don’t have any automations or Alexa routines or other integrations that might be causing it, my own next troubleshooting step would be simple:

Remove one of the affected lights from your ST account. Add it back with a different name. Don’t put it in any automations or scenes yet. Don’t add it into any other integrations you have. Disable it in Alexa. Now observe. If the other devices still go off at 1 am and this one doesn’t, it’s something about the home automation system.

If the test device ALSO turns off, it’s more likely local interference or a bad device (although a system flaw is still possible).

3 Likes

I understood from the OP that the camera is connected to a plug. Maybe my misunderstanding.

If only Zwave a All Off command could explain it… but really that would cover the system flaw.

(I honestly cannot believe that interference can cause anything like this. Maybe drop connection but not an off command.)

2 Likes

I agree dropped connection is much more likely. It’s definitely a weird situation. :thinking:

1 Like

Thanks I’ll give that a try and see if I can watch the live logging tonight.

To be clear, the Ring camera is wired on a zwave light switch. That’s because it used to be a normal light fixture, so it’s just the switch being turned off that’s affecting it, nothing else. I haven’t had an issues with my zwave ring sensors but that’s a completely different network and hub.

In terms of interference I’m open to all options, however, in the logs there have been zero disconnections of devices. Literally all I see from multiple sources is just that switches were turned off, no further explanations. It’s reflected in the app in real time, and they all turn back on from the app without delay. I can’t say with 100% certainty that every switch/outlet is affected because I don’t leave every light in the house on. Only the devices turned on show up as being turn off. This includes many Zooz zen27’s, a few zen22’s, a GE enbrighten, and 2 smart outlets on the outside of the house for the landscape lights.

1 Like

OK. There was a community member a few years ago who had a similar problem with his Z wave devices, but he never did figure out what was causing it. (I know, very frustrating.) I myself had a problem which I reported in the forums of a Z wave lock unlocking itself every day at about the same time. Never did figure that one out either, in spite of senior smartthings engineers looking at it.

Eventually I took that lock off of smart things and put it on a different Z wave hub and never had the problem again. So for my own particular case, I came to the conclusion that it was a cloud artifact. I know that’s not much help.

I believe the other community member ended up rebuilding his whole Z wave network and then it was OK after that. Not, I know, what you want to hear. :scream:

But let’s hope there’s just a random routine or automation and the test with the isolated device will turn that up.

1 Like

And don’t forget to mention the ghost automations, what many people complained about at some point back in 2019.

2 Likes

Ok! I did what you said and also have my live logging. I’m not sure it helps. Without spamming the whole thing, here is what I’m seeing:

All the zwave devices get parsed every 15 minutes starting on the hour. All code below is bottom to top in order.

At 1AM for a smart outlet that was on (and now turned off) it looks like this:

1‎:‎00‎:‎45‎ ‎AM: debug Parse returned [Landscape Back Security switch is off]
1‎:‎00‎:‎45‎ ‎AM: debug parse() >> zwave.parse(zw device: 17, command: 2603, payload: 00 00 00 )

The only difference between this and a normal parse say at 01:15 is that the command changes to 2003. The 2603 command above is the same as when I manually trigger a switch on/off.

So you asked about removing and re-adding a switch with a new name. At the 1AM mark this re-added switch remained on and the parse looked like this:

1‎:‎02‎:‎39‎ ‎AM: debug Parse returned [Zooz Zen27 Dimmer v2 switch is on, Zooz Zen27 Dimmer v2 level is 100%]
‎1‎:‎02‎:‎39‎ ‎AM: debug parse() >> zwave.parse(zw device: 1D, command: 2003, payload: 64 63 00 )

This is what every “normal” 15 minute parse looks like for a switch that’s on. Command 2003 and payload 64 63 00. If the switch is off payload is 00 00 00.

When I manually turn a switch off it gets command 2603 and payload 00 00 00.

Another difference between 1AM and normal parses is that first this shows up (this is also true of manual on/off commands but not normal parses):
1‎:‎00‎:‎39‎ ‎AM: debug dimmingDuration: 255

Regarding 1AM there is no code before or after these parses. So, as far as I can tell, all this is telling me is the switches are being turned off at 1AM with no further information about why, which I already knew.

In terms of the re-added switch, it performs normally like it should. So, it seems the switches are being turned off…by something. It could be a ghost routine. But, it’s also super odd all the parses start around 40 seconds (ex 01:00:39 or 01:15:43). If there was some errant routine doing this, then why does the 1AM mass turn off follow the exact same pattern rather than a random time or a nice round time instead like 01:00:00 on the dot? This gremlin happens at a normal parse time but just shuts everything off instead.

Have you tried performing a z-wave repair from the IDE? Take note of any messages that are generated. I can’t remember if you have to click anything to observe the messages once the repair starts. The IDE should essentially tell you if you need to click anything after you start the repair.

1 Like

I did a repair yesterday but just repeated, no errors in the app or live logging.

Yes, I’d say so.

So did you rule out Hunches on Alexa?

3 Likes

@kypdurron5 - Any chance you have a Z-Wave usb stick plugged into a PC as a secondary controller? I have heard of other users experience the same problem, not realizing that a secondary Z-Wave controller was the cause until they unplugged it from their PC.

2 Likes

@orangebucket OMG you were right all along. I previously looked through the Alexa histories and even looked for “hunches” although it’s something I’ve never heard of or enabled and I couldn’t find any tabs for it in the app.

Well, the one thing I didn’t do was click on routines, because, why? I don’t use any Alexa routines and haven’t touched that tab.

And there it was. On June 30th Alexa took it upon herself to autonomously make a routine to turn every “light” off, because why would anyone want lighting around their property at night? :exploding_head: It looks like hunches is buried in the Alexa privacy settings and is enabled by default. To make its own routines to control things on its own without permission with zero logging that it doesn’t even know for sure what it’s controlling. What a stupid idea.

Anyway, thank you everyone for helping me work through this; really glad to see the Smartthings community is alive and well despite Samsung dumping the hardware!

6 Likes