Strobe Only Alarm Fortrezz ssa2 SHM


(David Ehrenberg) #1

I attempted to search but could not get a definite answer. I am looking to have strobe only response to an alarm. In SHM I currently have it set for Alert with lights(Strobe) and nothing for Alert with sound and when alarm trips still get sound and strobe. Does anyway have a solution to correct this condition.

Thanks


Handler for Fibaro Siren
#2

Hi @David_Ehrenberg,

If the device is using ST’s default device handler (zwave siren), it will always trip the siren and strobe because the DH doesn’t differentiate between strobe and sound. ST’s device handler sends either all on (0x00, or 0) or all off (0xff, or 255).

I looked at Fortrezz’s documentation on this siren, and this is possible with ST:

Controlling the SSA1 (MultiLevel Switch Command Class or Basic Command Class)

If a Z-Wave MultiLevel Switch Set or Basic Set signal with a value of 67 to 99 or 255 is received by the SSA1, the unit will sound a 117-decibel
audible alarm and will flash the strobe lights. A value of 1 to 33 will turn on only the strobe lights while a value of 34 to 66 will turn on only the siren.
The same messages with value 0 will turn off both the siren and strobe lights. Or, the SSA1 can be turned off locally by quickly pressing the button
three (3) times. The SSA1 only returns 0, 33, 66, or 99 in response to a Multilevel Switch Get or Basic Get command depending on the mode.
With a controller, the status of any SSA1 in the network can be checked. A gateway controller’s remote access capabilities may allow you to control
or to check the status of any SSA1 in your network from a remote location such as from another city, state, or country. 

You could create your own DH (copy ST’s exactly) so that when “strobe only” command is sent from the app or smartapp, it sends an 0x21 value to the device to turn on just the strobe. Here’s the snippet of their code modified to do that:

def strobe() {
	log.debug "sending stobe/on command"
	[
		zwave.basicV1.basicSet(value: 0x21).format(),
		zwave.basicV1.basicGet().format()
	]
}

All I did was change the value from 0xFF to 0x21.


(David Ehrenberg) #3

I took a look at that code and it currently has the ox21 already inserted so I guess thats not the issue but thanks

This was already in place

def strobe() {
[
zwave.basicV1.basicSet(value: 0x21).format(),
zwave.basicV1.basicGet().format()
]


#4

Which device handler are you using?

The app could perhaps only be sending “on” or “both”.


(David Ehrenberg) #5

I am currently using the default SmartAlert Siren device handler. If I am making a mistake please bear with me I am relatively new to smartthing devices.

Dave


#6

No worries @David_Ehrenberg, that actually is the best choice for the device handler for your siren, and was probably picked up properly. No mistakes at all!

OK, I think I figured it out…

The “Alert with Lights” isn’t really meaning the strobe light on the siren, but actual light switches. The reason why your siren shows up in that list is because it has switch capabilities defined in the code:

capability "Switch"

Unfortunately, SHM “Alert with Sirens” only does both the siren and strobe.

So why does the siren fire up when you have your siren in “Alert with Lights”? Easy! Remember, because it has switch capabilities, SHM sends an “on” command to the siren thinking it’s a light but the siren treats it as turning everything on.

Make sense? No mistakes on your end at all. You were just expecting a little more out of SHM that it’s capable right now.


(David Ehrenberg) #7

Ok thanks makes sense but if I edit the following:

def on() {
[
zwave.basicV1.basicSet(value: 0xFF).format(),
zwave.basicV1.basicGet().format()
]

and replace 0xFF with 0x21 do you think I could just activate the strobe?

Dave


#8

Ha! I was just think the same thing @David_Ehrenberg!

If you keep the “Alert with Lights” set up, it would do just that. Won’t hurt to try.

Typically, other apps that trigger the siren would send the “both” command, so you should be OK. If you find that your siren doesn’t go off with other SmartApps, you may have to go back to the original value.


(ilker Aktuna) #9

Hi,

I ordered one Fortrezz Siren (SSA1) which seems to be in the compatible products list.
While waiting , I want to try some smartapps on a simulated device.
So I would like to add it through IDE.
However, I can’t find any Fortrezz siren device handler. There is only one default siren handler.
Is there a special Fortrezz Siren handler ?


(Andrew Morris) #10

Any luck with getting only the Strobe to turn on? I am looking to use a Fortrezz SSA-2 respond to a Samsung Water Leak detector with a strobe when the detector condition is “Wet”. Any help would be appreciated.


#11

Searching came across this old thread. Great stuff got the On to mean strobe only with the suggestion above in IDE. The only issue is that the Strobe light seems interminable or I didn’t wait long enough, I wonder if there is a way to time limit, say to strobe only for a minute or so. I have to go into the app to turn off the Strobe through My things. I created a new routine called Turn Alarm Off and since it is my widget, gets me a bit quicker to turn off.


(Daniel Marcotte) #12

i just install a SSA2US a week ago and it is currently possible to active only the strobe, only the alarm or both. I use the device Handler : SmartAlert Siren

I triguer what i want with WebCoRE piston or directly in the SmartThings app

for those who want a ssa2, go and buy it