STOPPED WORKING - KOF Zigbee Fan Controller - Light Child Device

Power went off and i had to log back on smartthings app again. Everything works except custom driver. It shows up, just doesnt do anything. Any ideas? Does it need to be “activated” again somehow?

This happened to me, too, and I tried deleting it and having it recreate and it just does not respond to ST. It responds great to the remote.

After the Smartthings outage, one of my KOF fans works perfectly, but the other does not. The remotes (hand and wall) work fine, but tapping the buttons in ST changes the setting, but doesn’t affect the light or fan.

[EDIT] May have spoken too soon…looks like neither fan is connecting now.

Go into the main fan device, go to settings, change the name and tick the “delete & recreate all child devices” toggle, then save. See if that fixes it. If so, just go back in and repeat the process to change the name back.

When the directions say “Child Devices must be removed from Smartapps first”, does that mean I remove them from within the apps themselves, or uninstall the apps under the Smartapps tab?

That means you have them included in some sort of automation. You can view the fan light device in smartthings then click the smartapps tab at the top and it will list what it is included in. Remove from those smartapps and try again.

Still getting “Unexpected Error”. Not sure what else I can remove them from. Guess it’ll have to wait until I get home. I’ll delete them from ST, unplug the controllers, and just reconnect/reinstall them again.

dang it. i removed the whole thing. how do i add it back?

Switch off the fan, switch it back on, and tell ST to look for add device.

You have to switch power (not just the fan, actually cut power) on and off 5 times to remove the pairing. The lights will flash if it successfully deleted the pairing. Then search for new devices in chatting and press a few buttons on the remote and it smartthings should find it.

That’s kinda what I meant, should have stated it better. That said, I only had to cut power once to find the device. I thought the “5-times” process was if you were turning it off with the remote.

Okay, removed both fans from ST, disconnected and reconnected power to both, and readded both to ST. They are working perfectly now. :slight_smile:

2 Likes

got it working again. thanks. hope I dont have to do this every time power goes out.

Yep having the same problem. I did find out that , in spite of it not working with the Smartthings app (iPhone), it still responds perfectly if I as Alexa to turn it on, off or change speeds. This indicates to me the handler is working, just not with the iPhone app

Hey guys - I am very new to ST and I am trying to trying to add my new Hampton Bay fan, and I can get the Device Handlers added (using Github), and I have installed the SmartApp, but I can not get the child items to create. I have tried “deleting them”, and hitting refresh twice, but no luck… any suggestions?

I just tried to install KOF Zigbee Fan Controller the fan and light child devices
as device handlers.

On my Android, I opened App and things. Where do I find device to add?

Any help will be highly appreciated.

Had the same problem. Accidentally removed ceiling fan. Re-paired in ST. Re-attached in Alexa, but doesn’t show up in Google Home or add device in Google Home. How do I get it working again in Google Home?

No one seems to be responding on this forum anymore. Is this forum dead?

1 Like

My fan connection is all jacked up now… tried deleting from ST, now each time I try to add back it gets discovered as “thing”… & I save, but it’s empty. No child devices are nothing.

Update - forgot I had to go to IDE & add the handler back to the device :wink:

No one has responded to my question in weeks. I don’t know what’s going on. If they don’t know the answer, it would be nice if someone just said there is no answer.

I wonder if the classic app is not being supported any more. I couldn’t get a Sengled bulb to pair last night. However, I don’t think the KOF driver works with the new ST app. Have you tried it?