Stelpro Orleans SOR Series High End Convector


(Laura Landy) #1

Let me preface this post by saying I am brand new to the SmartThings hub and to smart home functionality in general. But I recently purchased about 10 of the above Stelpro heaters because they connect to the Zigbee network like the SmartThings hub. Nevertheless I am unable to get any of them to appear in my SmartThings app. I’m following the instructions in the manual provided by Stelpro and keep getting the error message ERR. The manual does not tell you how to troubleshoot that error message (if anyone from Stelpro is on here you should really bolster this part of the instruction manual). I’ve tried to manually select the channel that I believe my Zigbee network is using (I think it’s 19), but either I’m not doing that right or that isn’t working because I still get the ERR message. Can anyone on here help?

@gouroufui I see you’ve helped other people with Stelpro and SmartThings Hub issues. Any chance you can offer some instructions to a total non technical newbie please?


(jeubanks) #2

No experience with this model. However I have had to disassociate (remove) one of my Stelpro Z-Wave thermostats first before I could add it correctly. It was as if it had been added to someone else’s network already (probably during QA).

Try the remove step. Then do an add.


(Laura Landy) #3

Thanks for the the advice @jeubanks. The manual doesn’t say anything about a “remove” step. I can turn the sensor that emits whatever frequency should normally be picked up by the Hub to off and then try to turn it back on, which I’ve done. Didn’t make any difference.

For what it’s worth, the SmartThings Hub has since picked up 3 of the 5 heaters we have installed. That being said, in the “Things” list they all just say “Tile Missing” and when you click on them the areas under “Right Now”, “Recently” and “SmartApps” are totally blank.


(jeubanks) #4

There’s the link to the user guide. I’ve put the relevant information below as well. I Bolded the remove section. If after removing and then adding back you still have problems someone else may have some ideas, or you may want to call Stelpro customer service.

Stelpro Orleans User Guide

ZIGBEE CONNECTIVITY
This convector is compatible with the ZigBee smart home protocol.
Once connected, it can be controlled remotely by means of the
application included with the user’s ZigBee controller.
FOLLOW THESE STEPS TO CONNECT YOUR CONVECTOR TO A
ZIGBEE NETWORK:

  • Make sure that the ZigBee controller is in ASSOCIATION mode
  • Access the advanced menus
  • Select menu 1 ( )
  • If ON is selected, the convector will find the channel assigned to the
    ZigBee network. You can also manually specify the channel that your
    ZigBee controller is currently using. The ZigBee connection process
    will be faster if the ZigBee channel is manually specified.
  • During the association, your selection will flash rapidly and the
    connectivity icon ( ) will be animated
  • Once the association with the ZigBee network has been established,
    the channel number will be shown on the display
  • If an error occurs during association, (ERR) will be displayed for 3
    seconds followed by (NO HEAT) being displayed
    FOLLOW THESE STEPS TO DISCONNECT YOUR CONVECTOR
    FROM THE ZIGBEE NETWORK:
  • Access the advanced menus
  • Select menu 1 ( )
  • Change the parameter to (NO HEAT)
  • During the disassociation, (NO HEAT) will flash rapidly and the
    connectivity icon ( ) will be animated
  • Once the disassociation with the ZigBee network has been
    completed, (NO HEAT) will be displayed
  • If an error occurs during disassociation, (ERR) will be displayed for
    3 seconds followed by the channel number being displayed

(J-F) #5

Hi @Landylicious,

Stelpro zigbee devices are not recognized by SmartThings as we would like them to be.

In order to have the SmartThings Hub to properly recognize your Stelpro convector, you will need to create a new device handler in your SmartThings account at this link:
https://graph.api.smartthings.com/

You will then need to copy/paste the code from the Stelpro device handler located here:
https://raw.githubusercontent.com/stelpro/Ki-ZigBee-Thermostat/master/devicetypes/stelpro/stelpro-ki-zigbee-thermostat.src/STZB402%2B.groovy

Here are some general tips to ensure proper connectivity:

  1. Make sure your SmartThings Hub is in association mode
  2. Make sure your Stelpro Orleans convector is within range of the SmartThings hub and powered on
  3. Make sure you have created the device handler with the Stelpro code as described above.
  4. On your convector, in menu #1, try the “On” setting to auto detect the zigbee channel

If you follow these guidelines, you should be able to connect your Orleans convector quite easily.
If not, please contact Stelpro tech support.

Have a good day!
J-F


(Mark) #6

As @gouroufui explained, not all z-wave and zigbee devices work with ST unless a custom device handler is loaded onto your hub. It’s not that hard to do, this thread explains it well.

However it’s important to note that as the ST cloud was scaled up over time to accommodate new users, different “shards” were created. Not everyone’s hub can be accessed via graph.api.smartthings.com.

You won’t get an error message if you try to access your hub through that link, but you will not be able to load the custom code successfully.

Access your hub by going to https://account.smartthings.com and it’ll automatically redirect you to the correct shard.


(Mark) #7

Also, this is correct for z-wave devices. Sometimes even new devices need to be excluded before they will pair with a new z-wave controller correctly. Removing or even resetting a z-wave device may not actually exclude it.

Zigbee devices are different, there is no exclusion procedure like with z-wave devices. They can usually be added/removed/reset without additional steps.


(Laura Landy) #8

Thanks for this @Jeubanks. I have the manual at home and followed these steps. Made no difference in trying to add the heaters back to the SmartThings hub again. I still get that same ERR message and the manual you’re sharing from doesn’t tell you how to troubleshoot that unfortunately. Really appreciate you trying to help out though!


(jeubanks) #9

@Landylicious, sorry it didn’t work. From this point unless someone else has any experience with that model I would call Stelpro.


(Laura Landy) #10

@Marktheknife, your advice about shards and providing the link to get to the right one was INVALUABLE. Without it, I couldn’t see any of the Devices I had added through my laptop, although they appeared at what on its face seemed like the same link when accessed through my mobile. Thank you for taking the time to share!

So I have made a bit of progress here, but ran into another stumbling block and wonder if you can help. I successfully created the Device Handler, and also successfully added 5 of the 6 installed heaters that such that they now appear in the “My Devices” list. However, when I try to remove the sixth one from the list (which paired with my SmartThings Hub before I created the Device Handler) so that I could re-add it now that I’ve created the Device Handler, I get the below error message:

Oh No! Something Went Wrong!
Error: 500: Internal Server Error
URL: /device/show/6bfa6bf3-43ca-4ec7-a6e4-a27ac71971ab
Reference Id: 4bde3b50-031c-4d38-8890-ad5d0682d09a
Date: Tue Jan 30 05:15:58 UTC 2018

I also cannot remove it using my mobile.

Any advice there perchance?


(Laura Landy) #11

Thanks so much for taking the time to share, J-F. I’ve made a bit of progress using your instructions, but ran into another stumbling block and wonder if you can help.

I successfully created the Device Handler, and also successfully added 5 of the 6 installed heaters such that they now appear in the “My Devices” list. However, when I try to remove the sixth one from the list (which paired with my SmartThings Hub before I created the Device Handler) so that I could re-add it now that I’ve created the Device Handler, I get the below error message:

Oh No! Something Went Wrong!
Error: 500: Internal Server Error
URL: /device/show/6bfa6bf3-43ca-4ec7-a6e4-a27ac71971ab
Reference Id: 4bde3b50-031c-4d38-8890-ad5d0682d09a
Date: Tue Jan 30 05:15:58 UTC 2018

I also cannot remove it using my mobile.

Any advice on how to remove it so that I can re-add it in now that I’ve created the Device Handler since it doesn’t show up the same way as the other 5 do in my SmartThings Hub app?


(Mark) #12

I am not actually sure what that error message means.

However, in general, it’s not necessary to remove a device from your hub just to change its device handler. The handler can be changed from the device’s settings page in the IDE.


(J-F) #13

Hi @Landylicious,

In the SmartThings IDE (where you created your device handler), you may switch the “device type” of the 6th convector to use your newly created device handler.

  1. Go to https://graph.api.smartthings.com/
  2. Go to “My Devices”
  3. Click on your 6th device (it may show up as a “Thing”)
  4. Click on “Edit” at the bottom of the screen
  5. In the “Type” field, go to the very end of the list and select your newly created device handler named “Stelpro Ki ZigBee Thermostat”
  6. Click “Update”

Restart your SmartThings mobile app and your device should show up properly.
If your convector is still on the zigbee network, you should be able to control it properly.

Have a good day!
J-F


(Mathieu Prud'homme) #14

Hi, i have the SORB series wich is using the same thermostat as the orleans but is a fan forced heater for the bathroom. I was wondering if you were able to properly use it as i am not even after reading this thread. i have tried loading the device handler that stelpro written but still not working. And when i am trying to create on DH well its not working at all… would need some help with it or some feedback thanks.


(Laura Landy) #15

Ya, I was able to make it mostly work. Not perfect, but I got the Device Handler loaded and it seems to control the thermostats. Routines don’t seem to actually get the thermostats to the right temperature though, which I’m still trying to work through with both Stelpro and Samsung. The Support experience with each has been pretty slow and unimpressive, if I’m honest, so hopefully you don’t have to go there.

In any event, these are the instructions I got from Stelpro about setting up the Device Handler:

  •      Go to this address : https://raw.githubusercontent.com/stelpro/Ki-ZigBee-Thermostat/master/STZB402%2B.groovy
    
  •      Select all the text (CTRL+A)
    
  •      Copy the selected text (CTRL+C)
    
  •      Then you will need to go to this address : https://graph.api.smartthings.com/
    
  •      Click on Log in
    
  •      Enter the email address used for your Smartthings account and click on Next 
    
  •      Enter your password and click on “sign in”
    
  •      Click on “My Device Handler”
    
  •      Click on “+ Create New Device Handler”
    
  •      Click on the tab “from code”
    
  •      Click on the white space and copy the text (CTRL+V)
    
    ° You should see the text appear if not you will need to try coping the text again
  •      Click on “Create”
    
  •      Click on “Save”
    
  •      Click on “Publish” then click on “For Me”
    
  •      Click on “My Device Handlers”
    

° you must see this <image003.jpg>
° If you see this your Device Handler is created
° If you do not see this one of the steps has not been done correctly please restart from the beginning

  •      Once your Device Handler is created, all your new thermostats Ki Zig-Bee from Stelpro will be recognized as “Stelpro Ki Zig-Bee Thermostat”
    
  •      If you had already connected some thermostats Ki Zig-Bee on your Sartthings, you will need to go change their “Type.’ In that case, please follow the Steps for each thermostat already connected 
    
  •      Click on “My Devices.”
    
  •      Click on the thermostat connected as (Type : Thing)
    
  •      Click on “Edit” at the bottom of the page
    
  •      Change “Type” for “Stelpro Ki Zig-Bee Thermostat” located at the end (Bottom) of the drop-down list
    
  •      Click on Update, “Update”
    
  •      Your thermostat should appear correctly on the screen.
    

BUT in order to make this work I had to follow @marktheknife’s advice above where he said:

"However it’s important to note that as the ST cloud was scaled up over time to accommodate new users, different “shards” were created. Not everyone’s hub can be accessed via graph.api.smartthings.com1.

You won’t get an error message if you try to access your hub through that link, but you will not be able to load the custom code successfully.

Access your hub by going to https://account.smartthings.com2 and it’ll automatically redirect you to the correct shard."

Hope that helps! If it doesn’t, I’d try to deal with Stelpro directly as I haven’t quite figure this all out yet myself. But if you think I can answer any further questions, don’t hesitate to reach out to me too.


(Mathieu Prud'homme) #16

It is working fine for me now. Had To pair it two times before it works fine. Hope toi can make it work


(Gyslain Hamel) #17

the KI Zigbee has the same DH as this SOR convector? Because your Github link gives 404 but i laready have the KI DH


(J-F) #18

Yes, the Stelpro SOR convector and the Stelpro Ki Zigbee share the same Device Handler


(Sebastien) #19

I got my Orlans heaters to work with the KI Zigbee device handlers, thanks for the tips!

I also have Google Home, and after linking my Smartthings hub, Home clearly recognized the heaters and I added them to rooms. Home even suggests commands like “raise the temperature by 3 degrees”. When I try the commands I get an error that says “That mode isn’t available”

Update: I have 5 heaters connected to my hub, 2 are working with Home and 3 aren’t with the above error message

Anyone has any ideas?

Thanks!