ST smart lighting apps power allowance is not working


(Ray) #1

Before I report to support. Anyone else still have their timer (power allowance) working with the stock Smart light apps? I know there are other apps but local is what I am looking for and it was working fine before last week system upgrade. IDE update and Reinstalled another instance did not help.


#2

Same here, most of my timed off’s have not worked consistently since the last update. Neither have several of my routines. +1 on the new app design and -10 for the update.


(Ray) #3

So I reported to support and they updated the smartapps and it’s working right now. Not sure what’s the diff between support update and the update in IDE and new install. Will see how long will this last.


(Geko) #4

He-he… When support says they “updated the app”, all it means that they pushed the button in the IDE that reloads the app. This temporarily solves the issues with stuck schedules and other state inconsistencies. You might as well do it yourself without waiting for support. :sunglasses:


(Mike Thomas) #5

I just converted all my Routines to Smart Lighting Automations, because I thought I read somewhere that Smart Lighting is one of the very small number of things that actually runs locally (on the hub), and would presumably be a bit more reliable.

Was that a bad idea?


(Ray) #6

That’s depend on the routine. Pretty much anything with schedule or time based is not really local run. Also depend on the devices as well. Not everything is qualified for local run. On the positive side. It’s way more responsive using smart lighting apps and as long as the platform is running.
Take for example. My power allowance is not working again after support “updated” my smart lighting instance yesterday. It’s suppose to be local.


(Ray) #7

I didn’t wait for them. I did update that instance in IDE but it didn’t work. Could be coincidence but it worked when they did it.


(Mike Thomas) #8

OK, thanks Ray. I’ll keep them as automations since the work is already done, and see how they behave (I had a few oddities yesterday, after initially setting them up).

The devices are GE & Aeon Smart Switches and the automations are time based (some absolute time, others relative to sunset).

Speaking of sunset - the automations that have an absolute ‘on’ time can also have an ‘off’ time specified (nice), while the automations that have a relative ‘on’ time cannot (perhaps because of the possibility for complications introduced by someone specifying an ‘off’ time that happens to be before the calculated ‘on’ time).

Mike


(Joe) #9

I’m having an issue and I was just about to post a new thread on it and this one popped up. I have tried everything to get this to work and still can not.