ST says it changes temperature but it never does


(Jeremy Whittaker) #1

It appears there is an issue with ST telling me it’s changing the temperature on my thermostat but then never changing it. I have the 3M-50 thermostat. Seems ST has always had a reliability issue with communicating with my thermostat quite honestly. Any suggestions?

photo 14-2_zps3044db97.png

photo 5fe45262-16f8-42bb-aa9d-d1aa92f27c25_zps7af6674e.png


(Kevin Tierney) #2

I have noticed something similar where the two devices/apps (wifi vs z-wave) do not stay in sync. For instance I just changed my thermostat from the ST app to 50. I looked at the thermostat and the change happened immediately. I went into the thermostat’s app and it still showed that the thermostat was set to 60. It seems that there may be some sort of control issue and that the thermostat doesnt sync the settings between it’s two “masters”

Hmm, after I typed the above paragraph I tried the opposite. I turned the thermostat up on it’s own app, but it did not change on the thermostat. I changed the temp back on the thermostat and it shows up on the ST app, but not the thermostat app. Odd


(Jeremy Whittaker) #3

Well this doesn’t look promising. I went into IDE and it’s showing it hasn’t talked to it for months.

Date

Name

Value

Units

30 Dec 2013 22:29:23 - 1 month ago temperature 72.5 F
30 Dec 2013 20:23:18 - 1 month ago temperature 72.0 F
30 Dec 2013 18:57:11 - 1 month ago temperature 71.0 F
24 Dec 2013 05:20:44 - 2 months ago temperature 74.0 F
24 Dec 2013 05:15:16 - 2 months ago temperature 74.5 F
23 Dec 2013 23:54:09 - 2 months ago temperature 73.5 F
23 Dec 2013 20:10:16 - 2 months ago temperature 72.0 F
23 Dec 2013 19:35:20 - 2 months ago temperature 71.5 F
23 Dec 2013 17:54:15 - 2 months ago temperature 71.0 F
23 Dec 2013 16:24:09 - 2 months ago temperature 70.5 F


(Chrisb) #4

@jeremywhittaker,

Wild guess here… but are you running this unit with Batteries or off current from the Furnace?

I did a quick look up of the manual here: http://www.radiothermostat.com/filtrete/guides/3M-50-Installation-27may10.pdf

On page four it says:

IMPORTANT: the 3M-50 runs on 3 AA aklaline batteries and/or the C wire if available. If you do not have a C wire you can run a new wire from teh HVAC or use a standard 12-24V wall transformer. A constant power sources if required when using the radio module.

If I’m understand that right, it sounds like the thermostat itself might still work using microvolts from the HVAC or possible with a low voltage from the Batteries, but it might NOT be enough to power the radio.

Might be talking out of my butt of course, but I’d check the batteries.


(Jeremy Whittaker) #5

Yea, I definitely have the C cable connected for power. I can remove the batteries and it would still work. If I change the temperature using my phone using the wifi card it works perfectly fine. It is only zwave through smart things that does not work.


(Chrisb) #6

Hmm… well, as I said shot in the dark.

Another shot in the dark: I have a z-wave outlet that just should not respond at all. It worked fine for months, then just stopped communicating back to the Hub. I even tried removing it from SmartThings, then adding it back in. It actually added in, but still won’t really respond to commands. What I had to do was turn off power at the breaker to this outlet. Once I did that, then turned power back on, then it started working just fine and has stated working for months since I did this.

So, maybe completely disconnect power from the thermostat and then reconnect it. See if that helps?


(Jeff DeWolfe) #7

I’ve got the same issue with the same exact thermostat. The zwave module in these works like crap. In fact, once a month it completely locks up and causes my GE remote and dimmer to stop working. As soon as I pull the zwave radio out, everything else starts working. I think a better fix would be to get local lan connectivity and use the wifi module instead of the zwave module for this thermostat.


(Jeremy Whittaker) #8

@chevyman142000 I have the wifi module in there as well. The problem with that is ST does not support this thermostat over the wifi module only zwave. Unless I’m missing something?

I’m sure it would work if I rebooted it. This can just get a little annoying you have to take it apart. Pop all the batteries and then unscrew the C cable. I know it’s not a lot but rather frustrating that it just doesn’t work.


(Jeff DeWolfe) #9

Nope, it does not work…yet. They have local lan somewhat working, but as far as I know, no way we can add this…yet. I’m just dreaming is all. For now I have the zwave module pulled out because of how un-reliable it is and the issues that it causes.


(Jeremy Whittaker) #10

Thanks Jeff, hopefully one day ST will integrate via the wifi card instead of the Zwave. Until then I guess it’s just rebooting the device constantly!


(Jeff DeWolfe) #11

@urman Any thoughts or ideas on this thermostat? We would like to use the wifi connectivity instead. Just wondering if you can give us any idea of when we might be able to control via local lan. Thank you!


(Jeremy Whittaker) #12

For the record I’ve had issues with this thermostat’s Zwave module since day 1. I almost wonder if something is off in the code or something…?


(Jeff DeWolfe) #13

I agree. I don’t think it is a SmartThings issue. I personally would rather use the wifi for connectivity so that I could use either SmartThings or the Filtrete/radiothermostat website for changing temp.


(Jeremy Whittaker) #14

I have no choice but to use the filtrate app for android and it has worked flawlessly. I’m sure it’s just http commands. I can’t imagine it would take a lot to get ST integration if it was approached from the wifi perspective.


(Jeff DeWolfe) #15

I don’t think so either. It has an open api. Documentation can be found here. http://www.radiothermostat.com/documents/RTCOAWiFIAPIV1_3.pdf And here: http://www.radiothermostat.com/documents/RTCOA%20WiFI%20Application%20Developers%20Guide%20V1_0.pdf I would be more than willing to help test if someone knows how to write this up via a new device type or if SmartThings gets involved in getting it to work.


(Andrew Urman) #16

does it support local LAN operation? Anyone got any docs on it?

SHOW ME THE DOCS

(like show me the money)


(Jeremy Whittaker) #17

Jeff posted this earlier. Is this what you need?

It has an open api. Documentation can be found here. http://www.radiothermostat.com/documents/RTCOAWiFIAPIV1_3.pdf And here: http://www.radiothermostat.com/documents/RTCOA%20WiFI%20Application%20Developers%20Guide%20V1_0.pdf I would be more than willing to help test if someone knows how to write this up via a new device type or if SmartThings gets involved in getting it to work.


(Jeff DeWolfe) #18

Thanks for checking in @urman! Let me know if those documents have what you need. If not, I’ll do some more digging to get what you need. Any help on this would be AMAZING! Thank you!!


(Andrew Urman) #19

I don’t see any actual API docs in there. Are there docs on how to communicate with it via LAN?


(Jeff DeWolfe) #20

@urman check this one: http://www.radiothermostat.com/documents/RTCOAWiFIAPIV1_3.pdf

I’m not much of a coder, but it looks like everything is here. The other doc doesn’t have the API stuff that is needed. Looking through this one, it looks like it talk to the thermostat via this: http://localipaddress/tstat I can confirm that when I tried that on my thermostat, this is what was returned: {“temp”:67.50,“tmode”:1,“fmode”:0,“override”:0,“hold”:0,“t_heat”:63.00,“tstate”:0,“fstate”:0,“time”:{“day”:1,“hour”:23,“minute”:0},“t_type_post”:0}

Let me know if that helps or if I can get anything else. If that doc is still no good, let me know and I’ll do some more digging. Thanks for looking at this!