CT100 thermostat - incorrect temperature reading

For the last couple of days, ST has been reporting the wrong temperature from my CT 100 thermostat. This is happening regardless of the device type used.

Is this happening to anyone?

Yes on my Ecobee3. It kept reading 68 when it was 74. I had to disconnect and reconnect in the ecobee connect app. Not sure how your thermostat connects ( wifi vs. z-wave vs. zigbee). I just fixed it tonight.

I ended up excluding it and including it to ST again . It’s now fixed!


How did you exclude it? I tried on mine and now it gone from the app but I believe it’s still paired because the radio link is showing on the ct100 and I can’t figure out how to remove it now.

If I remember, the same thing happened to me. I ended up excluding it properly by unplugging the ST hub and once ST came back online, I put the hub in exclusion mode again and removed the thermostat off the network.

I then proceeded by pairing it again but for some reason, it took several minutes to sync with ST, but after that it worked fine.