ST isn't seeing Wemo switch & Wemo switch is offline

So, @bago , I tried and ST still isn’t seeing the wemo switch. Let me know if you have any further tricks :slightly_smiling:

They work fine from the Wemo app?

yes, @bago :slightly_smiling:

I’m sorry. That worked for me when I had issues.

ok, thanks for trying @bago

One last thing, iOS or Android?

IOS, @bago , iphone 6

I have an iPhone too. With Android, sometimes you have to clear the cache. With iOS, ensuring that app closes completely usually works. Forcing either to restart from scratch fixes numerous issues (usually).

You’ve uninstalled the Wemo (Connect). You’ve closed the ST app completely. Maybe it’s an issue with the ST platform. I know other LAN and cloud devices have had issues recently too.

OK, thanks for trying to help @bago. One last question: I can’t add any devises using the website for smarthings, right? devises can only be added and discovered by the phone app?

Correct. There are some exceptions (i.e. ecobee and others), but I don’t think that wemo is one of them.

The device ID for mine is the MAC address.

ok I thought so, thanks again @bago

I purchased a new router and had to reset some things and I too can not pair the Wemo switches with smart things at this time. It does not find them during discovery of connected devices. When I try to manually add them going through the switches -> belkin -> wemo light switch, I get a message telling me that my hub needs to be updated. I spoke to support on Fridy and they said I am not the only one receiving this error. Just wanted to let you know it seems like a ST issue at this time.

Thanks @jgravert , I appreciate your feedback :slightly_smiling:

1 Like

Thanks @jlevatino1122, I appreciate your feedback :slightly_smiling:

My 2 Wemo devices (light switch and Insight switch) are now listed as “Offline” in the ST app.
They have been working fine for a long time up until a few days ago.
The most recent firmware update for them was about a month ago.
They worked fine in ST right after that update.
They are working fine now in the Wemo app.

Looks like maybe something has changed on the ST side to cause them to no longer be compatible.

I think you are right @btcompute, thanks for the feedback :slightly_smiling:

I’ve just discovered that if I go into the WEMO (Connect) app within Smartthings, the two wemo’s get re-discovered and are recognized again in the Things list.
Hope this won’t have to be done frequently.

I have four switches and they all have this problem from time to time but one of them is always a problem.
I have tried this many times and lately it always comes back as OFFLINE.

The fix I have found is giving up on Wemo. In the last few month I have noticed that in the Wemo app, they disappear less often which may be due to new firmware, but in ST I have got one switch is always OFFLINE no matter what steps I have taken.

I’m hoping thing will improve in the next few months, but if I find other switches that can also do the Auto-off timer functionality built into the switch, I will replace the Wemos.

Hi @xjonx, try this,

1 Like

Thanks! I will check it out.:grinning: