[ST EDGE] Zooz Edge Driver Channel

Can you confirm that the new version of the ZEN32 driver is working as expected?

The previous version of the Edge driver which worked had the buttons contained within the device screen and did not add child devices. I think the last time I remember those being added was under the original Groovy driver.

Do you know if there is a way I can force an update of the firmware? If i can get them to a more current version, maybe that might resolve the compatibility issue?

I was referring to my custom version of the driver that isn’t posted to the forum because I can strip out the association related code to see if that solves your problem.

I tested it with multiple firmware versions and one of yours has the 10.40 firmware which is the latest version.

I’m going to move this conversation to a PM since I think you’re the only one having problems…

The new colors work just fine. I don’t use the other features.
Thanks very much!

1 Like

I haven’t played much around with it other than the colors, but I haven’t had any issues. I have two of them working fine.

1 Like

Hello, I loved the old drivers where my Zen30 devices had the switch and relay as separate tiles. I have 11 of them in my house and they worked great…until Edge drivers were rolled out. Suddenly I had 11 orphaned child devices and I couldn’t figure out why. I did a little digging and found that initially the Edge driver didn’t support the relay as a child device in a separate child device, so I deleted all of the orphaned relays and just dealt with having less features with the new Edge driver.

Fast forward to today and I’ve found that the latest multichannel switch drivers have a setting “Create Separate Device for Relay” and I eagerly set that to “Enabled” and then nothing. I thought the relay might have been created and dropped into the Unassigned Room bucket, but I can’t find it there either.

The Zooz Multichannel Switch driver installed on my SmartThings Hub is 2023-10-25T00:04:55 479338713

Can you please tell me what I’m missing here? I’d love to have my relays back as separate tiles because everyone in my household uses SmartThings and they, along with me, HATE not having that separate tile for the relay.

Ok, now it just started working! Every one of them I ENABLE the separate device for relay on automatically creates that separate device! THANK YOU!

1 Like

Did that solve the problem?

We’re not home enough during the week to trip those sensors. I’ll be keeping an eye on them starting this evening as traffic will increase in those areas shortly! I have not noticed one stuck since changing the setting though. (really only tripped a few times each day during the week)

I’m going with “that solved the problem”!!

Plenty of traffic through that area today and I didn’t notice it stuck once.

Thanks Kevin!

I spoke too soon. Motion Sensor 1 has been stuck on Active for the last 2 hours… Uggh!

I am having a problem with my new zen34 remote and smartthings. It’s just too slow. I’ve been reading about group associations and direct associations. I used the graph api to get the network id of the device I want to control, It’s a dimmer switch with the value of “CE”, and it’s unsecured (it’s pretty old). I paired the zen34 without s2 and authentication says FAILED, but button presses show up for the device, so I’m sure it’s unsecured as well??!? If there’s an actual method to pair this with no security I’d like to know.

In the driver settings where it says enter the network IDs separated by commas, since there’s only one I’m putting in CE - no quotes, commas or spaces and going back to the device control page it’s showing what I assume is an empty array “” for both group 2 and 3 I haven’t been able to get this to change.

As far as associations I have been trying to set the groups with the driver settings and trying to use @philh30 's associator, although it doesn’t have documentation - it’s just been me guessing how to use it.

Can someone provide a screenshot of what the device association group section should look like in the edge driver settings?

Just to make sure I wasn’t totally inept - I got groups to work on Home Assistant with minimal effort and it’s pretty good speed-wise.

From what I’ve seen with this device and SmartThings, Associations only work if the device is joined s2 authenticated.

Sorry, I know that doesn’t help you since the device you’re attempting to control isn’t secure…

Thanks for the reply. Oh well, at least there’s a reason for it acting the way it is. I’ll see about trying a new dimmer switch someday.

Zooz Multichannel Switch Update - 11/18/2023

  • ZEN30 - Added support for 800LR version.

Im using the zen16 Relay3 to run my pool pump. Is there anything I need to set in the settings in order to do so since its a 15amp connection? Or should everything “just work?” Want to make sure before I have it wired up and dont forget to do something in the app settings.

1 Like

This just in from Zooz… It doesn’t really say if the “stuck on Active” is fixed, just the other settings. @krlaframboise what do you make of this?

Thank you for your patience!

SmartThings has confirmed there is a bug that is affecting updating parameters in battery operated devices.

We implemented a workaround to our driver to circumvent the issue, and the updated driver has been pushed to our Zooz channel. You should now be able to update any parameter, then manually wake the device and have the change implemented properly.

Please let us know if you have any questions!

I just installed a Zen32 scene controller but I can’t control the 4 small buttons (I can use them in automations only). This is also preventing home assistant from seeing these buttons as well. It also appears I cannot see status of these buttons either, in other words I don’t have a button in smart things I can press to control the 4 small buttons.

Has anyone else had this issue or know how to fix it?

There’s nothing to control with buttons - ST sees when they are pressed but ST can’t “turn on” a button or similar. The LEDs should be controllable but that’s about it.

Okay that’s not what I expected but I get it. Unfortunately Home Assistant does not see these buttons as an option that I can find is there something I’m missing for that or is smart things not passing this information to HA?