[ST EDGE] Zooz Edge Driver Channel

The Zooz ZSE19 is is already included in the community Edge drivers. Basic support (at least) is already available. Advanced parameters - duration, custom tune, temp/humidity reporting - may not be available until someone adds that support. Until then, those parameters will be at the default or (perhaps) whatever you have currently set them to.

1 Like

Wow that is incredibly disappointing. Could do without the custom tone and maybe even duration since STHM can do that anyway, but sucks the other sensors may be wasted.

1 Like

You might give it a try - I looked through the source code and it appears that temperature and humidity are supported.

1 Like

How can I enroll/add this driver? Do you have a link?

1 Like

Channel is here. Discussion is here. Driver requests are here. Code is here.

1 Like

There is a custom Edge Driver that works in a similar way to the old Zwave Tweaker. You temporarily assign your zwave device to it, it exposes all configurable parameters, you set them as you like, they get saved in the device itself, then you switch back to the regular driver for everyday use. :sunglasses:

(New Release) New Edge Driver Z-Wave Device Config Mc



@krlaframboise you might find it interesting that SmartThings seems to be converting all of their multi-component switch devices back to parent-child style devices. Maybe enough complaints about MC devices not showing in Alexa and Google Home? Here’s an example for the Zooz double plug, but there’s a handful of others they are converting too


@nayelyz, is it safe to start implementing drivers like this?


I really like the multi-component versions myself, especially with the Zen32 and the Multi-Relay. Should we unenroll from the channel if we want to avoid moving back?

1 Like

It seems that smarttings has decided to implement child devices without keeping the original multi-component device.
There would be another way to do it keeping the original multicomponent device and creating the child device when it is needed and who needs it.

In this way you would not have to touch the code that already exists, just add the code for the child device

@nayelyz If you want you can move this to another thread so as not to mix with this other


Sorry but there is no info about this yet, but I already shared these comments with the team.

@krlaframboise under iOS once the Dashboard view is changed to large, then if changed back to normal it remains a large tile. I have 3 ZEN16’s that this occurs on, but I have one ZEN52 that respects the setting. Also is it normal behaviour that under the large tile the child relays always show as off?

Hi @krlaframboise, beside the ZSE09, will you be adding the below?

Zooz ZEN07 (Zooz Mini Plug)
Zooz ZSE08 (Contact Sensor)

I used the wrong ocfDeviceType so the next version of that driver I release with have that fixed in the ZEN15 profiles and any of the other profiles that have the same mistake.


Firmware 1.04 mentions that it fixes a polling issue which could have caused the issue you’re seeing if you were on an earlier firmware version, but I’m not aware of a 1.10 update. When I checked the Advanced Settings and Change Log pages last month while writing the driver they showed 1.04 as the highest version…

The tiles for the child relays shown on the Dashboard when in Large View are displaying the exact same attribute as the child relays displayed on the Device Details screen so if they’re not showing the same value then something is stuck in cache.

I’ve seen the Large view get stuck before, but I’ve always been able to fix it by changing the setting back to large, closing the mobile app, waiting a moment, and then changing it back to Normal. That being said, yours is probably stuck because of the same caching issue that’s causing the other problem.

Try clearing the mobile app’s cache and if that doesn’t work then reboot your phone.

That’s exactly what I was thinking, assuming it’s possible to have a component driver that also creates child devices in a hub connected driver, but I’m going to hold off on doing anything until this feature is official support by ST or at least that PR is merged…


I’m pretty sure the ZEN07 and ZSE09 are certified as Works with SmartThings so they’ll be functional with the built-in drivers and they were discontinued several years ago so they won’t be getting custom drivers.

You won’t be able to change any of their settings with those drivers, but as long as you let ST migrate the device you won’t lose the setting changes you made while using the custom DTH.

The ZSE08 doesn’t have any configuration parameters so it never had a custom DTH and there’s no need for it to have a custom driver.

1 Like

Kevin, thank you for all the work you are doing.

As Oct 15 hit, I tried to replace a couple of custom drivers with Edge ones. Everything worked fine for ZEN15 but not so with ZSE40. ST stubbornly picks some generic Z-Wave Sensor driver even though I do have Zooz Multisensor driver installed on the hub.

I’ve tried these steps: removed all ZSE40, factory reset them all, removed the generic Z-Wave Sensor driver from the hub, just in case uninstalled and installed again the Zooz Multisensor driver and verified that it shows up on the hub, and added ZSE40. ST picks the generic Z-Wave Sensor driver no matter what I try. If I go into the device Driver and try to Select different driver, no driver shows up.

Any suggestions how to force ST to pick the Zooz Multisensor driver driver instead of the generic one?

On the Channel enrollment page, did you install the “Zooz Multisensor” device? (I suppose that “I do have Zooz Multisensor driver installed on the hub” means yes, but just checking…)

Can you check (and post) the device fingerprint?

Anyway, thanks for this prompt: I discovered that my ZSE18 had disappeared from my SmartThings setup - it wasn’t in the app nor groovy IDE nor ‘smartthings devices’ list. Strange.

I did get it back with a reset and re-include, and it came up with the af6a…740455 ‘Zooz Multisensor’ driver from this channel. I still have to recreate the affected routines…

Perhaps the driver transiently disappeared, causing my device deletion and your problems, but has since returned? Maybe try one more time?

Yes, I did install “Zooz Multisensor” driver and it shows up on the hub driver list.

I am not sure what “device fingerprint” is and hope that’s what shows up on the new ST page, which is 9208b336-eaf4-4216-ac04-2994202c4305.

I’ve tried at least half a dozen times cleaning up everything, adding ZSE40, checking the driver and seeing the generic one, removing the device, adding again, doing factory reset and trying to add, et cetera. No matter what I try, upon adding it picks up the generic driver.