[ST EDGE] Zooz Edge Driver Channel

No, that’s nothing something that can be changed dynamically…

Zooz Switch Driver - Update (9/29/2022)

I just published a new version that supports the ZEN15 Power Switch and ZEN06 Smart Plug.

Supported Devices:

  • Zooz ZEN04 Smart Plug
  • Zooz ZEN05 Outdoor Plug
  • Zooz ZEN06 Smart Plug
  • Zooz ZEN15 Power Switch
  • Zooz ZEN71 On/Off Switch
  • Zooz ZEN72 Dimmer
  • Zooz ZEN73 Toggle Switch
  • Zooz ZEN74 Toggle Dimmer
  • Zooz ZEN76 S2 On/Off Switch
  • Zooz ZEN77 S2 Dimmer

One way around this is to create a coordinated virtual switch (see TAustin’s vEdge channel) for each real switch, and four routines for each switch to synchronize virtual and real.


You can also use Mariano’s virtual appliance driver mirror device and only 2 routines are required.

1 Like

So removed and re-added. I did need to modify the settings and rebuild routines. It’s still not 100% on reacting to the contact relay S2. And it’s doesn’t seem to update the tile with the status, when it does work I can see the status reflected in the virtual switch but not on the actually device tile.

You will notice that R2 says ON with the tile and OFF inside the details.

The S2 seems to permanently show contact closed

Just so there’s no confusion, you’ll still need to use the official driver for this device, those other drivers just provide a way to sync the components with virtual devices that can be named separately and used by integrations like Alexa.


If you touched the input type settings after you re-joined the device then you’ll need to remove it again… This isn’t a quirk with the driver, the device’s manual says the same thing.

You can change all the other settings without needing to re-join the device.

The dashboard tiles and device details tiles are showing the same attributes so if they’re different then that’s a caching issue with the mobile app and you’ll need to reopen the device details screen and/or the mobile app.

If by “virtual switch” you mean one of those other integrations then stop using it until you get everything working with just the driver.

The sensor value is the state of the input, not the relay, so the S value won’t change when you control the device from SmartThings.

Well R2 relay is currently off, but displays ON, and when the door closed should display open it remains closed. I realize this an issue with the app in this situation, but restarted it after forcing it closed doesn’t change what it displays.

I didn’t change the input type setting, but I did lose the reverse contact state and I need to tell R2 to turn itself off after a second in the event it gets turned on.

It is indeed routine fed virtual switch that follows the states of the device.

I will try removing it and adding it back to see if I can get improved behavior.

I see in the manual it says that it will create a child device but I didn’t think this was the case for the edge driver

Thanks for help

I noticed I was seeing different and improved results on my iPad vs my iPhone. So I uninstalled my iPhone app, cleared the safari cache and reinstalled it. That might have fixed the problem. I’ll play with it more. Thank you

If you use the main switch to turn R2 on (since the mobile app probably won’t let you if it’s in the wrong state) and then turn R2 off, does R2 change to off?

By force it close do you mean physically closing the sensor attached to that input?

You will lose all the other settings after re-joining the device, but it should be fine as long as you don’t change the input type settings.

Don’t add it back until you get this device working the way it’s supposed to…

I didn’t realize it was worded like that, but if you don’t have firmware 1.04 or above then re-joining is needed if the inputs aren’t reporting properly.

I meant force quit the app. Then relaunch. But it seems to be fixed after deleting the app and reinstalling.

I have updated the device to firmware 1.20 since I needed the reverse contact feature. So does that mean I can change inputs types without re-joining in the future?

@krlaframboise I was able to get the ZEN17 driver setup and working. What is the intent for the different input types? I am not seeing any change in behavior between them. In all cases, the relays act on/off switches. I tried connecting to a button triggered by a dry contact. To get this to work, I had to set the auto-off timer so it acted as a momentary button. I didn’t see any input type that made it “behave” as a momentary button. The input types are currently setup as dry contact sensors. I see the additional S1/S2 tiles, but they never seem to change, presumable because my auto off timer is 1 second and may be too fast. I haven’t tried upping that yet.

If you attach something like a dumb contact sensor to S1 and select “Contact Sensor” for S1 then it will show the open/closed state of that sensor.

I’m not sure what you mean by “button triggered by a dry contact”, but if you connected something like the Zooz ZAC98 to S1 and select the “Dry Contact” input type for S1 then that tile will show the on/off state of the relay.

Keep in mind that if the firmware is below 1.04 then you might need to remove the device and join it again if the S1 tiles aren’t changing when the state of the device connected to them does.

Turning the Relays (R) on/off won’t change the state of the inputs (S), but changing the state of the inputs will turn the relays on or off. The newer firmware has a setting for Disable Trigger Input which prevents the inputs from turning the relays on/off.

Kevin, thank you for the updates covering the ZEN15. I’ve switched one of my four to your driver to try things out.

It may be by design but it appears there are some superfluous headings:

Also, your previous DTH used to have a setting that set a ‘vibration’ sensor capability on or off. Have we lost that now? I ran some simple automations off that but guess I could switch to using power. Just curious.

Thank you for the update. loaded the zen15.
Think I’m looking at kW not W. Lots of things running in the house and it sometimes goes negative
Also is there supposed to be Voltage

Can you post a screenshot of the device details screen because that doesn’t look like my driver…

This device has always had issues with sending weird values so I made the driver ignore negative values and values that are way over the maximum values of the hardware.

The mobile app displays the capability name and attribute label for custom capabilities so there’s no way for me to hide the small headers…

That wasn’t something that was built into the device so I didn’t include it, but I just remembered that I’m using the vibration feature to monitor the frequency and duration that my sump pump runs so at some point I’ll probably add something similar.

My sump pump generates a bunch of power reports while running, but that feature only sends active when it starts and inactive when it stops which made it much easier to trigger automations.

1 Like

Adding to the thread that I use the vibration sensor of the zen15

1 Like

device details

The Name field of the driver says it isn’t using a Zooz driver. Try tapping the button at the bottom to switch it.