[ST Edge] Yeelight

Yeelight Edge Driver.

Support device: Ceiling Light, Color Light
Requirement: Geek mode in yeelight app.
ST Hub & Yeelight in same local network.

If you have more than 10 devices, turn off the paired device and repair others.

If created device is not working, remove it then pair again.


7 Likes

Hi @ fison67

I have three yeelight products: bedside lamp 2, screenbar light and a white light.

I use nodered and I can control bedside lamp2 and white light via LAN.

But using the driver, it only found the bedside lamp2 and it is not even possible to control it, it gets a status “verifying”.

Hi @Raimundo

I didn’t make a white bulb driver yet. Only ceiling and color bulb.

If it doesn’t work, remove and then try again.

It would be helpful if you could list the model numbers of the devices that work with your edge driver. Thanks. :sunglasses:

1 Like

I have 4 Ceiling Lights, all of them are working with your Drive.

I’m experiencing an issue. With the drive the ST app now has the Moon mode for the light. This feature, on the Yeelight app and the remote control dims the light to a very fade warm light. If activated via remote control or Yeelight app, the light status on ST app continues as ON, if using the default integration with yeelight.

But, using the driver, if the Moon mode is activated via ST app, the light is shown as OFF.

When moon mode is activated, the main switch status is off.

This is exactly what I wanted, a LAN control driver!
Great work. Now I will be able block my yeelights from accessing the WAN.

First of all thanks for making these drivers!
I have 2 issues:
When turning on a color light bulb that is set to blue, the bulb will flash white on maximum brightness before changing to the set color.
The second one is that I cannot add all my yeelight bulbs. For some of the bulbs I don’t have the option to enable lam control for some odd reason.
Can you help me please?
Also, my beside lamp works great with the color drivers
Thanks!

1 Like

Thank you, this is very appreciated and helpful.

I installed the driver, but it seems the discovered devices are stuck in a ‘checking’ mode.

Was able to resolve this by rebooting the hub.

@fison67 are you working on support for white bulbs?

Thank you

1 Like

I have difficulty running it local… I changed it on the same WI-FI network, resting, rebooting the hub, but nothing works… LAN is ON. ?

Good job, thanks :slight_smile:
Now I am able to set exact brightness level or color temperature on specific event. It is possible to add feature to relatively raise/lower these values on event?

Hi! I cant find a link to download the driver. Where can I download it?

The link is in the 1st post.

I just cant use this driver. I have the lamps registered in the Yeelight app. Is it necessary to eliminate them before? Do you have to reset the lamps and put them in pairing mode to be detected? What I did was this, but the lamps do not appear.

1 Like

Dear Fison67,

Thabk you so much for tge drivers, I can now run my routines locally.
However, every now and then my 3 bulbs tend to go offline. Rebooting doesn’t help, I have to delete and readd them.
As it was already pointed out, while changing through colors, the bulbs go white and bright first.

Thank you so mich for your efforts!

Dear Fison67,

Thank you so much for the drivers, I can now run my routines locally.
However, every now and then my 3 bulbs tend to go offline. Rebooting doesn’t help, I have to delete and read them.
As it was already pointed out, while changing through colors, the bulbs go white and bright first.

Thank you so much for your efforts!

Is this supposed to work with the star bedside lamp?

I have the driver installed and lan control enabled, but doing a scan for devices does not find anything.

Tagging @fison67

How do I use this driver?

@Catalin_Apostol can you tell me the process you used to discover your devices with this driver?