[ST Edge] vEdge Creator: a virtual device generator for end users

This driver was a simple port of an existing Groovy driver. Please see the README for it on my github respository: edge_WLED/README.md at main · toddaustin07/edge_WLED · GitHub

It may be best to reach out to the original Groovy driver author if you have questions, if he is still around.

So now with the new version of the virtual device creator, when ever I scan for nearby devices the virtual device creator doesn’t show up anymore. I tried reinstalling the driver through the CLI but that didn’t make any difference. Any suggestions on what I’m doing wrong?

You looked in the room where your hub device is located? The ‘No room assigned’ room seems to no longer be the location for new devices.

What kind of hub do you have?

Whenever I go to add new device and then press scan for nearby devices, it doesn’t return anything. Used to show the virtual device creator. I have the smartthings v2 hub.

I figured it out. I forgot it put it in a room after I added it. Thought I had to add it again. My bad. Thanks for the great work.

Hey, so I have an error suddenly - the ‘Select & Create’ and ‘Virtual Device Inventory’ options are greyed out and I get a toast saying ‘This device hasn’t updated all of its status information yet. Check again later’.

How do I fix this? Thanks.


I am using the edge creator for couple of month and it was working fine until today.
I am now getting a message that the device status is not fully updated and it only let me change the number of devices i want to create, the other two selections for device type and inventory are grayed out.

I have the latest version from 2/1/23 ends with. …957

Should i uninsall and reinstall it?
What will happen to the 15 virtual devices i am already using?


I was getting the same message with the vDev Controller.
I created a virtual switch which was assigned to the room where my hub is located. After that, I stopped seeing that message and a list of all my virtual devices appeared in the vDev Controller.

Same issue as the last 2 posts (greyed out add options). I am on v2.5.

How do I update to v2.8? I thought version updates of this type were automatic for subscribed channels, but I’m probably wrong on that. Tried the ST scan for new devices and none were found. No other driver versions appear when I check in “select a different driver” option. (Sorry if this is covered already in this long thread). Haven’t had to touch the ST edge driver tools for a few months now;-).

You need to delete the virtual device creator (not the driver). It doesn’t mess up your virtual devices. Then scan for nearby devices and the v2.9 device creator will show up in the room with your hub.


Successfully created a few Virtual buttons using V2.9. All good, except for the “Window Shade” one. It appears on my ST app, but cant assign the “Open” and “Close” action.

I wish to use IFTTT to link up the Virtual Device “Window Shade” on ST app and Broadlink app to trider RF signal to open/close the curtain

The same thing works like a charm on Virtual Device - “Switch” and “Momentary Button”. Can someone help?

Can you please elaborate on what you mean by this?

This works very well and I am super happy with this local switch app.
One note
These switches automatically went into sthm In my sensors used in away mode .
This has created many false alarms etc till I figured that out.
Just fyi.
And lastly a quick help page explaining the difference of all the switch types and what the three controls do in the app.
This has made a very noticable improvement in my home automation and dramatic reduction in latency.

1 Like

Thanks for your comments. One of these days I really do need to create a help document as you suggested.

You can exclude specific devices from being included in STHM monitoring. See this post.

Yes thanks, I figured that out today.
Just a good thing for other users to know is when they create a bunch of virtual switches, they will automatically be added to the away mode sensors in STHM. Once excluded per your instructions, it all works great.

That only happens if you have selected to use all sensors. If you manually select individual sensors, new ones are not added.

Interesting: virtual devices created by this driver are not listed when viewing virtual devices in the API+ Browser.

There is a device type in SmartThings named VIRTUAL for native virtual devices (which haven’t really been launched yet). They also appear under the virtualdevices endpoint in the API. A similar thing happens with HUB and hubdevices and GROUP and devicegroups.

As far as the API is concerned the devices made using this driver are actually of type LAN.


I’m unable to see the list of channels or drivers using the Services category. I can drill down from my Hub and see drivers.

I just generated a new token to be sure I had, in fact, checked everything when creating it. Same (lack of) results.

Any clues?

Channels and drivers under the Services tab are the ones you own/created. You can see the installed drivers as you described. I don’t believe there is a list of channels similar to the CLI.

1 Like