[ST Edge] Sonos LAN based Control

Here is my implementation of the Sonos LAN based controller. The documentation (not much needed) is on the GitHub page.


Awesome! Thanks for the work!

I have 5 Sonos in my house. 2 of them (paired as Kitchen - each sonos one SL) 1 is the Sonos one, and 2 are the Ikea Symfonisk … pictures attached. With the Kitchen pair, I can select favorite playlist and play music. The other 3 nothing happens… am I doing something wrong?

I deleted the driver, unenrolled from the Chanel and the sonos are still coming up everytime I do a scan even tho the driver isn’t installed. :thinking::thinking:

Hmm - they clearly cannot be from the driver uninstalled - so they maybe coming up from the other Sonos driver (the legacy one that is still active)…

I will look into your other issue by adding some more debug stuff, but you will need to install the command line to get the debug logs to see what is going on - I only have Sonos ones, Sonos Bridge, and Sonos playbars. I don’t have any Ikea gear - wonder if they behave differently…

Sure actually was. Once I reinstalled the driver. They were picked up by the driver instantly. I have all my 5 sonos working fine. But somehow your driver got stuck. I even rebooted my hub and nothing. Very weird. Let me know once you fix the other issues. I would love to give it a try. Can’t go wrong . TY

I have a similar setup (5 Ones, 4 paired and 1 Symfonisk) and issues to @Drknght4 with controls not showing on any, but very excited to see where this goes.

Thank you for this.

Similar issue as others. I have one Sonos One. Can’t toggle on/off from the tile. Can toggle on off once opened. Can skip forward but not reverse and no playlists show up. Also when the device is playing the time never ights up indicating it is active.


Ok looks like there were multiple issues with the way the update of that information was being scheduled. So I have redone it completely so it happens only once per driver rather than once per device. It was failing only intermittently (some multi-threading issues I presume)…

However, this version has been a lot more stable for me… Why don’t you all try and let me know if it is any better for you all…


Currently I am not getting it to discover my Sonos speaker.

Hi Schwark, what is the new version number? i just uninstalled and reinstalled with the same issues as before. is the latest version 2022-09-24T21:07::58:31690392?

yes, that is the latest version… hmm… Wonder what is going on… If any of you is willing to install the smartthings CLI and send me logs, I can try to figure out what might be going wrong…

Also, which version of Sonos are you guys on? I am on Sonos S2… Wonder if S1 and S2 behave differently also. Most of the Sonos speakers can be updated to S2 - just a question of whether you have or not.

I changed the way speakers are being detected as part of this update. So if they were being detected before and not being detected now, that would be helpful for me to know as well.

Sonos S2 here as well and the speaker is on wifi (not sure if there would be a difference between wifi or LAN). Tried the basic troubleshooting steps…uninstall device as well as the driver and rebooted hub. Clicking the toggle on the tile= spinning toggle and play when opening the device page is hit or miss. Also as I said before, no favorites listed. Also of note, sometimes the on/off toggle within the page is blacked out or just a blue or a black circle…something I’ve never seen before. It’s seems as though the hub is loosing communication with the speaker. I’ll try to get you some logs tomorrow when I get a chance. I’m sure you’ll figure it out.

There is now a later version - please use that one when generating logs. Thanks

EDIT: apparently the changes made, now allows it to be found.

@schwark I have a Sonos One SL (Gen2) and it’s not finding the speaker. My Sonos shows up as a personal device, but nothing that is controlled by a driver. It is running off wifi does that matter?

@Shoot31 now if you could add the ability to use the playtrack from a url. That would make this driver EPIC!

The newest version no longer finds my speaker during discovery

That is interesting… Is it the latest greatest version, as this version falls back on the old way of finding speakers if the new one does not work… So it really uses both AND has a lot of error checking to make sure it does not fail in all kinds of cases. So I am at a loss how it actually got worse without some logs…

Also, it can take a while… So don’t leave the Scan Nearby screen when you see a message “Could not find any devices”… Hang on that screen for a little while longer - and see if they show up then.

I have been trying to see if that is possible - still researching - Sonos requires URLs in their own format and there is a cloud api I think that can translate URLs, but I am still trying to find out how it can be down without the cloud…

Hi, superb driver and great being able to play favourites now, thank you for your time and effort but I have had a slight glitch…

Having had success with one favourite and one routine selecting a favourite when the dimmer was 10 (to test - one Sonos).

I then assigned 4 separate favourites with 4 routines triggered by button presses, all on the same Sonos.

On using these routines nothing worked and all Sonos devices failed to respond, the LAN drivers totally locked across the board for all my Sonos, original stock are fine though.

Then, after 10-15 minutes, all LAN driver issued commands were executed in sequence - as if queued, but…

Favourites are now not being selected although on/off functionality is fine :frowning: So seemingly back to the start point :thinking:

Sonos all v2, ST all current on Android, driver is:

(By the way, all favourites are radio stations… :+1:)