[ST EDGE] [RELEASE] Homeseer Devices, manufacturer-provided edge drivers

They confirmed it will be modified but there’s no ETA yet.


That’s good to hear. Thank you for confirming.


I tested this driver today, especially the LED status mode and individual LED control and have to say that it’s working perfectly, exactly like @krlaframboise DTH which I was using before.

Edit: Just realized the @krlaframboise is also the developper of this new EDGE version one… Good work Kevin!


This is awesome @JDRoberts! Thanks for letting us know, very eager to re-write my old Webcore pistons with the Rules API for these switches!!!

1 Like

@rodcmarr, I don’t find this to be the case. I am controlling all 7 LED rebBlinking when the door is open and then green when closed without turning the switch on

Be sure to set the mode to status mode to ‘Custom’

Then you can set each LED to a different color, independently

Ahhh… @rodcmarr, I misunderstood… I am using the Rule API to enable each LED without turning the switch on or off. I was trying to see where you ran into issues and tried an in-app Routine… that is where you must turn the light on or off to get to the KED settings

If you’re interested in trying the Rule API, I can help/ Share what i’ve written. I’ve had it running several weeks now without issue

1 Like

That’s a confirmed bug in the iOS app that they will be fixing at some point so users need to use the Android app to create a Routine that controls just the LED or use the Rules API instead of a routine.

1 Like

I confirm that is has been fixed in the iOS version of SmartThings release of yesterday (version 1.6.97) hourra !

1 Like

Is this driver eventually going to support HS-WS100 and HS-WD100 switches?

1 Like

Last information from Homeseer support was that those two models would not be included because they are no longer sold by Homeseer. However, I believe the community-created driver does have them.


While I am able to enroll for the new edge drivers, I am unable to re-add my device. Search nearby rarely works, and there is no listing for HomeSeer devices. Any ideas on how to add my device back?

Try these links

I enrolled in the official Homeseer driver. My issue isn’t the driver, it is re pairing the device- unless the driver is required for Homeseer to show up on the device list.

I’m addition to enrolling in the channel you need to install the needed driver from the channel.

The unofficial community channel might include more older devices than the official channel.

And with Z-Wave use need to exclude the device before you can re-pair it.

Under the bub drivers it says I’m registered for the HomeSeerer Edge Driver. Is there an additional step? Also, I’ve got a legacy HSFS-100, which appeared to be on the homeseer list. I think in either case Homeseer should show up on the list of device to connect, even if I have the wrong one sintalled?

I also think I excluded the device (the app said so, but it still seems to show up as offline).

This device has a history of being flakey so the symptoms also make it hard for me to know if I’m attempting the right approach.

Any other suggestions would be greatly appreciated.

The registration is for the channel you also need to install the driver. I would also install both drivers to see if will pick one



I’ve got both listed separately, but for Homeseer drivers it just says " Homseer edge driver", with a suffix of “Homseer edge drivers”

ok, this is now working with a new driver, but lots of issues with intermediate things not working right- but the Driver was not the issue- so here were the challenges (for others not forced down the path as I was today):

  1. Exclude reported complete in ST app, but actually not excluded (API, app and ISE noted this correctly).
  2. Trying to add this twice, new devices randomly added to different rooms, and different types of devices added.
  3. So I had to manually delete and start again, reported as nothing added.
  4. Search by name did not have “homeseer” available to add, but add nearby mode did work sort of.
  5. Instructions for device reset, not completely accurate, but ultimately solved the issues.
  6. Then the manual process to reconnect automation, move to the correct room, etc.

Is there a smart bulb mode? Which means not actually disconnecting the power but turning off the smaet bulbs.
The Amazon listing says that it has but I cant figure it out.

Also can the LED brightness be reduced. It’s too bright.

This is incredibly sad and feels narrow minded. These switches (HS-WS100 and HS-WD100) are not THAT old. I bought my last batch about a year ago…

The community driver seems very good, but not perfect, and official vendor support would probably build further trust into future compatibility.