[ST Edge] Issues with released Drivers

I have seen It now.
In the status monitor of the favorites page, app android, the door open warning of the multipurpose sensor that has the edge driver installed does not appear.
With the DTH it did appear.

Yes, those options are not included in the local execution yet. Our team is working on that but there’s no ETA yet.

I can’t see the logs yet due to the below error which I have raised on a related thread, however I think this may be the reason why my Xiaomi illuminance sensor does not produce any readings using the zigbee-illuminance-sensor driver

None of my IKEA motion sensors should have gone active for a couple of days now. That hasn’t actually stopped some of them (grrr …). Three with Edge drivers have gone offline. I’m pretty sure those are the ones that haven’t been activated.

Mind you if they are relying on battery reports to stay online all bets are off as I have too many Tradfri Outlets around to muck things up. On reflection everything I have from IKEA is actually letting me down.

1 Like

Hi, Graham. Thank you for sharing the behavior of the devices, I’m checking some details with the engineering team so, I’ll get back as soon as I get their feedback. Thanks!

7 posts were split to a new topic: [ST Edge] Zigbee Illuminance Measurement

Back home now and all my motion sensors are online again without my doing anything. I’d like to think it was the motion events that put them back online. Recovering from being offline is great but I’ve yet to figure out what put them offline to start with.

Just pointing out that the ocf device type for illuminance sensors never had an icon so that’s not a new issue.

Just tried the Sonoff SNZB-04 contact sensor, which identifies as the eWeLink DS01, with the Zigbee Contact driver. Initial reaction is open/closed looks fine but there may be issues:

  1. It looks like the profile being used includes the temperatureMeasurement capability. I’d be delighted if it did support that but I don’t think it does.
  2. The battery level with the DTH was 60%, which sounds reasonable, but the Edge driver is reporting it as 3%. OK, the second one I tried had 74% in the DTH but is showing 69-70% in Edge which seems fair enough so I changed the battery in the first and tried again and got 100%. So that is probably OK. No wonder they are practically giving these things away at the moment.


  1. One of my devices that had been open since about 14:30 was showing offline when I just looked (about 18:30). Closing it brought it back online.

The Sengled and at least one of the Nyce contact sensors in that driver don’t support temperature either. I’m surprised there isn’t a sub-driver without temperature capability.

I believe this is the fingerprint that the “Sengled” device matches, right?

contact-battery-profile only includes the contact and battery capabilities, does the temperatureMeasurement tile appear in the device UI?

Do you know which is the other Nyce device that doesn’t include this capability, @Automated_House?

It’s different from the profile used by eWeLink DS01, which indeed includes the temperatureMeasurement capability. I’ll report that, @orangebucket to see if there was an error assigning the profile.

The Nyce one is correct. I missed the different deviceProfileName set for it. Thanks!

1 Like

To test the Beta Contact Sensor edge driver, since it did not detect my open/close sensor as compatible, I have added the LIDL open/close sensor fingerprint with contact-battery-profile.

  - id: "LIDL Open/Close Sensor"
    deviceLabel: LIDL Open/Close Sensor
    manufacturer: _TZ1800_ejwkn2h2
    model: TY0203
    deviceProfileName: contact-battery-profile

It is working well.

  • The configuration seems well done, since it reports the status every 300 sec, according to the default configuration.
    The battery also reported a change since installation and have the percentage remaining calculation.
  • The same thing happens to the edge driver smartthings multiporpuse sensor. It does not appear in the status monitor of the favorites page when it is open.
    More specifically, if the sensor is open when you install it, it appears in the status monitor. When you close the app and reopen it, it no longer appears

Do you happen to have any Lidl motion sensors? Motion Sensor driver needs Lidl fingerprint :relieved::grinning_face_with_smiling_eyes:

I’ll try it as soon as I can and tell you something

Modified edge driver “zigbee Motion Sensor” with LIDL Motion Sensor fingerprint with motion-battery profile works fine.

I will update if any problem appears

  - id: "LIDL Motion Sensor"
    deviceLabel: LIDL Motion Sensor
    manufacturer: _TZ1800_fcdjzz3s
    model: TY0202
    deviceProfileName: motion-battery

This is great and needs to be added to the official driver eventually. :relaxed::pray:

Yes, right.
Adding this fingerprint data to the fingerprint.yml file

and then doing the package and publish with the CLI.
Installation in the hub can be done with the CLI or from the app by opening the Drivers option in the hub menu.

Uninstall the sensor and reinstall it by searching nearby

1 Like

In the drivers page of the Hub, when you exceed what can be seen on a page, it does not scroll down and you do not see all data

1 Like

Thank you for sharing, this is already reported. We’ll let you know about the progress. :smiley: