[ST Edge] Issues with multi-component devices and third-party integrations

Can you try this version of the Z-Wave Switch Mc to see if you can control channel 1 with main and channel 2 with Switch1 from the app?

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-15T16:23:17.548625           │
└─────────────┴──────────────────────────────────────┘

I am having the similar issues as @lewisburgess with z-wave dual switches using both stock z-wave switch driver and z-wave switch mc driver with Minoston Z-Wave Plug Outlet Dual On/Off Switch Outlet (MP20Z). I have no control of the second outlet using either driver.

Issues with Z-wave switch driver

With this latest version either?

I will try once it updates and it and report back. I still have verson 2022-03-11

1 Like

I still dont have this version available.

I published it again, just in case.

If you have the CLI in use you can install it immediately with the command
smartthings edge:drivers:install

1 Like

This now works to control both loads with the Minoston Z-Wave Plug Outlet Dual On/Off Switch Outlet (MP20Z).

I am fine with this version but wanted to note that the switches don’t control the expected outlets.
Main controls the Right (secondary) outlet and Switch 1 controls the Left (main) outlet. Thank you for fixing this!

Hi,

This is improved on the Fibaro Double Switch

Main controls 1 load and Switch 1 controls the other from within the app.

But, there is an issue in the app changing state when either toggle switches change state. Looking at the logs, the hub is not seeing a state change and therefore, the app state is not changing. I have occasionally seen a button “pushed” but rarely.

Secondly, I use an IKEA button (with an Edge driver) to control some bulbs and both of these devices in a routine. There is a very significant delay in the Fibaro Double Switch switches changing state. The bulbs fire straight away. In a different room, with a Fibaro Dimmer and several bulbs, the states change straight away.

I haven’t tried removing the device and re-adding it. It’s the only Fibaro Double Switch I have. The Single Switch seems to be the same as before (you know I have a case open with ST about this). The Dimmers all work as usual. I removed my Aeotec Double Switch entirely as I have no use for it elsewhere in the house so I can’t try this (as you know, I was having big trouble with this).

I’ll send you some logs in a PM.

Thanks :slight_smile:

I didn’t change anything for the fibaro double switch. It Use the stock driver code.

I have one with the driver and it updates the toggle states change in the app correctly and without delay.

Oh, well it has improved - so something’s changed!

What would you like me to test?

I thought you had a problem with the double switch aoetec, but it seems that you no longer use it

Ah yes, sorry. It was so bad I had to remove it. I have mentioned it privately to ST in my support case about the Fibaro Single Switch and asked if they’re serious about be doing some diagnostics on this. If so, I’d reconnect it. But it is quite a pain to do this so not ideal.

Hi Mariano,

I tried adding the Evalogik Outlet using the Z-Wave Switch Mc driver.
- id: 0312/C000/C003
The app updates when the physical outlet is switched but I am unable to control via the app. I tried restarting hub, removed and re-added device without any luck a few times. No errors seen in logcat when adding.

Also, would you please add this Minoston Outdoor Dimmer MP22ZD at your convenience? Thank you

Raw Description: zw:Ls2a type:1100 mfr:0312 prod:FF07 model:FF03 ver:1.00 zwv:7.13 lib:03 cc:5E,55,9F,6C sec:86,26,70,85,8E,59,72,5A,73,7A

Try to capture the log when you turn on and off then device from app

Try this version v4 with the double plg and with the single
the changes I made yesterday fixed your double plug, but it messed up the single plug on some devices, each manufacturer works differently.

Added dimmer Minoston

  - id: 0312/FF07/FF03
    deviceLabel: Minoston Dimmer
    manufacturerId: 0x0312
    productType: 0xFF07
    productId: 0xFF03
    deviceProfileName: switch-level
┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch v4                     │
│ Version     │ 2022-03-18T18:04:48.886215           │
└─────────────┴──────────────────────────────────────┘

This works well with the following devices
Evalogik 1ch Outdoor Plug ZW96 - id: 0312/C000/C003
Evalogik Outdoor 2ch Plug ZW97 - id:
Minoston Outdoor Dimmer Plug MP22ZD - id: 010F/0102/2000
Minoston Dual Switch MP20Z - id: 0312/FF00/FF05

A few questions…
Do you have a github for your z-wave drivers? All I can find is your zigbee drivers.
How can I get the device id for edge devices?

Thank you so much for all your work and patience! You are very much appreciated.

2 Likes

I haven’t published any Zwave drivers on github yet

If you mean this id: 0312/FF00/FF05, is the fingerprint_id of a device in a driver. If you change this device to another driver it may have a different fingerprit_id.
Whoever makes the driver can freely assign a fingerprint_id of up to 36 characters
I don’t know how to get

I have already added the dimmer to the Z-Wave switch Mc driver and you can pass them all to this version of the driver

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-18T18:57:41.883923           │
└─────────────┴──────────────────────────────────────┘
1 Like

Do you mean the network ID that the hub assigns to a zwave device at the time it joins the network? Usually given in Hex as a two character ID between 00 and FF? The one you need to set associations?

I know there’s a way to query it with the CLI, but I don’t know the specifics. I think @philh30 had a post on it somewhere…

Tagging @nayelyz

1 Like

I think this is the post you’re referring to:

But @Terri_Baker was already in that thread…

3 Likes

@Terri_Baker,

the device ID <ZwaveDevice: bd5c15c7-76f5-4430-b95d-c8ea349e9f61, DNI ( device network identification) [1E] and device name (Luz Entrada) can see in logcat with the CLI in all device logs

2022-03-18T18:59:08.274439592+00:00 INFO Z-Wave Switch Mc  <ZwaveDevice: bd5c15c7-76f5-4430-b95d-c8ea349e9f61 [1E] (Luz Entrada)> received lifecycle event: infoChanged
3 Likes