[ST Edge] Issues with multi-component devices and third-party integrations

Ah yes, sorry. It was so bad I had to remove it. I have mentioned it privately to ST in my support case about the Fibaro Single Switch and asked if they’re serious about be doing some diagnostics on this. If so, I’d reconnect it. But it is quite a pain to do this so not ideal.

Hi Mariano,

I tried adding the Evalogik Outlet using the Z-Wave Switch Mc driver.
- id: 0312/C000/C003
The app updates when the physical outlet is switched but I am unable to control via the app. I tried restarting hub, removed and re-added device without any luck a few times. No errors seen in logcat when adding.

Also, would you please add this Minoston Outdoor Dimmer MP22ZD at your convenience? Thank you

Raw Description: zw:Ls2a type:1100 mfr:0312 prod:FF07 model:FF03 ver:1.00 zwv:7.13 lib:03 cc:5E,55,9F,6C sec:86,26,70,85,8E,59,72,5A,73,7A

Try to capture the log when you turn on and off then device from app

Try this version v4 with the double plg and with the single
the changes I made yesterday fixed your double plug, but it messed up the single plug on some devices, each manufacturer works differently.

Added dimmer Minoston

  - id: 0312/FF07/FF03
    deviceLabel: Minoston Dimmer
    manufacturerId: 0x0312
    productType: 0xFF07
    productId: 0xFF03
    deviceProfileName: switch-level
┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch v4                     │
│ Version     │ 2022-03-18T18:04:48.886215           │
└─────────────┴──────────────────────────────────────┘

This works well with the following devices
Evalogik 1ch Outdoor Plug ZW96 - id: 0312/C000/C003
Evalogik Outdoor 2ch Plug ZW97 - id:
Minoston Outdoor Dimmer Plug MP22ZD - id: 010F/0102/2000
Minoston Dual Switch MP20Z - id: 0312/FF00/FF05

A few questions…
Do you have a github for your z-wave drivers? All I can find is your zigbee drivers.
How can I get the device id for edge devices?

Thank you so much for all your work and patience! You are very much appreciated.

2 Likes

I haven’t published any Zwave drivers on github yet

If you mean this id: 0312/FF00/FF05, is the fingerprint_id of a device in a driver. If you change this device to another driver it may have a different fingerprit_id.
Whoever makes the driver can freely assign a fingerprint_id of up to 36 characters
I don’t know how to get

I have already added the dimmer to the Z-Wave switch Mc driver and you can pass them all to this version of the driver

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-18T18:57:41.883923           │
└─────────────┴──────────────────────────────────────┘
1 Like

Do you mean the network ID that the hub assigns to a zwave device at the time it joins the network? Usually given in Hex as a two character ID between 00 and FF? The one you need to set associations?

I know there’s a way to query it with the CLI, but I don’t know the specifics. I think @philh30 had a post on it somewhere…

Tagging @nayelyz

1 Like

I think this is the post you’re referring to:

But @Terri_Baker was already in that thread…

3 Likes

@Terri_Baker,

the device ID <ZwaveDevice: bd5c15c7-76f5-4430-b95d-c8ea349e9f61, DNI ( device network identification) [1E] and device name (Luz Entrada) can see in logcat with the CLI in all device logs

2022-03-18T18:59:08.274439592+00:00 INFO Z-Wave Switch Mc  <ZwaveDevice: bd5c15c7-76f5-4430-b95d-c8ea349e9f61 [1E] (Luz Entrada)> received lifecycle event: infoChanged
3 Likes

Has any more progress been made with this. Ive recently started running into some issues when moving things over to edge.

As above the issue is that I cant have individual tiles for each side of a socket and cant control them independently or by voice.

I have 5 Alcione Aurora Aone smart sockets. Both worked great, both had official ST support and paired (both sides) no issues. However they are so buggy and often go dead.
I re-paired them using edge. Didnt work. App kept crashing or no response at all. I deleted them and put them back on using the stock DH from ST. They work fine for now. Speaking to Aurora support, they will no longer be developing this product so once the ide goes and i need to use edge - will i lose the ability to control the other side of the socket?

I also have 4 ClickSmart sockets. Paired as a single Switch to start. Change the device to Zigbee Multi Switch Power and they work, have done for ages.
That was until this week.
@Mariano_Colmenarejo has helped massively by sorting the drivers out. However so far i cant voice control the second side and cant have independent tiles.

So far all ive had from smartthings is a guide on how edge drivers will work
However it seems this doesnt and heavily invested, now worried it wont at all.
Seems a massive step backwards at the moment.

1 Like

In order to gain voice control over multi component switches you will need to create a virtual device and set routines to mirror the switch.
Mariano made a mirror device that only requires 2 routines per device. Edge Driver Virtual Appliances Mc

Hi yes thank you, thats all well and good and thank goodness people like Mariano have done it.
but simple question why should we? They said transition would be seamless.
Except for plugs, light switches……

Not only might we have to re-add all our devices, we then need to make virtual devices to get them working as they used to? Plugs alone I would have 18 to make. There must be people with many more

Is that really progress?

Look at some of the smart apps that are being broken too. Yes some great users are working very hard to make a fix for them but it feels like another step back.

Their new CEO has said

“So, you have a chasm between the early adopters and innovators, who really know how to run a smart home, and the everyday user who has some smart, connected devices but doesn’t have a handle on the full scope of a connected home.
The future growth is really in this user”

So a new user get SmartThings in their new 2022 tv. Thinks great whats that, id like some smart home. Watches some demos, goes on amazon and finds a smart plug or multi switch that is SmartThings compatible.
They pair it. Only one side works.

Will that early user be told on any instructions or will they know to look here to find the solution? NO
Will the average/basic user want the hassle?

Are any manufactures going to want to make multi plugs for SmartThings if they know that edge drivers dont actually let users use them properly?

So does that help that user and does it bridge that gap?

They could get a tuya hub and devices for less and it will work. Or they could move to Apple which will just work

I am between both types of user. I have been able to add code and get many devices to work and i like to find ways to make things work. However I am not a programmer so i have no clue how to build any code and really appreciate the work done on here. But, im a believer that it should be as sinple as plug and play.
If they are trying to break out into the world on a bigger scale by putting smartthings on all their new phones, in their fridges and tvs, then it needs to be simple.

The whole point of smart home is to make it smart.
Having to add another driver and make virtual 2 virtual switches for a device to work as it should is just backwards.

5 Likes

The API includes a device type named EDGE_CHILD. Just thought I’d throw that out there.

Hi @nayelyz
Any information from engineering team, regarding this matter ? It has been almost 9 months and we haven’t got any information so far ?

Basically we want to know if we could get same behaviour as option as previous official smartthings way of handling multi component devices, so each component is separate device ? So we can use them separately for instance in voice assistants.

4 Likes

I am trying to set up the mirror to be able to control the second device but it does not seem to be working. I have tried both the ST Z-Wave Switch and @Mariano_Colmenarejo’s version and in the routines I do not have the ability to independently turn on/off the second switch.

These are the only options I have for the routine control:

Even though I select only switch 2 on and off, it turns main on:

I just installed both the drivers today so they should be the latest version. What am I doing wrong?

FYI, I am using iOS on iPhone/iPad.

I’m not sure if it’s different on iPhone since I only use Android.

You should have 3 options for each switch
Turn On or Off
Turn On
Turn Off

Are both switches independently working from the physical device and the app or does 1 switch turn on both?
Which driver is the switch currently pair with?

The device is a Qubino Flush 2-relay. Both physical switches work properly and when I open up the device in the app I can independently control each relay. For some reason in the routine creation, I don’t get the on or off options (see picture in my OP). I figured I should have those three options just like any other device but it does not seem to be working.

I switched back and forth. ST initially matched with Miariano’s driver and I switched to the ST driver. Both seem to look the same so maybe there is a cache issue? I know this is working for most people so not sure why this looks the way it does.

Is there an iPhone setting for the equivalent of the clear cache on Android? Other than that have you tried restarting the hub?

Edit
@jkp I thought I recall that you have an iPhone. Any idea how to help?

@guxdude

This is a issue if IOs App un the Then part of the rules.

I Hope It fixed early

1 Like

Ahh. Ok an iOS bug. I thought I was going crazy. Thank you.

@nayelyz is there a place where I can track this bug? Any idea when it might be fixed? I can’t operate most of my house with out this as I have a lot of these 2-relay devices.
Thanks