[ST Edge] Issue with the Z-Wave Switch driver

This fixed it. Thanks for your help

1 Like

@Mariano_Colmenarejo Is it possible to add an option for multi switch device tile?

Hi @Terri_Baker

The Zwave switch driver has more than 50 profiles, of which more than 20 are for multi-component devices.
making presentations with multi tile involves duplicating the profile and adding code to perform the profile change.
If it’s for one in particular I could do it.
Giving presentations is quite tedious

It’s for 2 devices. I am in no hurry and and feel free to say no. I really appreciate all you do!

minoston 2ch plug MP20Z
id: 0312/FF00/FF05

Evalogik Outdoor 2ch Plug ZW97
id: 0312/C000/C005

Hi @Terri_Baker

this device in fingerprints.yml is a single smartpug-binay

  - id: 0312/C000/C005
    deviceLabel: Evalogik Outlet
    manufacturerId: 0x0312
    productType: 0xC000
    productId: 0xC005
    deviceProfileName: smartplug-binary

Could by C004 or C007?

#  - id: 0312/C000/C004
#     deviceLabel: EVA Switch 1
#     manufacturerId: 0x0312
#     productType: 0xC000
#     productId: 0xC004
#     deviceProfileName: dual-switch
  - id: 0312/C000/C007
    deviceLabel: Evalogik Switch 1
    manufacturerId: 0x0312
    productType: 0xC000
    productId: 0xC007
    deviceProfileName: dual-switch

Added in preferences option for multi Tile profile for all devices use dual-switch profile

  - name: "changeProfileDualSwitch"
    title: "Select Tile Type"
    description: "Select Multi-Tile or Single-Tile Type (default: Single-Tile Switch)"
    required: false
    preferenceType: enumeration
        "Single": "Single-Tile Switch"
        "Multi" : "Multi-Tile Switch"
      default: "Single"
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-09-01T18:46:10.49888026        │

Hi @guxdude

is Qubino flush2 relay working fine?

Sorry for the bother. Yes, I excluded it and re-included it and it seemed to start working right. If it acts up again, I will let you know. Thanks.

1 Like

I’m trying to migrate my Evalogik 2 outlet plug to the Edge drivers … I installed the “Z-Wave Switch and Child Mc” driver, deleted the device from the app (and IDE). I was able to re-add it to ST, it found the correct Edge driver and I went into the setting to select the Multi-tile switch and toggled the “Create single device for Switch1” button.

I now have 2 tiles: Main and Switch 1, but that’s where things started going wrong. The main device says it either “has a problem connecting” or “it hasn’t updated all it’s info yet”. The device details shows two switches, but they’re both grey’d out. Can’t click anything. If I back out to the room, I can tap power and after spinning for a while it stays “ON”.
The Switch 1 device controls the main / left outlet (looking at the device with the button up and label down). That seems to work well.
I tried setting up a scene to turn both switches on/off but that didn’t work either (it only controls the main switch). Turning the switches on and off from the physical button works (1 press controls the main switch, 2 presses controls the secondary one).

Edit: Using the standard Z-wave switch only gives me one switch, which also controls the main (left) plug. I’ve deleted re-added this to ST more than 10 times so far :frowning:

Did you try creating a routine (not a scene) to turn on switch 1? You can use another device or time as the trigger. That is the only way I got switch 1 working. Once it was working I just deleted the routine.

Just did. I added both the main switch which has options for main and switch 1 and switch 1 to the routine. All kind of combinations between on, off and on or off. It didn’t help.

Nope, but this is a z-wave dual plug. I don’t think I could even switch the driver to a zigbee one, would I? I just installed it just for kicks and doesn’t let me select it :slight_smile:

Apologies my mistake

1 Like

Things stabilized a little. I no longer get the time-out errors and the device responds to commands instantly (plug must have found a better z-wave path). Both the Main and Switch1 buttons control the left plug. When I turn either of them on in the app, both show as on and vice-versa.

Here’s another observation when using the physical switch - this shows there is some kind of communication (status updates) from the right plug to the app, but no control.

  • When I turn on the left plug (1 click), the app shows both Main and Switch1 as On. I can turn off the plug from the app by pressing either switch.
  • When I turn on the right plug (2 clicks), the app shows the Main switch as On and Switch1 as Off. Pressing Off on the Main switch in the app doesn’t turn the plug off, but flips is to Off in the app.
  • Turning Off the right plug (2 clicks) will also turn off the Main switch in the app.

I tried the Old driver and ran the routines again to see if I can get the 2nd plug to react and it still didn’t work. @Mariano_Colmenarejo do you have any idea on this one?

Hi @neod192

I won’t be able to check anything until Friday. I don’t have access to the code or CLI.

Send me the exact fingerprints of the device so I can identify it in the driver and see if there is something specific to do for it.

you can pair it with z-wave thing Mc to see the information of the endpoints and commad class

Could be needed logs to see wath device send when Turn on ana off avery Channel

No rush! I appreciate the help and your drivers are amazing :heart_eyes::heart_eyes::heart_eyes: Here’s the fingerprint. I haven’t used the CLI yet, but I can look into it if you need the logs. Thanks!

When I can, I’ll look in my driver to see which endpoint each component is assigned to.

In the stock driver, endpoint 0 is assigned to main and 1 to switch 1.

You can try the stock Z-wave switch driver to see if it does the same

With the stock driver, it only shows one switch and it controls the main plug. I’m kind of surprised it doesn’t show the 2nd one at all…

It may be created in the hub room or unassigned room

Nope … ! I wonder if my switch has end points 1 and 2 instead of 0 and 1?