[ST Edge] Issue with the Z-Wave Switch driver

Enter to the device driver menu and check from which channel the driver was installed, SmartThings Driver (Beta)?

Nope, it’s the production one. I can try the beta and see if there’s a difference.

1 Like

Yes, are different, production has not activated your device fingerprints, according GitHub. Although the production code has some weird stuff, it looks outdated, it doesn’t have child devices and the production drivers do.
I thought it was just me that had outdated github

2 Likes

On my gosh! The beta Z-wave switch driver added a 2nd switch and it controls the 2nd plug! The first switch still controls the main plug. It works as expected :slight_smile:

3 Likes

Hi! I have a Qubino Flush 2 Relay.
I realized the Smarthings’s Channel Z-Wave Swith is showing only the SW1, and controlling it, so I changed the driver for Mariano’s. It’s ok. I can control SW1 and 2, but only with 1 device. How to create the Child device? (In the Settings, I switched “Create Single Device for Switch2” on)

Thanks!

Yes, child device will appears in the same room of the your hub

It didn’t appear, can’t find.

Hi, @PAndras
Have you searched the device by name? You can also use the Advanced users’ app to search for it.

1 Like

You can try turning off device creation in preferences and turning it back on.

If it had not created then it will be created and if it already exists it will NOT be created again

Hi @nayelyz

I think something has happened and EDGE_CHILD type child devices are no longer created. :man_facepalming: :man_facepalming:

I have tried with two different drivers and neither creates new CHILD_DEVICES device

I think lifecycle added is not called and the device is not added.

New LAN devices are created

We already got a report about this. Now you mention it as well, it can be a general issue.
I’ll ask the team about it.

1 Like

Hi, @Mariano_Colmenarejo
Can you replicate the issue and submit the Hub logs, please?

  1. In the Advanced Users app, enter the “Hubs” section
  2. Enter the corresponding Hub and click on “Dump Hub logs”
  3. Confirm the process by clicking on “Dump Hub logs” again in the pop-up.
  4. You’ll get a green box at the top confirming the Hub logs were requested.

We also need your Hub’s ID (you can share it over DM) to find your logs in the server, please.

Hub Logs and info sent by DM

1 Like

Hello, @nayelyz

Could it have something to do with the fact that the hub says that childDeviceAvailability : Unsupported?
I had not seen this before

I am also seeing that on both of my v2 hubs.

I was wondering about that, but it can be seen saying ‘Unsupported’ in a post made by Bruce in mid-July and I have a dump from early April saying the same for my hubs. The Advanced Web App really ought to explain why we should care what the hub characteristics are.

1 Like

It seems that it has more to do with the fact that the hub does not support other child hubs devices, but it is all assumptions.

I tried it, but nothing happened

Searched, but it isn’t exists

@nayelyz Can we get ST Dev team to look into this?

This is a breaking change.