[ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins

Edge devices are truly Local, but the IDE always shows them as cloud.

3 Likes

The Groovy IDE is due to be shut down, so ST hasn’t been bothered to update it to properly reflect devices using Edge drivers. Until ST opens up a new interface that’s easier for end users to navigate, the CLI is the best place to look for details on any device using Edge.

If you want an easy way to confirm that the device is now running local, try setting up a routine that turns this device on at a certain time. After you save, you should see a house icon on the routine’s tile, indicating that it (and all devices in the routine) will execute on your hub.

1 Like

Thank you @philh30

1 Like

Motion Switch and Dimmer have been added. You’ll need version 2021-12-29T21:03:17.669163 of the driver for them to work. If you’ve already installed the driver, the new version should push to your hub sometime in the next 24 hours (or you can force it through the CLI using edge:drivers:install).

I only have the Switch, so you’ll have to let me know if you encounter any problems with the Dimmer. You should see switch, dimmer and motion sensor as controls on the detail view, and the various configuration parameters in settings. I may circle back to this after I’ve used it for a little while and add custom capabilities to control some of the config parameters, but if I do that it’ll be in a separate driver.

1 Like

@philh30, Jasco 45856 is a Zigbee Wall Switch with power meter capability. Can this be included?

No. This one will only work for z-wave, so someone will need to write a separate driver for the zigbee models. I have a few of the zigbee ones too, but I haven’t done much zigbee coding so I’m not to eager to jump on those.

If you send me the manufacturer and model, I can add It to the zigbee switch power Mc driver and try.

This is the limk to the thread
https://community.smartthings.com/t/beta-zigbee-edge-driver-compatible-with-lidl-ecosmart-osram-smartthings-others/231689?u=mariano_colmenarejo

2 Likes

Thanks Mariano! I’ll post the switch and dimmer over there.

2 Likes

Out of curiosity, does ST Edge and this driver for the 26933 allow you to run routines that alter the default dimness setting? My use case scenario is a bathroom light dimmer; in the middle of the night the dimmer triggers by motion and turns the lights on, but super dim so as not to blast you with light. During daytime hours the dimmer triggers by motion and turns the lights on, but to 100% brightness without me having to hold the up button. Currently I’m doing this through a WebCore piston and the DTH written by MichaelS for the Groovy IDE, but it is my understanding that WebCore will no longer exist after the switch to Edge.

My driver specific to the motion switches and dimmers (available in the same channel as this one) has a few of the parameters for those devices available on the detail view and in routines. I’ve only included default dim level in the settings at this point, but it can be exposed in the same way with a custom capability. Based on your use case it makes sense to do that, so I"ll work on that in the near future.

1 Like

That’d be awesome. Thanks!

2 Likes

I accomplish this scenario by using times or modes in the built-in routines. I have 2 different routines - 1 for the evening/night and 1 for the daytime. See my example screenshot.

1 Like

Hey,

@jeremykeen I like your suggestion.

However, it looks like changing modes is not done locally.

If there is a way, let us know.

An alternative, not quite as clean, is to put in the 2 rules as you suggest, and have each rule using time period as one of the conditions.

The one drawback, is that then the time period has to then be entered for each rule separately, and if the times do not agree, because of manual data entry mistake, then there might be weird behavior.

Jeremy, my understanding is that the switch/dimmer is still a functional switch/dimmer irrespective of SmartThings, and that when it detects motion it will within its internal electronics turn the light on to whatever the default dimness setting is. Your routine is something that runs on the ST hub, and not within the switch. As such, my concern is that there may be a latency that results in the detection of motion, the lights going bright, and then the hub causing them to go low. I do concede that my concern may not be valid with the transition to Edge and the low latency that comes with running routines on the local hub rather than in the cloud though, so I’ll defer to your experience as I have not yet transitioned to Edge, and am only trying to line things up for when I’m forced to.

1 Like

@maranhao

I was wondering if you meant something a little different. :slight_smile: lol

As far as @jeremykeen solution, it works fine because the hub sends the dim/on command as one command, and this is unaffected by cloud or local processing.

In other words, the routine does NOT send the “on” command and then the “dim” command.

In fact you can test this in this way.

Start with the switch off. Go into SmartThings and set the light to some brightness. Notice that the light goes on to that brightness directly. And that there is no way to set the default brightness without turning on the light

I am not sure there is a way to set the default brightness of a zwave light dimmer switch without turning it on, using default zwave dinner switch handlers.

Are you saying, using the custom handler and webcore you are able to modify the default brightness without actually turning on the light?

That the next time the switch is manually turned on at the switch, it goes to this brightness?

1 Like

Changing location mode is now local. Changing security mode is still cloud.

Still a valid concern. There’s still latency (albeit much smaller) with Edge - the z-wave motion report still needs to bounce through your mesh, be processed by the hub, then the set level command bounces back. I’m pretty confident the internal motion sensor of the GE/Jasco motion switch/dimmer models will trigger faster than a local routine.

This driver exposes all of the GE/Jasco configuration parameters for each model, and the dimmer models tend to have default dim level as a configuration option.

1 Like

Yes this is correct if you have the dimmer/switch set to occupancy mode. I set mine to manual and control the level with SmartThings. There is a very slight delay but in most cases it is nearly imperceptible compared to the occupancy mode. I also use this method because in some cases I have multiple switches I am controlling with the motion event.

@professordave I do have automations using modes that run locally. This one:

1 Like

It has been a while since I set up this routine, and I certainly am not always in the bathroom at the time the default brightness setting changes, but to my knowledge when WebCore changes this setting it does not trigger the light on.

@jeremykeen
Yes, you are correct it looks like location stuff runs locally. Not sure what I was looking at before when I said it was not local

@philh30 I have a new switch for you to add. I played a bit with the GitHub code however figured it’d be better to have it in your git. I was able to get the switch to function however the settings I was not able to get working. It works with other Jasco device handlers to enable the multi-tap (2,3) functions.

The switch is a Jasco unit. It’s boxed as an UltraPro. Raw description from the SmartThings API portal is:
zw:Ls2a type:1001 mfr:0063 prod:4952 model:3238 ver:5.53 zwv:6.04 lib:03 cc:5E,55,6C,9F,22 sec:25,85,59,86,72,5A,73,5B,70,2C,2B,7A

Edit: it looks like the Honewell switch on your driver is quite similar (Jasco after all). the part number on the UltraPro switch box is 39354.