[ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins

Check the manufacturer number in the Advanced Web App. If it came in as all 0’s, exclude and re-add again.


Thanks for reply Mark!
Yes, it showed up as all 0’s, tried to exclude it and include it again and it’s 0’s again.
Very strange :frowning:

I just moved the outlet closer to ST to make the removal/pairing easier,
tried to exclude and include it about 6 times and the 0’s ID problem still persists.
Tried using the scan nearby devices, and find it in the list of devices, no difference.

I have had this issue, you may want to try and get them right next to each other. Try moving the hub right next to the outlet and then move it back after the device has paired agian.

1 Like

Thanks, will try that :+1:

No. I’m not expanding this driver beyond the units manufactured by Jasco. If you’re just looking for generic support then you should be able to use the stock z-wave switch driver. You’re also welcome to take the source code for this driver and package your own version that includes whichever fingerprints you want to add.

Curious if it’s possible to make the fan icon spin like it does on the stock driver?

What shows as the state on the dashboard? Is it Off/Low/Medium/High or something else?

I get the Off/Low/Medium/High. The icon does change from grey to color appropriately it just doesn’t spin when on. Had assumed it was a limitation but thought I’d ask.

They used to spin (animated icons)

They do with the stock driver. I don’t think they ever have for me with this driver.

@philh30 so is this possible?

I have a Enbrighten dimmer, model 42603, fingerprint 0063-4944-3235 - I’m pretty sure this one:

The behavior of the switch just changed in the last couple days and tapping the down button no longer turns it off - instead, it dims to the lowest level and I have to tap it again to turn if off. Has anyone else experienced this, and how do I change it back?

Edit: I changed the driver to the SmartThings one to see if it still dimmed instead of turning off and it didn’t. I then changed back to this driver and it still tuning off (as I would like it to). Strange!

I have a fingerprint not on the list. 0063-4952-3239
It is supposed to have LED indicators as well. Will that show if added to this driver?

@philh30 Im having an issue with the drivers. I have a GE/JASCO Dimmer switch and its recognizing it as a fan switch in the fingerprint. Ive deleted it and re-added it but comes back the same. What might I be doing wrong?

What is the fingerprint (Mfg Code and Model) you see for the device in the Advanced Web App?

1 Like

mfg code is 0063-4944-3034
model 4944-3034

The driver has that fingerprint as a “legacy fan” switch.

  - id: "0063/4944/3034"
    deviceLabel: GE Fan 12730
    manufacturerId: 0x0063
    productType: 0x4944
    productId: 0x3034
    deviceProfileName: ge-fan-legacy

@philh30 is going to need reconcile the discrepancy between what’s in the fingerprints.yaml for the driver and the device you have.

1 Like

That’s a 300 series (very old) in-wall fan control. It could be that you’ve wired the fan control to a lighting circuit (I have no idea whether the fan control is rated for that). If you remove the wall plate and post a picture of the switch there should be some markings on the metal to give confirmation of which model it is.


OK, It could very well be a fan switch because I bought it from amazon and ive had them send me some wonky stuff before. That being the case, I dont see a need to revamp anything on your end. Ill just move it over to a fan and buy a new dimmer switch and call it a day. I just wanted make sure I wasnt doing anything wrong. Thanks for the input guys.


I have a fingerprint not on the list. 0063-4952-3239