Speaker Notify with Sound no longer has custom message option

smartapp
sonos

#1

Noticed this morning that my “Speaker Notify with Sound” app no longer has the option to input a custom message (see screenshot). If I make any edits to the app and hit done, then the custom message no longer plays and is instead replaced by one of the bell/chime sounds. The app in the marketplace is missing the ability to create custom messages too.

Other instances of the app still seem to function fine as long as I make no changes (i.e., they still play the custom messages). Anyone else seeing this issue and have a solution or workaround? I thought TTS was fixed.

Thanks!


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #2

I am seeing this as well. I am guessing this is related to the issues we are seeing on the platform since yesterday.


(Mike Maxwell) #3

Actually, I think the TTS code got commented out in error… Should get fixed eventually, in the mean time use RM it supports TTS, and you don’t end up with a bazilion app instances…


#4

What is RM? I also have the same issue

Thx


(Mike Maxwell) #5

Rule Machine, a community app.


(Bobby) #6

The ‘custom message’ is back on the stock marketplace app, but the TTS is at best randomly working. I use both RM and Notify with Speaker and messages work maybe half of the time.


#7

Yep - custom message did return on the marketplace app after working with SmartThings support. I was never able to get Rule Machine to recognize my Sonos. When I click on speech devices in the “send or speak” menu, it just says I have “no available options.” Have others been able to use their Sonos as a speech device in rule machine? I may need to browse the rule machine thread but haven’t had a chance. Thanks!


(Bobby) #8

Sonos is a “music device” in RM…


#9

Maybe I’m in the wrong area of rule machine, but I don’t see an option for “music device” in the send and speak action (see attached). Am I supposed to be in a different action?


(Bobby) #10

Hmmm, are you on the most recent version of Rule

Because you are missing another option under ‘On this speech device’. This is what I see on my phone:


#11

I’ll check to see if I’m on the latest version when I get home today. That could very well be the problem. Thanks for pointing that out.


(Kevin O'Donnell ) #12

I have the same issues using the Samsung R1 speaker. I can’t add or edit my custom messages. Other sounds work in Notify With Sound, just not custom messages. I really hope this gets fixed because my speaker really ties everything together and completes my setup. I looked into getting rule machine set up but it looks like it’s no longer supported?


(Ule) #13

Hi, you can use the mediaRenderer events, its a enhanced version of Speaker notify with sound, try it
Right now SmartThings TTS its not working, you must to use voiceRss, ivona or alexa, alexa not need to get an api key, but its slower, I suggest to sign with voiceRss its free and support 300 msg per day, try it

[Updated] Media Renderer Events, play messages, radio stations, tracks, sounds


(Kevin O'Donnell ) #14

Okay I’ll have to try that. I’ve been seeing media renderer all over the community site. I’ll just have to set it up. I don’t really want to have to go to my pc to set it all up but I’ll do what I have to do. I liked the speaker notify with sound was easy to use because it is already in the smartapp section on the ST mobile app. I wish they’d add these type of community apps to the smartapp section inside the mobile app. Anyways, I’ll give it a try. Does the Echo show up as a speaker that can be used to relay messages for events? That would be awesome


(Kevin O'Donnell ) #15

this doesn’t work with the Samsung R1 speaker. MediaRenderer won’t find the speaker unfortunately


(Kevin O'Donnell ) #16

Speaker Notify With Sound custom messages works now!! So excited!


(Ule) #17

Hi Mediarenderer Events works with every media player device, its and independent app , you dont need to install the media renderer device.


(Kevin O'Donnell ) #19

I’m guessing the reason when I select “play this track” and it says “you currently can’t add this” is because I don’t have a Sonos? I can’t select tracks for any of the music apps unfortunately.


(Kevin O'Donnell ) #20

Thanks for the reply! It wasn’t really clear to install the events code. I installed the connect code and was so confused why it wasn’t working. Well I’m going to mess around with this cool new app. Thanks!


(Jack R) #21

I’ve used this smartapp but it repeats the custom message four times. Anyone else have this problem? Any suggestions?