Sorry newbie.. Sonos Integration

Hi guys.

Just went from Future Home to SmartThings so everything is new to me. I am reading all i can now.
But for some reason I can not seem to add my Sonos speakers (Play 1s, Play 3, PlayBar)

I find this one several sites:

  1. From the Home screen, touch Menu
  2. Touch Supported devices
  3. Touch Sonos

But Sonos is not under supported devices in the apps.
What am I doing wrong?

I’m seeing them listed under speaker in the supported devices section

You can add them by tapping the + in the upper right of the home screen and choosing Add Device and then Sonos. Make sure your Sonos speaker is on the same local area network as your hub.

hmm… maybe I have another version?
This is what I see

lol…Thanks again.
But yes, this is What I see when I do that


And Sonos is not on the list…

The brand list is regional, so it may not be technically supported for your country. But its a LAN discovered device, so it may auto discover. Try choosing the Belkin Wemo brand and going through that setup and see if SmartThings happens to find your Sonos devices.

1 Like

Thanks Jimmy. Didn’t know that device support was regional.
But using Belkin didn’t work.
Any other tips?

Did you try the generic ‘Scan’?

I think it’s ‘Søk’ in the top right of your screenshot. Some people have reported that it gets to 60% through searching and then stops, but when they go back to their device list they see the new device. (Mine did this and the device was all the way at the bottom of the list)

You’ll want to make sure your SmartThings Hub and Sonos are on the same local network when doing the discovery.

Yes, tried the generic scan as well and that didn’t work either.
And yes, both the ST hub and my Sonos speakers are on the same network.

Just noticed that when I try to add devices in Smartthings Groovy IDE, Sonos is under devices!
Just added two of my speaker using IP address. If this work I guess I need to reserve these IP’s.

Still at work so I don’t know if this work yet but crossing my fingers

Bummer. I don’t think that Type in the IDE will work. The new one says websocket I believe.

Yes, you are right. It didn’t work :frowning:

Update: strange thing happened last night. Just bought a couple of Ikea Trådlos bulbs. While searching for these, suddenly ST found my Sonos speakers that were online!
I know this makes no sense, but it did. And I have tried and tried to search for the speakers several time before.
I have a couple of more of Sonos speakers that I connected after this, and ST can’t find these.
Guess I try to reset and add one of the Ikea bulbs again go see if this happens again lol

Nice! Don’t need to reset a bulb, just go through the steps of adding one.

Thanks :slight_smile: