Sonos One compatibility


(Robin) #1

Can I use Sonos One with SmartThings? Says nothing on the website.


#2

#3

(AaronW) #4

Sonos Play One works perfectly in my ST environment. No issues using the ST Labs - Sonos SmartApp.


(Ecallegari) #5

How about Sonos One. Not the Play 1. Has anyone figured out to get that to be discovered in Smartthings? I know Play 1 can eventually get detected but I cannot get my recently purchased Sonos One to attach. :frowning: looked around forum, hard to find any solution that is recent.


(AaronW) #6

You just need to ensure you have the Sonos updated to the latest version through the Sonos mobile app and then add the SmartThings beta smartapp. I have 6 loaded into ST.


(Ecallegari) #7

Thanks for the response prayerfuldrop. Sonos FWs and versions are up to date. I just signed up for the SmartThings beta program which maybe the only thing left to get it to work (do not have the beta app yet).

Regular SmartThings classic app is not finding it for me. (Already followed all the network advices, static IP, etc).


(AaronW) #8

That is odd. Did you go into the Marketplace, Things, SmartThings Labs, Sonos (beta) and activated there?


(Ecallegari) #9

Yes, tried the marketplace one and still no luck. Even added a new smartthings motion sensor to see if I get lucky and it detects Sonos One but that didn’t happen.

I’m switching wireless routers to a newer one in hope of enabling broadcast and uPNP to see if that makes a difference.

BTW, in process of all this, I’m getting the dreaded Smarttings hub going offline all the time :frowning: Going to have to reset that too.


#10

It should be in market place.

Marketplace —> things tab —> scroll to bottom smartthings labs —> last on that list should be sonos labs —> from there connect portion, and follow directions.

I’m not on any beta testing Stu and it’s in mine.

Hope this helps


(Ecallegari) #11

It works now. Turns out it was my old router which couldn’t enable uPNP and broadcasting (my guess). After changing to new router, it was discovered immediately. Didn’t even have to go to sonos lab nor did I have to make it a static IP (but I did later anyways).


#12

For the better experience of resuming music (Tunein radio) and text to speech. Keep your Sonos connect with ethernet cable all the time.

And if you ever restart your router, you need to delete your sonos from things and connect it with ethernet then re-add it to ST again.

This will make sure ST smart app works smooth with your Sonos for automation.