Sorry, but there was an unexpected error

Agreed, but… This is unfortunately exactly what will happen if Tech Support is flooded with manual customer emails as well.

Opening, classifying, prioritizing, routing, and responding to support requests takes a lot of effort. If thousands of customers report there relatively trivial issues, the cost or quality of support will be impacted.

Curious what is your source that IBM did this for years but it didn’t work.

I think there are plenty of proactive companies. I have contacted support for many companies and been told “We are aware of the issue and working on it.” Amazon Echo had been providing amazing support so far. I have been impressed with their level of response. Even to very specific issues in my setup.

2 Likes

I also installed the newer version (V2) of the Aeontec Home Energy Meter, and used a custom device type for it, and all our android devices started to give that error when “Things” were clicked (and a blank screen). It worked fine on our iOS devices though.

After talking and emailing with support for several days on this issue, we finally decided to test each device type and narrowed it down to the Aeontec device. By simply going to the Smartthings IDE site and logging in, then going to “My Devices”, and changing any devices you have using a custom device type to a “Smartthings supported” generic device type, you can determine which custom device type is the culprit. Obviously make this change on one device at a time until that error goes away on your android app.

What to do next is up to you. You can either keep that device on the standard supported device type, or continue to use the custom device type if that error message does not affect the overall functionality of the app. AFAIK, there is still no comprehensive solution to this.

HTH

I have made no changes to a setup that was working for weeks. First the preferences issue and now this issue. This is a problem with the server side changes they are making why would the next step be up to us ? If the error provided information about which device failed then we could debug an issue like this on our own. But an error this general is ridiculous. Every device I own has custom code and I have mostly custom smart apps. How am I supposed to debug this issue ? Since it is happening to so many people and we all started having the issue at the same time I think support should be handling this.

I should add that support replied to me that they are aware of the issue and investigating. They added that it doesn’t cause the app to crash so it wasn’t that bad an issue and that I should let them know if it was preventing me from doing anything. Given that the preferences issue which did in fact break everyone’s device code wasn’t fixed for a month I am not holding my breath for this one. :wink:

2 Likes

Whether we all report it or not, as listed previously in this thread, support is aware of it and HAS been aware of it for at least a week, yet no fix. Where’s the escalation path for $#!% that goes on for too long, and whose definition of too long do we use???

I work in IT as well, so what? You don’t need 500 tickets to tell you something’s down or not working correctly. A single report of an issue handled by the right resource can provide all the necessary information that there’s a problem. Fixing it may require completely different resources, but identifying that there IS a problem should not rely on hundreds of individuals

1 Like

@April is the primary escalation path.

I don’t know who sets the definition of “too long” or “too few tickets”. I presume there is some upper management of Tech Support and/or Operations (e.g., @Tyler1, as discussed in this referenced posting… below).

I seldom contact Tech Support … I’m glad they use email, but I just avoid the experience with all my vendors. The Forum is full of folks that express excellent experiences with SmartThing’s tech support. My personal experience is “good”, but not “excellent”. The flaw: There was no followup message confirming that my problem was resolved (whether by the actions I was told to take, or whether the situation was on ST’s end).

1 Like

We have @slagle now.

2 Likes

Excellent! (And excellent recruitment!).

1 Like

We do have me now.

But for reals… Let me give ya’all a little update.

We have a few tickets open for this right now at the engineering level. There was some action on it today in fact. I will continue to watch the ticket at update the thread here as I continue to gather information.

1 Like

I agree! he’s the perfect fit, and the best! We’re so lucky to have him!

3 Likes

This is where I am so going to miss my old Timmy dude! Now I have to think twice before blowing my lungs out of my mouth at ST since Tim, our chum is there! I am sad as well! :frowning: but I am sure he will help smarten up things! :slight_smile:

1 Like

Every time I click the Things button on the mobile app it gives me the error message “Sorry, but there was an unexpected error.” Probably happened with an update. I am on android. Changed phones recently and I still have this problem. Reset the app, cleared data everything except pressing the reset button on the hub. Really do not want to lose all my devices and recipes set up with my account.

I have seen that a lot too the last couple of days. No recent Android update, must be related to the platform.

1 Like

On iOS too. My dashboard crashed several times yesterday on things page.

Ditto - on Android. Restarting app seems to clear it for a while.

3 Likes

I’ve seen this on iOS as well.

Me six!

Yup, started a few says ago, sad thing is I’ve gotten so used to these things going all pear shaped, I hardly noticed…

1 Like

I too have begun seeing this a lot in the last few days. I’m on Android. Between this and the scheduler issues, I’ve been very unimpressed as of late. :disappointed:

We should let @April in on this issue. Did you enter a support ticket. I fired one off about an hour ago.