Sonos with Hub v2 (2015)

Is Sonos integration compatible with SmartThings Hub v2 (2015) hub? I’ve tried to add Sonos after having it setup in the Sonos app but the hub does not detect it. Starting to wonder if it’s not available in this version hub but can’t find anything verifying version compatibility or further troubleshooting steps.

yes, it works with the 2015 hub :slight_smile:

but which model of the speakers do you have and which generation?

1 Like

@jpk @jkp - cousins? - JK :upside_down_face:

Yes like @jkp said it works with the 2015 hub. There’s a new Sonos integration. If you’re using an old Sonos integration from the Classic app, delete it and set it up again using the new ST app.

I have Sonos One SL and play 1.

Lol cousins.

I don’t have a prior integration, trying to add it for the first time. Just times out.

Does Sonos need to be in a pairing mode? I’m following the add through the new app but no dice. Doesn’t find it.

Try this topic: Migration to New SmartThings app successful BUT app Sonos Broke (Fixed)

@RBoy thanks for that link. My speakers were never previously added, so not available to delete. Is there something else I should be looking at?

I can’t get it working either. The old system scanned the network and found them all - the new does… Nothing.

Ensure they are on the same network in your house. Then it should find them when adding.

1 Like

Thank you - that worked for me

No luck here. It’s fine if the Sonos are on V2 of the app I hope? And yes - same network.

@mprachar Anything in your router that would block your hub to Sonos communication in the network? I noticed in my firewall logs quite a bit of UDP and other broadcasts being blocked while it was on different network. Some firewalls or routers can filter host to host on same network so make sure there is free flowing traffic between


I have Sonos all over the place. STP is set up properly and actually works. I am able to cast from other devices to the Sonos Media renderers (Spotify Connect, etc.) My Google Assistant is connected to the Sonos speakers, and the old integration was working.

I guess what I a looking for is more info on how it’s supposed to actually work. The new instructions say to “power up” “the” Sonos speaker after beginning the search. That isn’t how Sonos works, but I’ve tried starting and stopping playback, as well as plugging them in during that time period. The search progress gets stuck at 60% each time.

I am hardwired and I use SonosNet, but that shouldn’t be a problem either.

I have emailed ST support - we’ll see what I get back.


I think this is the problem. The SmartThings Sonos integration is a LAN connection between the ST Hub and the individual Sonos speakers. I don’t think SonosNet exposes the individual speaks to your LAN in a way that works with the SmartThings integration.

Ugh. Well, I hope that isn’t true - since it’s the only good way to do it. Running Sonos on Wi-Fi is stupid if you have more than one or two units.

Thanks for chiming in - looking forward to what support has to say (assuming they say anything of course.)

1 Like

Hi Mark:

Did you finally find a solution? I’m experiencing the same problem with a v2 hub.