Sonos not found


I have a smarthings V2 hub and a Sonos S2 system. I have tried adding Sonos to smarthings but it won’t find it. The smarthings hub is hardwired and the Sonos is connected to a Netgear mesh WiFi. Has anyone had issues connecting Sonos to smarthings?

It used to work before I upgraded Sonos to the S2 version


I am not sure if it’s related, but recently I am having issues with my Sonos Play 5, when I tell my new Nest Hub Max to play music (which it should play on the default speaker as I have set it as the Sonos), it doesn’t play. Saying that, Sonos played fine on the previous Nest Hub that I replaced, so it looks a hit and miss.

However to bypass this issue, I plugged in a Chromecast Audio in the back of the Sonos and set that as the default speaker for Google and it works perfect.

re: Smartthings: I can still see it and control it from Smarthings (just now was the first time in my life I tried the pause and play button :slight_smile:) . Also, the voice announcements still work, albeit announcing them 5 mins later, but they do work.

The Sonos V2 upgrade didn’t cause me any issues, but saying that, at the time I was using the old classis app, so when I moved to the new app, my Sonos migrated with it.